WordPress 5.2 ベータ2

以下は、Gary Pendergastが書いた WordPress.org 公式ブログの記事、「WordPress 5.2 Beta 2」を訳したものです。

誤字脱字誤訳などありましたらフォーラムまでお知らせください


WordPress 5.2 ベータ 2がリリースされました。

このソフトウェアはまだ開発中ですので、本番サイトで使うことはおすすめしません。新しいバージョンを試すためにテストサイトを立ち上げることを検討してみてください。

WordPress 5.2ベータをテストする方法は2つあります。WordPress Beta Tester プラグインを使うか (「最新版ナイトリービルド」を選択)、ここから ベータ 版 (zip) をダウンロードしてください。

WordPress 5.2は4月30日にリリースされる予定です。そこにたどり着くために私たちにはみなさんの助けが必要です。ベータ1を試した皆さんからのテストやフィードバックに感謝します。あれから100のチケットがクローズされました。主な変更とバグの修正をご紹介します。

  • Emoji 12のサポートを追加しました!
  • 新しい wp_body_open() テンプレートタグ (と、それに付随するwp_body_open アクション) により、テーマ (そしてプラグインも) から <body> 開始タグ直後にコンテンツを追加できるようになりました。 (#12563)
  • ダイナミックブロックコンテンツで余計なパラグラフタグが間違って表示されないようになりました。 (#45495)
  • サイトヘルスチェックの画面でバグの修正、微調整、パフォーマンスの向上が行われました。
  • クラッシュプロテクションがプラグインの編集を妨げないようになりました。(#46045).
  • カスタムエラーハンドラーが正しく読み込まれるようになりました。 (#46069).

PHP の最低バージョンのアップデート PHP の最低バージョンのアップデート

WordPress 5.2ベータ2から、WordPress が必要とする PHP の最低バージョンが5.6.20になります。もし PHP の古いバージョンで運営している場合は 、WordPress 5.2 が正式にリリースされる前にアップデートすることを強くおすすめします。

トップ ↑

開発者の方へ 開発者の方へ

WordPress 5.2 は、WordPress を開発する体験をより洗練されたものにするための変更を数多く含んでいます。遅れないようにするため、Make WordPress Core ブログ を購読し、皆さんのプロダクトに影響を与えうるアップデートや変更に関する開発者向け文章に特別な注意を払っておいてください。

トップ ↑

協力するには 協力するには

英語以外の言語を話す方は、WordPress を100言語以上に翻訳するのにご協力ください。

バグを見つけたと思った場合は、サポートフォーラムのアルファ・ベータエリア(日本語) に投稿できます。情報をお待ちしています。もし再現可能なバグ報告を書ける場合は WordPress Trac に報告してください。既知のバグ一覧はこちらで見ることができます。


The wonderful thing
about betas, is betas
are wonderful things.