CloudFlare Flexible SSL

説明

Click For Full Implementation Guide.

Using CloudFlare’s Flexible SSL on WordPress isn’t as simple as just turning it on.

This plugin forms an integral part to enabling Flexible SSL on WordPress and prevents infinite redirect loops when loading WordPress sites under CloudFlare’s Flexible SSL system.

インストール

For full installation instructions, please review the following article: Installation Instructions.

FAQ

Installation Instructions

For full installation instructions, please review the following article: Installation Instructions.

Does this plugin affect non-SSL traffic?

No. It only comes into play when CloudFlare is serving HTTPS traffic from your site.

Should I change my WordPress Site URL to HTTPS?

No – there is no need. Use CloudFlare’s pages rules to redirect your visitors. You can then safely turn off SSL whenever you want from within CloudFlare and your WordPress site will still load on HTTP.

What happens if I disable this plugin AFTER enabling Flexible SSL on CloudFlare?

Your WordPress site will not load on HTTPS/SSL. You will create an infinite loop loading problem and the only way to solve this is to turn off SSL redirects within CloudFlare.

Does I need this plugin if I use CloudFlare FULL or Strict SSL?

No. It is designed only to assist with Flexible SSL.

評価

Wonderful

I didn’t even know Cloudflare’s SSL was causing the redirect loop until I installed this plugin. Thank you!

This is what you need

Using CloudFlare’s Flexible SSL on WordPress isn’t as simple as just turning it on.

This is true. I have spent hours on it, trying to use Cloudfare ssl for a domain name and subdomains, not achieving anything.

And then I installed this plugin.

Great!

It works on standalone site, but it’s not working on domain mapping multisite.

33件のレビューをすべて表示

貢献者と開発者

CloudFlare Flexible SSL はオープンソースソフトウェアです。以下の人々がこのプラグインに貢献しています。

貢献者

“CloudFlare Flexible SSL” をあなたの言語に翻訳しましょう。

開発に興味がありますか ?

コードを閲覧するか、SVN リポジトリをチェックするか、開発ログRSS で購読してみてください。

変更履歴

1.2.2

UPDATED: Supported WordPress Version to v4.5

1.2.1

FIXED: Checking to ensure certain data types

1.2.0

ADDED: The plugin will try to set itself to load first, before all other plugins.

1.1.0

UPDATED: Supported WordPress Version
UPDATED: Also works for any standard SSL Proxy scenario that uses HTTP_X_FORWARDED_PROTO – it doesn’t have to CloudFlare

1.0.0

First Release