このプラグインは WordPress の最新3回のメジャーリリースに対してテストされていません。もうメンテナンスやサポートがされていないかもしれず、最新バージョンの WordPress で使用した場合は互換性の問題が発生する可能性があります。

Disable jQuery Migrate

説明

A simple plugin to disable loading of jquery-migrate on the frontend due to a XSS vulerability of jQuery Migrate 1.2.1.
More details here: https://github.com/jquery/jquery-migrate/issues/36

It’s also one thing less to load where it counts.

Props to people in this thread: https://wordpress.org/support/topic/removing-the-default-jquery-and-migrate-from-the-header-in-last-version-of-wp?replies=6.

インストール

  1. Upload contents of the plugin zip file to the /wp-content/plugins/ directory
  2. Activate the plugin through the ‘Plugins’ menu in WordPress
  3. Profit

FAQ

Why is the jQuery-migrate needed?

There are still some dependencies in WP-Admin that require it to be present. Most up-to-date frontend code and plugins don’t require it however so theres no reason to load it there.

Can this break my site?

Yes, possibly. Some plugins on your frontend might count on jquery-migrate beign available

評価

2017年7月26日
No idea why wordpress doesn't allows to turn this annoying thing off - but this plugin helps instantly. Thank you!!!
2017年4月5日
It removes the jquery migrate javacript file. After installing you have to test your site (open your browser with firebug / debug - F12) to make sure you are not using old versions of jquery.
2件のレビューをすべて表示

貢献者と開発者

Disable jQuery Migrate はオープンソースソフトウェアです。以下の人々がこのプラグインに貢献しています。

貢献者

“Disable jQuery Migrate” をあなたの言語に翻訳しましょう。

開発に興味がありますか ?

コードを閲覧するか、SVN リポジトリをチェックするか、開発ログRSS で購読してみてください。

変更履歴

1.0

  • Initial version