このプラグインは WordPress の最新3回のメジャーリリースに対してテストされていません。もうメンテナンスやサポートがされていないかもしれず、最新バージョンの WordPress で使用した場合は互換性の問題が発生する可能性があります。

NovaSense

説明

Pre-emptive security platform that prevents hackers, infected hosts, spammers, DoS hosts and more from reaching your site with NovaSense threat intelligence.

The NovaSense threat feeds are IP addresses that firewalls, ADCs, and other systems can block to prevent attacks. These are made up of data collected from online, intelligence data from Nova WAFs, Aria WAFs, honeypots, and from Snapt threat lists. These feeds are then analysed, tested and augmented by the NovaSense threat engine to deliver intelligent threat feeds.

Block Categories

  • Threats – Threats are hosts that have attempted to exploit, brute force, or execute a denial of service attack. These are often compromised hosts, and can generally be blocked.
  • Abusers – Confirmed spammers, comment spam, link spam, abusive crawlers and other miscellaneous abuses. Typically safe to block, but can have false positives.
  • Malware – Systems that are infected with or involved in spreading malware and ransomware. Typically blocked on incoming firewalls but also useful on WordPress.
  • Botnets – Known botnet and C&C servers, a smaller list of confirmed active botnet systems to be blocked at all times.

Benefits

NovaSense adds an additional layer of security to your site by preventing known threats and attackers from sending requests to it, and reducing the amount of server load caused by spammer and DoS attacks.

Additionally, it cleans up a lot of comment spam from blocking known spammers and compromised hosts.

External Service Information

In order to lookup IP addresses to block this plugin sends a DNS lookup for each IP address to IP.rbl.novasense-threats.com. This is known as a DNSBL or RBL service. This service is run by NovaSense (the developers of this plugin) and terms and conditions are available on the site at https://novasense-threats.com.

スクリーンショット

  • The configuration page where you select what type of threats to block.
  • The block page that's shown to an attacker.

インストール

To install this plugin:

  1. Install the plugin through the WordPress admin interface, or upload the plugin folder to /wp-content/plugins/ using ftp.
  2. Activate the plugin through the ‘Plugins’ screen in WordPress. On a Multisite you can either network activate it or let users activate it individually.
  3. Go to WordPress Admin > Settings > NovaSense

評価

2020年11月11日
This is a much needed service in the Wordpress space - thanks!
1件のレビューをすべて表示

貢献者と開発者

NovaSense はオープンソースソフトウェアです。以下の人々がこのプラグインに貢献しています。

貢献者

“NovaSense” をあなたの言語に翻訳しましょう。

開発に興味がありますか ?

コードを閲覧するか、SVN リポジトリをチェックするか、開発ログRSS で購読してみてください。

変更履歴

1.2

  • Date: 2020/08/15
  • Updates to the readme, assets.

1.1

  • Date: 2020/08/14
  • Fixed an issue with the plugin hook name.

1.0

  • Date: 2020/08/13
  • First release of the plugin.