サポート » インストール » 「自動アップデート」ができません。

  • 解決済 yalexm

    (@yalexm)



    WordPress v2.7.0を利用しております。
    インストール後の動作は問題ありませんが、管理モードに入ると、
    WordPress 2.7.1 が利用可能です ! アップデートしてください。」と出ているので、実行しようとすると、以下のようなメッセージが出てアップデートできません。
    ////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    http://wordpress.org/wordpress-2.7.1.zip からアップデートをダウンロードしてます

    ダウンロードに失敗しました。: 一時ファイルを作成できませんでした

    インストール失敗
    ////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

    フォーラムとweb検索で似た事例などを探しましたが、どこにも見あたりません。(私が探せないだけかもしれませんが・・・)

    レンタルサーバーはスッテプサーバー(stepserver)
    Apache v1.3.41
    PHP v4.4.1
    Mysql v4.1.1.8

    で動作しています。

    ステップサーバーのヘルプも読み、色々と試してみましたが、どこをいじっていいのかわからなくなってきました。
    パーミッションの変更か、ディレクトリをどこかに作成すれば良いのか、行き詰まってしまいました。
    どなたかおわかりの方がいらっしゃいましたら、教えて下さい。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • ステップサーバーはセーフモードらしいので、自動アップグレードは不可です。
    http://stepserver.jp/func/cgi/php.html

    あらかじめディレクトリ等を作っておけばいけるかもしれませんが、今のところ情報および動作報告は無いようです。

    php-webさん、ありがとうございます。
    セーフモードなので無理なんですね。納得致しました。
    お手数かけました。

    ステップサーバーから回答が来たので今後の参考になればいいかな。

    PHPのセーフモードにつきましては、サーバーのセキュリティの都合上
    この機能をはずす事はいたしかねます。
    (セーフモードオフの場合、他のユーザーの方からお客様コンテンツ
    及びプログラム類の閲覧が全て可能になってしまうためです)
    ご了承いただけますようよろしくお願いいたします。

    yalexmさん、php-webさん、こんにちは。

    あらかじめディレクトリを書き込み可で作成しておく方法について、XREA で動作確認しました。
    手順を 日本語Codex に書きましたので、よかったら試してみてください。

    WordPress Codex 日本語版 » セーフモードによる制限と対処方法

    また、リンク先の「方法2」は XREA とコアサーバーでの対処方法ですが、
    ステップサーバーでも特定の PHP スクリプトを CGI モードで動作させる方法があるなら、update-core.php を CGI モードにするだけで自動アップグレードが実行できるかもしれません。

    # トピックのタグが3つ繋がってしまっているので、直せたら修正お願いします。半角カンマ(,)で区切れます。 😉

    モデレーター IKEDA Yuriko

    (@lilyfan)

    PHPのセーフモードにつきましては、サーバーのセキュリティの都合上
    この機能をはずす事はいたしかねます。

    PHP6 ではセーフモードが廃止されるんですが、そのときはどうするつもりなんでしょうね??

    そもそも、セーフモードを on にしてても、他人のファイルにアクセスする方法はいくらでもあるので、有効にする意味はあまりないと思います。むしろ、CGI 動作かつ suEXEC した方が、「他人のファイルをいじれない」対策には有効のはずです (ただし、CGI にすると負荷が上がってしまいますが)。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「「自動アップデート」ができません。」には新たに返信することはできません。