サポート » 使い方全般 » 「get_settings の使用はバージョン 2.1 から非推奨になっています! 」とNotice

  • 解決済 mrs-piggy

    (@mrs-piggy)


    突然トップページに「get_settings の使用はバージョン 2.1 から非推奨になっています! 代わりに get_option() を使ってください。 」というNoticeが出るようになりました。funcition.phpの指定されたlineには特に問題がないようなのですが、他に何の原因が考えられるのでしょうか?プラグインはすべて停止にしてみましたがエラーは消えませんでした。
    お分かりになる方、ぜひ解決法を教えてください。よろしくお願いします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • こんにちは

    突然トップページに… Noticeが出るようになりました。

    WordPressの設定の前に、サーバーの設定で、エラーをディスプレイに表示する設定になっていませんか?

    display_errors:offにしても出ます。
    error_reporting:0にしてみましたが、やはりエラーが出たままです。

    index.phpにget_settingsを見つけたので、これをget_optionに変更したら無事エラーが消えました。お騒がせいたしました・・・

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「「get_settings の使用はバージョン 2.1 から非推奨になっています! 」とNotice」には新たに返信することはできません。