サポート » テーマ » 「Lightning」のトップページスライドショーが反映しません

  • 解決済 emplanning

    (@emplanning)


    はじめて投稿します。

    ワードプレス超初心者で、この度初めてワードプレスを使ってサイトをアップすることになりました。
    ページ作成を進めていたところ、トップページのスライドショーが、画像を登録したにもかかわらず反映しません(PC・スマホともに)。

    またカスタマイズ画面でいったん保存したにもかかわらず、次にまた開けると保存できずに前の画面に戻っています。

    解決方法をどこに聞いてよいかわからず、このページにたどり着きました。

    大変申し訳ございませんが、どなたか教えていただけますでしょうか?

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • ちなみにページは 
    http://www.tyokuhan.jp/contents/
    です。
    (まだ作成途中ですが)

    메텔

    (@digitmaetel)

    ありがとうございます。

    そうなんです。カスタマイズページから「保存して公開」ボタンを押しても

    画像が登録できないのです。

    でもってこのスライドショー自体外そうと思っても、外し方がわからないのです。

    메텔

    (@digitmaetel)

    拡張プラグインに設定があるのか、スライドショー自体を非表示にするにはスタイルシートで隠すか、PHPで調整するしかないようですね。
    拡張プラグインをインストールしていないので判りませんが、動作は問題ありません。
    http://wp.me/P5ZPvS-b

    画像自体がアップロードできていないのではないでしょうか。

    記事の画像ファイルは問題なくアップロードできているようですね。
    今表示されていない、top-1.jpgなどの画像ファイルは以前、登録していたけれど今は消した画像で、他の画像に変えようとされているという認識で合っているでしょうか。

    スライドショーの画像の設定はデータベースのwp_optionsテーブルに保存される様子です。
    そこにあるレコードがうまく更新できていないようなのですが、全てのテーマオプションが更新できないのでしょうか?
    試しに
    「Lightningデザイン設定」
    でキーカラーを変更したりはできるでしょうか。
    (デフォルトに戻せますので、安心して別の色に変更して保存し、ボタンやラインの色が変わったかを確認してください。)

    他の項目の更新ができないのであれば、テーマを有効にした際などにテーマオプションを保存するレコードがうまく作成されていない可能性があります。
    一旦、テーマを削除し、インストールしなおしてはどうでしょうか。

    それでも解決しない場合、テーマを作成された方のフォーラムがあります。
    https://wordpress.org/support/theme/lightning
    日本人の方ですので、日本語も通じるようです。

    熊本地震東区避難所92日目 様
    有難うございます。画像自体はアップロードできていると思うのですが・・・
    (メディアの中には入っています)

    HP拝見しました。うまく作動していますね。
    PHPはうまくさわれる自信がないので・・・最終手段にします。
    スタイルシートで無理やり隠すのも一つの方法ですね。
    有難うございます。

    munyagu 様

    有難うございます。

    今表示されていない、top-1.jpgなどの画像ファイルは以前、登録していたけれど今は消した画像で、他の画像に変えようとされているという認識で合っているでしょうか。

    → いえ、最初のうちはうまく表示されていたのですが、ワードプレスの更新をしてから(現在バージョン4.5.3)反映しなくなったように思います。
    以前と同じ画像でいいので写ってほしいのですが。

    全てのテーマオプションが更新できないのでしょうか?

    → ほかのテーマに変更してみました。やはりそこでもカスタマイズの保存ができず更新できませんでした。

    キーカラーを変更したりはできるでしょうか。

    → できませんでした。

    一旦、テーマを削除し、インストールしなおしてはどうでしょうか。

    → 削除して再インストールしたのですが同じ結果でした。
      やはりワードプレス自体のインストールがおかしかったのでしょうか・・・

    テーマを作成された方のフォーラムがあります

    → 有難うございます。そちらでも問い合わせしてみます。

    いろいろ解決策を教えていただき有難うございます。

    もう少し粘って解決してみます。

    메텔

    (@digitmaetel)

    WordPressの更新で不完全だったかもしれませんよ

    そうなんです。それが一番あり得るかもしれません。

    そうだった場合はどうしたらよいのでしょうか。

    메텔

    (@digitmaetel)

    手動で更新が一番確実です。
    とにかくWordPress自体の更新は数千のファイルがあるので、転送、解凍の間で欠損が起こりやすいですから。

    ファイル数は多いには多いですが、数千はない模様です・・・4.5.3-jaで1378ファイルですね。

    $ ls
    wordpress  wordpress-4.5.3-ja.zip
    $ find wordpress -type f | wc -l
    1378

    返信が遅くなってすみませんでした。
    手動更新・再インストールなどいろいろ試したのですが、結局解決せず・・・。

    だったのですが、先ほど「一度プラグインを全部切ってみよう」と思い試したところ
    ようやくカスタマイズの保存が可能となり、スライドショーも動くようになりました。

    その後インストール済みのプラグインをすべて有効化しても、きちんと動いています。
    問題は解決にはなっていませんが、とりあえずこのまま行こうと思います。

    いろいろ教えていただいた方々、本当に有難うございました。
    これからまだまだ問題にぶち当たっていくと思います。
    またぜひご指導くださいますようお願い致します。

    메텔

    (@digitmaetel)

    プラグインは全停止で、相談するようにしてください。
    相談の多いテーマには、それぞれサイトに使って運用してますが、すぐに検証できるように全停止できるようにしています。

    今回、プラグインを全停止して読み込み直したことで、読み込み順番が整合されて不具合が解消したのかもしれませんね。途中でプラグインを試したり削除したりしてたのではないでしょうかね。

    すみませんでした。
    次回からプラグインを全て停止してから相談するようにします。

    あとおっしゃられるように、プラグインを途中で試したり削除したりしていました。
    結局何のプラグインが影響していたのかもわからず。

    何卒今後とも宜しくお願いします。

14件の返信を表示中 - 1 - 14件目 (全14件中)
  • トピック「「Lightning」のトップページスライドショーが反映しません」には新たに返信することはできません。