サポート » テーマ » 『raindrops』の中の【高度な設定】にて変更していたところ不具合が・・・

  • 解決済 kenjis1969

    (@kenjis1969)


    『raindrops』⇒カスタマイズ⇒【高度な設定】⇒『フッタークレジット』
    というところでフッタークレジットを変更したところ、サイトのテキストがリンクテキストも含め、全て真白になってしまいました。(個別に色を付けていたテキストを除く)
    このとき、文字が真白になったのは、PC画面のみでスマホでの表示には問題ありませんでした。

    テーマを他に変えるとPCでも正常に見られるのですが、raindropsだとやはりテキストが全て真白の状態になってしまいます。

    今回は、取り急ぎの対策として
    【カスタマイズ】⇒【色】⇒【カラー設定】
    の中の『自動カラー設定』から『カスタムカラー設定』に変更し、それぞれのフォントやテキストに色を付けることで急場をしのいでいますが、原因と解決策が見つかりません。

    ちなみに、CSSなどは特にいじっていません。

    今回の事案、私の場合は、たまたま『フッタークレジット』を更新した直後にそうなったので、こういう書き方をしてますが、正直、カスタマイズのどの項目をいじっても、こうなってしまっていたんではないか・・・という感触ですので、一概に『raindrops』の問題かというとそうでもないような気はします。

    今のままでも問題はないと言えばないのですが、根本的な解決策にはなっていないように思えるので、どなたか原因と解決策のアドバイスいただけませんか?

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • 失礼しました。

    正しくは『raindrops』ではなく、wordpressで『raindrops』をテーマに選ぶとカスタマイズの項目に出てくる【高度な設定】です。

    こんにちは
    お手数をおかけしますが、再現テストをしたいと思いますので
    カスタマイザー / 外観 / 配色 で何が選択されているか?

    フッタークレジット欄は、html要素の制限があるのですが
    ( 使用できるhtml要素はaddress, span, a, br,img, %current_year% (この記述は、現在の年西暦4桁に置換されます )

    白くなってしまうのは、テキストでしょうか?それとも、リンクや特定のタグ内の文字ですか?

    配色と、フッターテキストの問題点の詳細を教えていただけませんか?

    • この返信は7 ヶ月、 1 週前に nobita さんが編集しました。

    >カスタマイザー / 外観 / 配色 で何が選択されているか?

    ベースカラーで#0067C0
    配色タイプはw3standard

    >フッタークレジット欄は、html要素の制限があるのですが
    ( 使用できるhtml要素はaddress, span, a, br,img, %current_year% (この記述は、現在の年西暦4桁に置換されます )

    Copyright © %current_year% streetsnap-japan.com All Rights Reserved.

    と記載しています。
    実は画面の真ん中に置きたくて、Copyrightの前の部分にスペースを入れていたのですが、ちょっとずれてるな・・・ということで、もう少しスペースを増やそうということでスペースを入れて更新をしたのがキッカケでした。

    >白くなってしまうのは、テキストでしょうか?それとも、リンクや特定のタグ内の文字ですか?

    ほぼ全ての文字です。固定ページ・投稿ページ・テキスト・リンク・タグ・ウィジェットなどのサイドバーなどの全ての文字が白文字になってしまいました。
    例外として、ウィジェットのタイトル・・・これは自分でタイトルを決めたものも空欄にして自動的に入る文字も、白文字にはなりませんでした。
    それと、HTMLで色を指定した場合は、指定した色でそのまま残っていました。

    現在は、『カスタマイズ』⇒『色』⇒『カスタム設定』にてカスタムカラー設定
    フォントカラー#000000
    リンクカラー#1e73be
    リンク色の補色を投稿タイトルに適用:いいえ
    フッターテキスト#000000
    にしていますが、
    現状が起きたときは、カラー設定は『自動カラー設定』にしていました。
    今はこの設定で以下のようになっています。

    詳細な情報ありがとうございます。

    再現が出来ました。

    取り急ぎ、原因部分は、カスタマイザーで配色のラジオボタンが変更された時に、それぞれに対応した値をセットする部分が正常に動作していないために発生しているようです。

    諸般の事情により、少し時間をください。

    実は画面の真ん中に置きたくて、Copyrightの前の部分にスペースを入れていたのですが、ちょっとずれてるな・・・ということで、もう少しスペースを増やそうということでスペースを入れて更新をしたのがキッカケでした。

    既に対応済みのようですが、この部分に関しては、全体をaddress要素でラップしていただいてもいいかと思います。

    • この返信は7 ヶ月、 1 週前に nobita さんが編集しました。
    • この返信は7 ヶ月、 1 週前に nobita さんが編集しました。

    Raindrops1.422がライブになっていると思います。

    今回の問題をHotfixしたものです。アップデートしていただき、動作を試してみていただけるとうれしいです。

    ご指摘の問題は、WordPress4.6のアップデートで、コアのクラス名が変更になり、カラータイプ毎のプリビュー画像が表示できなくなる問題と(1.421でfix)関係しているようで、jQueryを使って、カラータイプのラジオボタンが変更された場合に フォント色 リンク色を連動して変更する処理を行っていたのですが、クラス名が変わってうまく動作しない状態になっていました。(なので、最初にセットされるdarkの色が、そのまま維持されて真っ白になっていたものと考えています)

    こちらでは、正常に動作していますが、何かありましたら教えていただきたいです。

    kenjis1969

    (@kenjis1969)

    確認しました。残念ながら、
    アップデート後、カラー設定を自動カラー設定に変更しましたが、症状は変わりませんでした。
    プレビュー画面では、上手くいったように見えたのですが、実際の画面は以前と同じ症状のままで、やはりテキストやリンクテキストが白文字になってしまいました。(スマホは影響なし)
    なので、現在はカスタムカラー設定にしてあります。

    実は、こちらのページを見ていただきたいのですが、(https://www.nailsnap.com/)
    こちらは逆にリンクテキストが真黒なのです・・・

    >カスタマイザー / 外観 / 配色

    ベースカラー#f466ed

    ピンクにしてあるだけで、前述のサイトと設定は全く同じですが、真逆の症状が出ています。

    この症状はずいぶん前から実は出ていたのですが、スマホ画面では影響がなかったので放置していました。
    (ああ、こういう設定になったんだな・・・くらいにしか思っていませんでした・・・)

    実を言うと、streetsnap-japan.comも・・・以前はリンクテキストを含め真黒・・・だったのをカスタムカラー設定でリンクテキストだけ青に設定して、ごまかしていたのですが、なぜか前回のテーマの更新でテキストやリンクテキストが真っ白になっていて、カスタムカラーから自動カラー設定に戻ってしまっていたのをカスタムカラー設定に直したというのが正直なところです・・・

    CSSなどの編集や自分なりのカスタマイズというものを一切行っていないし、素直に使っていたため、そのうち誰かトピック上げてくるだろう・・・と思っていたのですが・・・

    それと、気になる点がもう一つあったのですが、二つのサイトはそれぞれ違う時期にWordPressをインストールしていて、最初にインストールしたバージョンが違います。

    https://www.streetsnap-japan.com/ ⇒ バージョン 2.8.2
    https://www.nailsnap.com/ ⇒ バージョン 3.5-ja-jetpack

    二つのサイトの違いと言ったら、これくらいしか見当が付きません・・・

    nobita

    (@nobita)

    確認しました。残念ながら、
    アップデート後、カラー設定を自動カラー設定に変更しましたが、症状は変わりませんでした。

    カスタムカラー設定 で一応対応済みの様子なので、無理にいろいろ設定を変更していただく必要もないかもしれないと思いますが、

    気持ち悪いという事でしたら、カスタマイザーの 高度な設定 「テーマ設定のリセット」を行ったうえで、再設定していただくと たぶんうまく動くんじゃないかと思ったりしているのですが、実験可能なサイトをお持ちでしたら 試してみてください。

    リンク色が、ブルーになったり黒になったりしている件ですが、これはたぶんRaindropsのアップデートの影響で発生していると思っています。

    Raindrops1.303のアップデートで、リンク色のデフォルトカラーの設定を追加しています。これは、テーマを査読してくれているレビュアーという人たちがいるのですが、その人たちの議論の中で、リンク色などはデフォルト値を持つべきだという話があって、それを受けて、アップデートした機能なのですが、その実装がとっても面倒で難しかったものですから、カラーのデフォルトが大部分で白か黒かといった単純な色で設定していました。 

    このため、ある時期から後にインストールしたもので、自動配色を使っていると ブルーだったリンクが黒に変更され、それ以前から使っているものは、ブラウザの標準リンク色のブルーが適用されているために起きている現象のように考えています。

    ワードプレスも常にどんどん変更がありますし、それに応じていろいろ変更を行ったりしているので、お手数ではありますが、リンク色の変更など利用者の手を煩わせる場面も少なからずあると思いますが、よろしくお願いします。

    恥多きテーマですが、今後ともよろしくお願いします。

    追伸

    カラータイプ w3standardのデフォルトのリンク色 黒のままだと申し訳ないので、コードのメンテナンスのついでに デフォルトリンク色をスタンダードな#0000EEに変更しておきます。( 次回のアップデートでご確認ください )

    ご協力ありがとうございました。

    • この返信は7 ヶ月前に nobita さんが編集しました。
    kenjis1969

    (@kenjis1969)

    ありがとうございます。

    カスタマイザーの 高度な設定 「テーマ設定のリセット」を行ったうえで、再設定

    というのを試してみました。
    https://www.streetsnap-japan.com/ に関しては、やはり改善されません。
    プレビュー画面上は正常に戻ったように見えるのですが、実際webサイトを開いてみると、テキストは変わらず白のままでした。(https://www.nailsnap.com/ は問題ないようです)
    仕方ないのでしばらくは、自動カラー設定はあきらめてカスタムカラー設定で行こうと思います。

    nobita

    (@nobita)

    結果を連絡いただきありがとうございます。

    原因を捕捉できない不具合というのは、テーマをメンテしていると時々あり、ずーとメンテを続けていく中で ある時ポンと原因がはっきりするといった事もあります。

    今回のご指摘で、コア4.6での、Raindropsのバグを発見することが出来ました。手当としては、「これなら動作する」程度の事で、安定性や確実性は確認できていませんが、最悪の結果は、回避できたと考えています。

    今後のアップデートで、このあたりの動作確認をより多くチェックしていきたいと考えます。

    ご協力に感謝します

    kenjis1969

    (@kenjis1969)

    問題の解決には至っていませんが、原因と対策また現状どのようにするのかという方向性がはっきりしたということで、いったんこのトピは解決済みとして閉じます。

    ありがとうございました♪

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。