サポート » バグ報告と提案 » このブロックでエラーが発生したためプレビューできません

  • 解決済 Hironari

    (@hrnr)


    始めまして。
    こちらに投稿するのは始めてなので情報が不足していたらご指摘お願いします。

    表題の件ですが、以下のフローで再現するのですが、バグとしてみなしてよいのでしょうか。
    すでにバグとして報告されているのであれば良いのですが。

    実際に現れた環境としては以下になります。
    WordPress バージョン 5.2.2–ja
    Edit Author Slug バージョン 1.6.0
    Really Simple SSL バージョン 3.2.2
    SiteGuard WP Plugin バージョン 1.4.3
    WP Multibyte Patch バージョン 2.8.2

    フローは以下になります。
    1.ブロックの段落を選択する
    2.文字を入力する
    3.HTMLとして編集するを選択する
    4.クラスの書き方を間違える(<span class= "" "">のような書き方で敢えて間違えます)
    5.フォーカスをはずせばエラー発生いたします。

    一応私自身がブログで取り上げています。
    画像と共に上げていますので参考にしてください。
    https://fullstackengineerfrombeginner.com/wordpress-cant-preview-for-error-how-to-fix/

    似たような事例として、5,6ヶ月前に私と同じ状況になった人がいるようですが、環境に問題があったので解決したとのことでした。

    ですが、ブロックエディタの記述の仕方でこのエラーが再現するのは、ちょっとおかしいかなと思って投稿させていただきました。

    以上になります。
    書き方など不明瞭な点がございましたらご指摘お願い致します。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • 連続で、失礼致します。

    今、同じ操作を行った所、上のような事象はおこっていませんでした。
    きちんとhtmlのブロックを直せるようになっておりました。

    冒頭で述べました
    WordPress
    Really Simple SSL
    のバージョンが一つ前のバージョンのために発生していました。
    これらは共に直近2週間以内に更新されています。

    おそらく、いずれかの影響で本事象が引き起こされたのだと思います。
    現在はこの事象は起こっていません。

    お騒がせいたしました。
    本件は最新のバージョンですでに解決済みの問題でした。

    以上です。

    本当に何度も何度もすみません。。

    上記の件なのですが

    WordPress 5.2.2を新しくインストールし、プラグインを全て削除して動作させて同一の操作を行った場合、やはり再現いたします。

    解決済みではありません。本当に申し訳有りません。

    『HTMLとして編集する』は使ったこと無かったのですが、試してみたところ、
    htmlのミスの仕方によって、表示が異なるようです。↓

    本来は、常に『解決』というボタンが出るのが好ましいように思います。

    プレビューできません。で止まったもの
    <p><sapn class="" ""="">afew</sapn></p>

    『解決』が表示されたもの
    <p><span>wfww<ps></p>

    ありがとうございます。

    どうやらバグみたいなのでGitHubのグーテンベルクの開発チームに問題としてあげておきました。
    現在このようなプレビューできない=ユーザー体験を損なわないような修正がちょうど行われていました。

    将来的には直るとは思いますが、いつかは未定です。

    以上になります。
    とりあえず、このトピックはクローズさせていただきます。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • このトピックに返信するにはログインが必要です。