サポート » 使い方全般 » さくらのレンタルサーバーで固定ページが全て404

  • 解決済 kurita83

    (@kurita83)


    こんにちは。

    以下の仕様のローカル環境から、さくらのレンタルサーバーにアップロードしたところ、固定ページが全て404になってしまいました。
    他のフォーラム内容も確認しましたが、解決できなかったので、解決策をお分かりになる方がいらっしゃいましたらご教授頂けないでしょうか。

    【ローカル環境】
    Apache 2.4.10
    PHP 7.3.2
    MySQL 5.6.34
    Wordpress 5.2.3

    【さくら環境】
    Apache/2.4.41
    PHP 7.3.9
    MySQL 5.7

    パーマリンク設定を「基準」に戻すと表示されますが、本来選択したい「投稿名」を再度選ぶと、再び404になってしまいます。

    プラグインは現在すべて停止し、テンプレートはデフォルトの「Twenty Seventeen」に設定しています。

    キャッシュクリア・複数ブラウザ(Mac Chrome / safari / Firefox)で試しても状況は同じでした。

    なお、「.htaccess」の中身は以下のようになっています。

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    以下の投稿も見つけて内容は確認しましたが、解決できませんでした。(当方の環境ではhttpd.confをさわれません。PHPのエラーログを保存するようにしましたが、エラーが出力されません。)
    https://ja.wordpress.org/support/topic/%e3%82%b5%e3%82%a4%e3%83%88url%e5%a4%89%e6%9b%b4%e5%be%8c%e3%80%81%e3%83%aa%e3%83%b3%e3%82%af%e5%85%88%e3%81%8c404-not-found%e3%81%a8%e3%81%aa%e3%82%8b/

    以上、解決策をご存知の方いらっしゃいましたら、お力貸して頂けないでしょうか。
    宜しくお願い致します。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • CG

    (@du-bist-der-lenz)

    ローカル環境の時とドメインは同一でしょうか。404になるのは固定ページだけですか、投稿ページでは起こりませんか。「.htaccess」を作りなおしてもかわりませんか。

    CG様
    返信ありがとうございます。

    ローカルと本番でドメインは異なります。
    DBを一式本番環境にインポートした後、「Search-Replace-DB-master」というものを使ってドメインを一式変更しています。

    404になるのは固定ページだけです。
    ホーム / 投稿一覧 / 個別記事ページは正常に「ドメイン/投稿名/」で表示されています。

    宜しくお願い致します。

    CG

    (@du-bist-der-lenz)

    URLに/index.php/を挿入してみましたか

    CG様

    /index.php/を挿入したら表示されました!
    ありがとうございます!

    ただ、index.phpがない方がスマートなのでできれば挿入したくないのですが、解決策お分かりになりますでしょうか?

    CG様

    補足を記載し忘れていました。

    同じディレクトリにリニューアル前のindex.htmlが残っている状態です。

    この問題がクリアになり、デザイン切り替え後は削除しますが現在はまだ残しておきたいです。

    宜しくお願い致します。

    同じディレクトリにリニューアル前のindex.htmlが残っている状態です。

    さくらレンタルサーバのデフォルトの設定は、index.php より index.html が優先されるように設定されているようです。
    https://help.sakura.ad.jp/hc/ja/articles/206054622–htaccessによるアクセス制御#09

    ishitaka様

    ご返信ありがとうございます。

    また私の補足が漏れており大変申し訳ありませんが、以下2つの方法でindex.phpを読みに行くように設定を変更しても、http://www.ドメイン名/投稿名/での固定ページアクセスが404になってしまう状態です。

    1:htaccessで優先順位を変更し、index.phpを読み込ませる
    2:index.htmlをリネームして、index.phpを読み込ませる

    解決しました。

    情報をググっているなかで、以前にも確認した以下のページに再度たどり着きました。
    https://teratail.com/questions/67861

    もともとサーバーにあったhtmlファイルの名前と、固定ページのスラッグがに同じものが多いので、今一度上記ページにある「Options -MultiViews」をhtaccessの1行目に加えてみたところ、index.phpをつけない状態でも404が表示されなくなりました。

    問題にぶつかって早いタイミングで確実にこの設定は一度試したのですが、その時は改善しませんでした。

    もしかするとその時はまだキャッシュが残っている等の問題で改善しなかったのかもしれませんが、今回は意図した通りの表示になりました。

    CG様、ishitaka様
    初めてのケースで、ネットの方法をあれこれ試しても解決できずに途方に暮れておりましたが、お二方に知恵を貸して頂いたお陰で今一度冷静になり、解決することができました。
    忙しい中お力を貸して頂き、誠にありがとうございました。

    CG

    (@du-bist-der-lenz)

    「/index.php/を挿入して試してもらったのは、問題点を確認するためでした。『固定ページでのみ起こっている』ことなので、次の段階が見えたので、元に戻してください、」と午後7時に返信しようとしたところ、ハプニングで中断しました。糸口が見つかってよかったです。安心しました。

    CG様

    ご丁寧に返信までして頂き、重ねてお礼申し上げます。
    本当にありがとうございました。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。