サポート » 使い方全般 » アイキャッチ画像が設定できない

  • 解決済 mizugamiyuki

    (@mizugamiyuki)


    functions.phpにadd_theme_support( ‘post-thumbnails’ );を記述しているのに投稿の管理画面でドキュメントパネルにアイキャッチ画像の設定タブが表示されていません。

    昨日は表示されており設定もできました。
    設定した投稿はアイキャッチ画像の編集はできませんが設定自体は残っております。

    解決方法や原因にお心当たりがある方がいらっしゃいましたらご教示いただけますと幸いです。
    よろしくお願いいたします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • @mizugamiyuki さん、こんにちは。

    functions.phpにadd_theme_support( ‘post-thumbnails’ );を記述しているのに

    とありますが、自作のテーマか何かでしょうか。もう少しご利用のテーマの情報等提示されると回答が付きやすいと思われます。もし公式のテーマをご利用中でテーマファイルを直接編集されてしまっているようであればアップデートで記述が消えてしまっている可能性もありますので念のためご確認ください。

    ご参考になれば。

    トピック投稿者 mizugamiyuki

    (@mizugamiyuki)

    @shokun0803

    こんにちは。
    アドバイスありがとうございます。

    自作テーマになります。

    shokun0803

    (@shokun0803)

    mizugamiyukiさん、こんにちは。

    自作テーマであるとのことですので、最初に functions.php を設定後に何らかの設定追加等を実施してアクションの実行順が変更になってしまったりしていないか、実際にコードが有効になっており実行されているか確認されてみることをお勧めいたします。

    あまり考えにくいですが管理画面の投稿のオプションでアイキャッチ画像の表示にチェックが入っているかも念のため確認されてみてはいかがでしょうか。

    ご参考になれば。

    トピック投稿者 mizugamiyuki

    (@mizugamiyuki)

    function get_current_link() {
    return (is_ssl() ? 'https' : 'http') . '://' . $_SERVER["HTTP_HOST"] . $_SERVER["REQUEST_URI"];
    }
    
    remove_filter('the_content', 'wpautop');
    
    remove_filter('the_excerpt', 'wpautop');
    
    function Include_my_php($params = array()) {
    extract(shortcode_atts(array(
    'file' => 'default'
    ), $params));
    ob_start();
    include(get_theme_root() . '/' . get_template() . "/$file.php");
    return ob_get_clean();
    }
    
    add_shortcode('myphp', 'Include_my_php');
    
    add_post_type_support( 'page', 'excerpt' );
    
    remove_filter('the_excerpt', 'wpautop');
    remove_filter('term_description','wpautop');
    
    remove_action('wp_head','wp_generator');
    
    add_theme_support('post-thumbnails');
    
    
    add_filter( 'excerpt_length', function( $length ){
    return 300;
    }, 999 );
    
    add_filter( 'excerpt_more', function( $more ){
    return '…';
    }, 999 );

    shokun0803

    こんにちは。
    いつもありがとうございます。

    functions.phpに記述しているのは上記が全てです。
    他の記述を削除したりして確認してみましたが表示されなかったです。
    また管理画面の投稿のオプションでアイキャッチ画像の表示にチェックが入っているかの確認ですがそもそもチェックボックスが表示されていない状況です。

    Aki Hamano

    (@wildworks)

    こんにちは。

    Tweny Twenty four, Twenty Twenty-Oneなどのデフォルトテーマに変更した時もその問題は再現しますか?

    トピック投稿者 mizugamiyuki

    (@mizugamiyuki)

    Aki Hamano

    こんにちは。

    アドバイスありがとうございます。
    お教えいただきましたデフォルトテーマに変更したところ問題は発生しませんでした。
    そして自作テーマに戻そうとしたところstyleシートがないとのことで戻せませんでした。
    そのため自作テーマに一旦styleシートをアップしたところアイキャッチが表示されない不具合が解消いたしました!!!

    貴重なアドバイスありがとうございました!

    大変助かりました。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • このトピックに返信するにはログインが必要です。