サポート » インストール » アップグレードしたらテキストエディタが使えない

  • 解決済 rurucop05

    (@rurucop05)



    4.9.4にアップグレードしたところ、投稿画面のテキストエディタが
    表示されているものの、クリックしても切り替わらなくなりました。

    子テーマfanctins.phpに、
    add_filter(‘user_can_richedit’, ‘user_can_richedit_custom’);
    を書き込むと、ビジュアル テキスト のタブが表示されず
    テキストエディタのみ使用できますが、それでは使い勝手が悪いので
    従来通り使えるようにしたいのです。

    プラグインのTinyMCE Advancedは利用していますが、
    停止にしてもアンインストールしても状況は変わりませんでした。

    テーマを切り替えても状況は変わりません。
    解決策思い当たる方、ご教示ください。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • takiz

    (@takiz)

    同様な現象に遭遇しました。
    https://wordpress.org/support/topic/unable-to-edit-theme-in-editor-after-wordpress-4-9-update/
    を参照し、全てのプラグインを無効にし、確認したところ。編集可能になっていましたので、ひとつづつ有効化して原因となるプラグインを探しました。この結果、当方の場合、counterize というプラグインが原因と判明しました。このプラグインを無効化した結果、現在は、正常に編集できています。
    ご参考になれば、幸いです。

    rurucop05

    (@rurucop05)

    >takiz様
    ありがとうございます!
    あとで気が付いたのですが、メディアを追加ボタンも使えませんでした。

    同様にプラグインを無効→有効でチェックしていったところ、私の場合WP_BeMoOveという動画埋め込みのプラグインが原因でした。
    このプラグイン、現在は配布も更新も停止しているみたいです。すでに遺物だったということですね。

    思えば、以前はメディアを追加ボタンの隣に、この動画を追加みたいなボタンがあった気がします。
    バージョンがついていけなくなって、表示されないのに干渉してたんでしょうね。ひゅーどろです(>_<)

    本当にありがとうございました。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「アップグレードしたらテキストエディタが使えない」には新たに返信することはできません。