サポート » 使い方全般 » インストール中にエラーが発生しました。

  • WordPress4.3のインストール中、突然「使用できないテーブルがあります。データベースの修復が必要かもしれません。」と表示されました。
    修復を試みました。ですが、「wp_postmeta テーブルが「Table ‘kensuke.wp_postmeta’ doesn’t exist」エラーを返しています。WordPress はこのテーブルの修復を試みます…
    テーブル wp_postmeta の修復に失敗しました。エラー: Table ‘kensuke.wp_postmeta’ doesn’t exist」のように表示され、修復できないものがありましたので、質問します。
    全文「wp_users テーブルには問題が見つかりませんでした。

    wp_usermeta テーブルには問題が見つかりませんでした。

    wp_posts テーブルが「Table ‘kensuke.wp_posts’ doesn’t exist」エラーを返しています。WordPress はこのテーブルの修復を試みます…
    テーブル wp_posts の修復に失敗しました。エラー: Table ‘kensuke.wp_posts’ doesn’t exist

    wp_comments テーブルには問題が見つかりませんでした。

    wp_links テーブルには問題が見つかりませんでした。

    wp_options テーブルには問題が見つかりませんでした。

    wp_postmeta テーブルが「Table ‘kensuke.wp_postmeta’ doesn’t exist」エラーを返しています。WordPress はこのテーブルの修復を試みます…
    テーブル wp_postmeta の修復に失敗しました。エラー: Table ‘kensuke.wp_postmeta’ doesn’t exist

    wp_terms テーブルには問題が見つかりませんでした。

    wp_term_taxonomy テーブルには問題が見つかりませんでした。

    wp_term_relationships テーブルには問題が見つかりませんでした。

    wp_commentmeta テーブルには問題が見つかりませんでした。

    修復できないデータベースの問題がありました。以下のエラーをコピー & ペーストして WordPress サポートフォーラムで質問してみてください。」
    「wp_posts: Table ‘kensuke.wp_posts’ doesn’t exist
    wp_postmeta: Table ‘kensuke.wp_postmeta’ doesn’t exist」

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • 接頭辞にドットが含まれているからでしょう

    /**
     * WordPress データベーステーブルの接頭辞
     *
     * それぞれにユニーク (一意) な接頭辞を与えることで一つのデータベースに複数の WordPress を
     * インストールすることができます。半角英数字と下線のみを使用してください。
     */

    Ortacさん、ありがとうございます。
    一度、サーバー内のデータをすべて削除し、
    もう一度転送して、再インストールしてみましたが変わりませんでした。
    ちゃんと、接頭辞にドットが入っていないことは確認しました。
    とりあえず修復と最適化を試してみましたが、結果は同じでした。
    そのときのエラーです。

    wp_posts: Table ‘kensuke.wp_posts’ doesn’t exist
    wp_postmeta: Table ‘kensuke.wp_postmeta’ doesn’t exist

    モデレーター Daisuke Takahashi

    (@extendwings)

    (WordPress 4.3.1がリリースされました。状況に何か変化があるかを確認してみてください。)

    wp-config.phpに$table_prefixと書いてある行があるかと思いますが、そのあとには何と書いてありますか?(この場合、”wp_”であればOKです。)

    解決しない場合、サーバのPHPとMySQLを調べてみてください。

    Daisuke Takahashiさん、ありがとうございます。
    状況を報告します。
    1、wp-config.phpには”wp_”と書いてありました。
    2、サーバーのPHP・MySQLの何を調べればよいのでしょうか?(無知ですみません)
    3、4.3.1が出ましたか。教えてくださりありがとうございます!

    モデレーター Daisuke Takahashi

    (@extendwings)

    サーバの各種バージョン情報などは、レンタルサーバなどであればホスティング事業者の管理画面で見ることができる場合が多いですので、一度問い合わせてみるといいです。
    VPSなどであればご自身でセットアップされた環境ですので、コマンドラインなどから自分で調べることになります。

    Daisuke Takahashiさん、ありがとうございます。
    PHP・MySQLのバージョンでしたか。
    確認しようとしましたが、レンタルサーバーのトップページ等、
    サポート関連のページが現在閲覧不可能な状態なので、できませんでした。
    (そのサイトのサポート関連のページもWordPressを使用しているので、
    もしかしたらアップグレードのときに同じエラーが発生しているのかも。←勝手な推測ですが。)

    WordPress4.3.1をインストールしましたが、状況は変わりませんでした。

    自己解決しました。
    解決までの流れ:
    1,サーバーの管理者様にお願いし、データベースを追加してもらった。
    2,そのデータベースで、WordPressをインストールをした。

    これだけです。
    原因は結局わかりませんでした。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「インストール中にエラーが発生しました。」には新たに返信することはできません。