サポート » バグ報告と提案 » エディタのバグについて

  • お世話になります。
    現在、複数のブログ(テーマはそれぞれ異なります。)でエディタ上に最下部にあったプラグインやテーマのフォームが表示される現象が起きております。

    テーマやプラグインの問題かと思ったのですが。
    それぞれ異なるテーマを使ったブログでも同様の現象が起きており、テーマに依存しないものかと思われます。

    記事の入稿時に、フォームが重なり非常に使いづらいため同じ現象が起きて解決された方がいらっしゃいましたらご教示いただけますと幸いです。

    宜しくお願い致します。

    ヘルプの必要なページ: [リンクを見るにはログイン]

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • こんにちは、

    テーマなどの、旧タイプの編集画面のメタボックスは、ブロックエディタだと、カスタムフィールドなどと供に、編集画面下部に表示されます。(表示されないものもあるかもしれません)

    この表示が必要ない場合は、編集ページの一番上の右側に、縦三点メニューをクリックして、一番下のoptionsを選択して、さらに一番下の Advanced Panels以下の該当項目のチェックを外すと消えると思います。たぶん、、、

    テーマ等でのメタボックスの作りと相性が悪く、適切な位置に表示されていないようなことであれば、テーマ側のメタボックスを取っ払う必要があるかもしれません。

    • この返信は4 日、 5 時間前に  nobita さんが編集しました。
    • この返信は4 日、 5 時間前に  nobita さんが編集しました。
    • この返信は4 日、 5 時間前に  nobita さんが編集しました。
    CG

    (@du-bist-der-lenz)

    「All in One SEO」プラグインには、問題として上がっていませんか。バグとされるには、「テーマやプラグイン」では。再現の確認しようがないです。

    nobita (@nobita)様、CG (@du-bist-der-lenz)様
    ご提案ありがとうございます。
    テーマの開発元に問い合わせてみたいと思います。

    取り急ぎは、nobita様がおっしゃられる様に非表示でしのぎたいとおもいます。
    ありがとうございました。

    バグの内容読ませて頂きました。

    私も同様の最下層のフォームが本文のフォームなどと重なる現象が起きています。
    テーマの方は自作していたので、自分側のバグかなぁ?と、思っていましたが、公式のテーマなどを活用しても同様の表示になってしまいます。

    こういった現象は他の方々も起こっているのでしょうか?
    因みにWordpressのバージョンは2019.09.15時点の最新のものを使っています。

    CG

    (@du-bist-der-lenz)

    自作されたテーマでは何ともしがたく、『公式のテーマ』が全ての意味するのでしたら、プラグインも全ての組み合わせで同様な表示になりますか。

    ishitaka

    (@ishitaka)

    私の環境では再現しませんでしたが、ブラウザによっては同様の問題が発生する場合があるようです。
    https://github.com/WordPress/gutenberg/issues/11378

    スタイルで問題を回避できるかもしれません。試してみてはいかがでしょうか。
    https://github.com/WordPress/gutenberg/issues/11378#issuecomment-493500820

    @lotokunn さん

    こういった現象は他の方々も起こっているのでしょうか?
    因みにWordpressのバージョンは2019.09.15時点の最新のものを使っています。

    プラグイン等が、何かわからないので一般論になってしまいますが、

    テーマにしろ、プラグインにしろ、エディター画面にメタボックスを設定する場合には、大抵編集画面で動作するCSSを使っている場合が多いのではないかと思います。

    そういったCSSにposition:absoluteや、ネガティブマージンを加えて実験すると意外と簡単に重なり合ったりしました。

    テーマやプラグインのCSS設定に問題があることも少なくないと思います。そのあたりをチェックしてみてはどうでしょうか

    ishitaka

    (@ishitaka)

    Chrome 76 では再現しませんでしたが、本日、Chrome 77 にバージョンアップしたところ再現しました。
    Chrome Canary (バージョン 79 相当) では、問題ありませんでした。issue もクローズしていますし、Chrome のバグと言ってもいいような気がしますが・・・

    取り敢えず、私の環境では issue に書かれている問題回避策で、重なる現象は回避することができました。
    https://github.com/WordPress/gutenberg/issues/11378#issuecomment-493500820

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。