サポート » その他 » エラーの対応が不明です。

  • 解決済 nagadora

    (@nagadora)



    管理しているサイトで、

    Warning: Use of undefined constant ture – assumed ‘ture’ (this will throw an Error in a future version of PHP) in /home/ok-reform/www/ok-reform/wordpress/wp-content/themes/ok/header.php on line 2」と「Warning: Use of undefined constant ture – assumed ‘ture’ (this will throw an Error in a future version of PHP) in /home/ok-reform/www/ok-reform/wordpress/wp-content/themes/ok/sidebar.php on line 1」というエラーが発生しておりますが、打開策がわかりません。

    ご存知の方ご教授頂ければ幸いです。
    恐れ入りますが、何卒よろしくお願い申し上げます。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • PHPのバージョンは、PHP 7.2.14 (モジュール版)です。
    Wordpressバージョンは、5.0.3です。

    こんにちは

    this will throw an Error in a future version of PHP

    とあるので、PHP のバージョンを 5.6 にしてみてはどうでしょうか。

    CG

    (@du-bist-der-lenz)

    打開策として、「this will throw an Error in a future version of PHP」とあるところではないか。

    現状治りました。ありがとうございます。
    PHPのバージョンを7.2.14に変えたい場合は、デザインの修正等が必要になるという認識で差し支えございませんでしょうか?

    PHPのバージョンを7.2.14に変えたい場合は、デザインの修正等が必要になるという認識で差し支えございませんでしょうか?

    そうですね。

    WordPress は主に以下の3つのプログラムから成り立っています。

    ・WordPress本体
    ・テーマ
    ・プラグイン

    それぞれに対応可能な PHP のバージョンというものがあります。
    PHPのバージョンを 7.2.14 に変更した場合には、どれもが不具合を起こす可能性を持っています。

    CG

    (@du-bist-der-lenz)

    PHPのバージョンを7.2.14に変えた、あるいは、PHPのバージョンを7.2.14のサーバーに移して、エラーが出たのでしょうから、それを事情説明すれば、自ずと気がついていたでしょう。
    PHPのバージョンを7.2.14に変えて、問題がないように、テーマ、プラグインを精査してからPHPバージョンを変えましょう。PHPバージョンによっては、(5.6以前には)元に戻せないバージョンもありますから。

    わかりました。
    お返事いただきありがとうございます。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • このトピックに返信するにはログインが必要です。