サポート » 使い方全般 » エラーメッセージがサイト上部に表示

  • 解決済 kyouko

    (@urochi9981)


    こちら、初めて利用させていただきます。
    どなたか、分かる方がいらっしゃいましたら教えてください<(_ _)>

    2週間前より、突然サイト上部に下記エラーメッセージが表示され、サイトのレイアウトが崩れています。

    [REQ_ERR: 403] [KTrafficClient] Something is wrong. Enable debug mode to see the reason.

    検索すると、同様のエラーメッセージが表示されているサイトを多く見かけますが、いくら調べても解決法が見つかりません。

    WPバージョンは5.7、テーマはNew Standard V3 サーバーはXserverです。

    プラグインの全停止を行いましたが、変わりはありませんでした。

    よろしくお願いいたします。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • 私には専門知識があるわけでは無いので基本の対応について記述します。
    どんなエラーが出ているかを確認する為に、まずは wp-config.php 内の
    define('WP_DEBUG', false);
    を次のように書き換えます。

    define( 'WP_DEBUG', true );
    if ( WP_DEBUG ) {
    	define( 'WP_DEBUG_LOG', true );
    	define( 'WP_DEBUG_DISPLAY', false );
    	@ini_set( 'display_errors',0 ); 
    }

    デバッグ機能をON、エラーログを残すがエラー表示は出さないという内容です。

    次に、htaccessにデバッグログへのアクセスを防ぐ以下の記述をします。

    <Files debug.log>
    Order allow,deny
    Deny from all
    </Files>

    後は、エラーが出る度にdebug.log内に記録されていきます。場所はwp-contentフォルダ内です。
    このログが問題解決のヒントになります。

    ——————
    英語圏のWP.orgフォーラムに同様の報告( Error on top of the page. HELP! )がありまして、
    こちらのトピックによるとホスティングサービスに連絡して解決したようです。

    I have contacted my host, and they resolved the issue, the cause of this error was some kclient plugin, they have deleted it and it resolved the problem.

    エラーの内容によってはXserverのサポートへの連絡やWordPressの再インストールなどの作業が必要になるかもしれません。

    • この返信は1年、 7ヶ月前にmoyo55が編集しました。
    • この返信は1年、 7ヶ月前にmoyo55が編集しました。理由: debug.logの場所追記
    トピック投稿者 kyouko

    (@urochi9981)

    moyo55様

    サポートしていただきありがとうございました!
    デバッグモードのご説明、大変参考になりました。

    海外サイトのご紹介もありがとうございます。

    私の場合、プラグインを全停止⇒バックアップを取って全削除まで試したのですが、海外の例はまたそれとは別のことを行った結果改善されたのでしょうかね。

    xserverには一度、問い合わせたのですが、『弊社はあくまでも土台を提供しているだけです』と言ったニュアンスの回答で、あまり良い返事は頂けなかったです((+_+))

    プラグインを全て削除しても改善されないのなら、テーマを標準テーマに変更してみましょう。
    問題解決のためのチェックリスト

    すべてのプラグインを無効化し、同時にテーマをデフォルトのテーマに戻して再度試してみましょう。それで正常に動くなら一つずつ元に戻してみて、どれが問題を引き起こしているか絞り込むことができるはずです。

    私もエックスサーバーを利用していますが、そのようなエラーメッセージは発生していません。

    とりあえずですが、サイトを表示したりリロードしたりすればエラーが発生したときにdebug.logに記録されていきますので
    ログの中に KTrafficClient に関するエラーがあるか確認してみてください。
    ログには 発生時刻・エラー内容・エラーに関係するファイル名・問題がある行数 が記録されています。

    また、npsslさんが言うようにテーマを変更しても発生するかどうかも確認してください。
    テーマを変更しても発生する場合はWordPress本体のファイルやサーバの設定等に問題があることになります。

    トピック投稿者 kyouko

    (@urochi9981)

    @npssl

    サポートありがとうございます<(_ _)>
    とても嬉しいです。

    テーマの変更をまずやってみようと思います!

    結果をまたご報告させていただきますね♪

    • この返信は1年、 7ヶ月前にkyoukoが編集しました。
    トピック投稿者 kyouko

    (@urochi9981)

    @moyo55

    再度お付き合いくださりありがとうございます!<(_ _)>
    パソコンにあまり詳しくないので、まずはテーマの変更を試して、その後デバック機能でエラーの確認をチャレンジしてみたいと思います。

    本当にありがとうございます♪

    • この返信は1年、 7ヶ月前にkyoukoが編集しました。
    トピック投稿者 kyouko

    (@urochi9981)

    @npssl
    @moyo55

    ご報告です!
    お二人に教えていただいたことを検索しながらいろいろやっていたら、なんと直りました!(^^)!
    何で直ったのかはちょっと分からないのですが、正常になったので本当に感謝です<(_ _)>

    ありがとうございました!♪

    トピック投稿者 kyouko

    (@urochi9981)

    解決です☆

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「エラーメッセージがサイト上部に表示」には新たに返信することはできません。