サポート » 使い方全般 » キャプション付き画像だけリンクが貼れない

  • 解決済 smasma1192

    (@smasma1192)


    画像にキャプションを書いてカスタムリンクすると、下記の通りソースは問題なく挿入されますが、ブラウザ上でリンクが効きません。

    [caption id="attachment_○○○○" align="aligncenter" width="250"]<a href="pdfファイルURL"><img src="jpgファイルURL" alt="埋め込みテキスト" width="250" height="354" /></a> キャプション[/caption]

    全く同じ手順でキャプションを書かなければ問題なくリンクが貼れます。

    <a href="pdfファイルURL"><img src="jpgファイルURL" alt="埋め込みテキスト" width="250" height="354" /></a>

    なぜなのでしょうか…

    • このトピックはsmasma1192が2年、 8ヶ月前に変更しました。
    • このトピックはsmasma1192が2年、 8ヶ月前に変更しました。
4件の返信を表示中 - 1 - 4件目 (全4件中)
  • smasma1192さん、こんにちは。

    ご提示されているキャプションショートコードをショートコードブロックに記載して試してみましたが、問題なくリンクが貼られました。また、環境が何も書かれておりませんので、これ以上の検証ができません。

    まずは問題解決のためのチェックリストをご確認いただき、トラブルシューティングを実施されてみてください。

    ご参考になれば。

    トピック投稿者 smasma1192

    (@smasma1192)

    shokun0803さん

    ご返信ありがとうございます。ご親切に教えて下さり助かりました。

    OS macOS BigSur
    ブラウザ safari 14.1.1
    wordpressバージョン 5.8.1
    使用テーマ Bizvector

    以前まではキャプションを書いても問題なくリンクされていたのですが、気がついた時には既にキャプションがついている画像全てのリンクがなくなっている(クリックポイントに接続されない)状態でした。
    プラグインのアプデが関係しているかと思い、全てのプラグインを一つ一つ無効化してみましたが変化なく、WordPressのバージョンのアプデの問題かと思い、5.7〜5.4まで一つずつダウングレードしてみましたが変化がありません。

    ブラウザのキャッシュという点では、同じOSではありますが複数台から確認し、iphoneからも確認しているのでキャッシュが残っていたということでもないように思います。

    同じ事例をネットで探すにも見当たらず困り果てていました。

    トピック投稿者 smasma1192

    (@smasma1192)

    すみません、テーマを親テーマに戻してみたところ(私がカスタムする前のBizvector)画像リンクがされました。つまり私がカスタムした子テーマに問題があるようです…

    一体何をどうしてこうなったかさっぱり検討がつきません…

    smasma1192さん、こんにちは。

    すみません、テーマを親テーマに戻してみたところ(私がカスタムする前のBizvector)画像リンクがされました。つまり私がカスタムした子テーマに問題があるようです

    であれば、まずは該当ページでどのファイルが使用されているか確認します。
    ヘッダーに global $template で表示するような方法もありますが、使われていると思われるページテンプレートのloop前後に echo ‘hoge’ のように入れてみて表示されるなら該当ファイルだと判断もできると思います。

    該当するファイルが確認できたら、loop部分等で何らかの処理が含まれていないか確認してみる、functions.php に何らかの処理が含まれていないか確認してみるなど、順を追って試してみるのはいかがでしょうか。

    もしかしたら、コード上はリンクが存在していて、CSSで何らかの上書きが発生している可能性もあるかもしれません。

    ご参考になれば。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「キャプション付き画像だけリンクが貼れない」には新たに返信することはできません。