サポート » バグ報告と提案 » ギャラリーのタブが現れない

  • 解決済 takashi ots

    (@takashi-ots)


    こんにちは。

    ギャラリーのタブが現れてくれません。

    投稿画面でも、ページ編集画面でも、ギャラリーを挿入するためのタブが現れなくなってしまったのです。

    投稿やページの新規追加画面などで画像をアップしたり、「画像を追加」「メディアライブラリ」から追加したりすれば、「ギャラリー」のタブが現れていたのですが、それがすごく不安定で、現れたり現れなかったりなのです。

    確率的には、10回に1回現れるくらいです。

    色んな原因を考え、試行錯誤してみたのですが、原因がわからず、こちらでお聞きした次第です。

    何十回もチャレンジして、現れたときと現れなかったときの違いを色々見てみたのですが・・・。
    ・画像サイズもバラバラ。
    ・拡張子の大文字・小文字も関係なく。 例)「jpg」「JPG」
    ・サーバーのメモリも関係しているかと思い、メモリを増加させてみましたが、変わらずです。
    ・2.8.6が原因かと思い、2.8.5も試してみましたが、やはりダメ。
    ・プラグインを全て解除して、試してもダメ。
    ・html側で[gallery]を入力しても、「ギャラリー」のタブは現れてくれない。
    ・ブラウザは、firefox3.5、IE7、Google chrome、safari全てダメ。
    ・OSはWindowsXP SP3、Windows7両方ともダメ。
    ・サーバーのメモリも増やしてみてもダメ。

    一度現れると、その投稿は比較的安定して、次々とギャラリー挿入できます。

    でも、サイズ、拡張子関係なく、挿入できるもの、できないものが分かれることもあります。
     例) 10枚の画像をページに貼り付けたうち、5枚はギャラリーのタブに反映されている。

    サーバーは、WEBKEEPERSのLINUX VPS スタンダードプランです。
    http://jp.webk.net/service/vps_function.html

    どうにもこうにも現れてくれなくて、困っています。

    プラグイン追加で解決することも考えましたが、普段該当サイトを触っている人間が、PCに不慣れな人間のため、できるだけ操作を少なく追加できるようにしたいと思い、まだプラグインには手を出していません。

    どなたか解決方法をご存知の方はいらっしゃいませんか?

    宜しくお願いします。

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • ギャラリータブで現れない画像は、メディアライブラリの「リンク先」で
    「(使用されていないメディア)」と表示されると思います。

    なぜこうなるかというと、新規の投稿/ページが保存されていないうちに
    画像をアップロードするからのようです。
    画像のリンク先がまだ無い状態なので当然ですね。

    再現手順例)
    1.新規投稿追加。
    2,タイトル入力(入力しない場合もかな)。
    3.パーマリンクが表示されないうちに「画像を追加」で画像アップロード。
    4.画像のリンク先が「なし」になる。

    対処法)
    タイトル入力後、ひと呼吸おいてパーマリンクが表示(=下書き保存)されてから画像をアップロードする。

    あるべき姿)
    plan A:投稿/ページが保存されてない間は「画像を追加」等できないようにする。
    plan B:「画像を追加」等時には、投稿/ページの(下書き)保存を保証する。

    参考)
    functions.php で以下のように(一例)自動保存をOFFしててもNGな気がします。

    function disableAutoSave(){
      wp_deregister_script('autosave');
    }
    add_action( 'wp_print_scripts', 'disableAutoSave' );

    kzさん。

    解説ありがとうございます。
    ご指摘いただいた通り作業すれば、正常に挿入できました!

    どれだけ調べても、おもしろいくらいに何も情報が見つからなくて、ホント困っていました。
    助かりました。^^

    ありがとうございます。

    私の環境では、2.8.6を使用しているのですが、メディアライブラリのリンク先は空欄になっていました。

    また、ご指摘いただいて、注意して見てみて気付いたのですが、メディアライブラリの1枚の画像に対して、ギャラリーはひとつしか挿入できないのですね。(別ページでも)

    既に別ページでギャラリーに使用している画像を、メディアライブラリから選択してもギャラリーには使えませんでした。
    その都度、アップしないといけない、ということですよね。

    かなり苦戦を強いられていたので、ホントに助かりました。

    ありがとうございました!

    その都度、アップしないといけない

    PCに不慣れだとアレですが、ギャラリーショートコードに画像のIDを指定すれば
    同じ画像を共有することができます。
    例)IDが 123, 124 の画像も追加。
    [gallery include="123,124"]

    参照)
    Gallery Shortcode

    解決しましたら、
    このページの右側のわかりにくい場所に
    「このトピックは」とありますので
    [未解決]を[解決済]に変更して
    [変更]ボタンをクリックしていただくと
    良い感じです。

    kzさん、ありがとうございます。

    参考になりました。

    また宜しくお願いします。^^

4件の返信を表示中 - 1 - 4件目 (全4件中)
  • トピック「ギャラリーのタブが現れない」には新たに返信することはできません。