サポート » 使い方全般 » グローバルナビゲーションだけ文字化けしてしまう

  • 解決済 sibosan

    (@sibosan)


    初心者です。教えていただきたいのですが、Business Proというテーマを使って、サイトを作り始めたのですが、グローバルナビゲーションのメニューを変更しようとしてメニューを保存ボタンを押すと日本語が文字化けしてしまいます。
    子テーマを使って
    /*
    Theme Name: business-pro_child
    Template: business-pro
    Description:business-proの子テーマです
    */
    @charset “UTF-8”;
    @import url(‘../business-pro/style.css’); /*親テーマのスタイルシートを読み込み*/
    という設定にしてあるので、文字はUTF-8のはずなのですが…
    どこを修正すればいいのでしょうか。

3件の返信を表示中 - 16 - 18件目 (全18件中)
  • nobitaさん、いろいろ調べていただき、ありがとうございます。ウィジェットでメニューをテキストでつくってリンクをかけてつくってあります。その部分に関しては、文字化けはしません。グローバルナビゲーションのメニューを作成機能を使うことだけができないという感じです。
    メニューは、何もしない状態(固定ページがすべて表示された状態)は、
    ・ホーム
    ・レンタル
    ・会議センター1F
    ・営業のご案内
    ・店舗案内
    ・展示ホール
    ・料金表(これからフォームを作る予定です)
    といったものです。
    このうち店舗案内の中に会議センターと展示ホールがあるためこのふたつを削除
    ・ホーム
    ・店舗案内
    ・営業のご案内
    ・レンタル
    ・料金表
    の順にならべかえて、メニューを保存すると、この時点で文字化けしてしまうのです。
    管理パネルや、投稿 タイトルは文字化けなしです。 コメント アーカイブは、使用しておりません。

    非表示の指定の件、助かります。いざとなったら、非表示で対応も考えます。

    ikaringさん、CPIからの返事です。
    『wordpressにて文字化けをしてしまうとのことで、
    ご連絡を頂いております。

    弊社のphp5.5.16 の文字コードは、UTF-8となっております。
    しかしながら、WordPress 等、一部文字化けとなってしまうことが
    御座います。その場合は、.htaccess や php.ini にて文字コードの
    設定を行って頂きますようお願い致します。

    php.iniにて、以下の設定値の変更を、お試しください。
       ————-
       mbstring.internal_encoding = (設定する文字コード)
       mbstring.encoding_translation = Off
       ————-

    php.iniのファイルをお客様領域の任意の場所に設置をして頂き、
    php.iniの変更を下位ディレクトリ全体に反映をするように、
    .htaccessに記述を行って頂きますようお願いいたします。

    以下、記述についてのオンランヘルプが御座いますので、
    ご参照を頂き、ご対応を頂きますようお願いいたします。
    http://acesr.document.secure.ne.jp/tools/php/php01.html』

    とのことで、やはりCPIサーバーでwordpressは文字化けするものがあるということですね。.htaccessまでいじくると、初心者の私としては画面がまっ白になりそうで、ちょっとためらっております。

    ikaringさん、nobitaさん、お騒がせしました。だいぶ長いことかかりましたが、やはりレンタルサーバー側(CPI)の方の問題でした。
    php.iniの
    mbstring.encoding_translation = On

    mbstring.encoding_translation = Offにしてから
    .htaccessを作成してワードプレスをインストールした場所にアップしたところ
    文字化けは治りました。
    CPIサーバーのシェアードプランACE01(エース)は、初期設定では、mod_rewriteが有効になっていません。mod_rewriteが有効になっていないと、WordPressのパーマリンク設定が出来ず、記事のURLの変更ができないようです。
    ですので
    .htaccessに以下のコードを書いて完了しました。

    AddHandler x-httpd-php536 .php
    suPHP_ConfigPath /usr/home/ユーザーID/html/
    Options +FollowSymLinks

    本当にいろいろとありがとうございました。

3件の返信を表示中 - 16 - 18件目 (全18件中)
  • トピック「グローバルナビゲーションだけ文字化けしてしまう」には新たに返信することはできません。