サポート » 使い方全般 » コメントの複数改行が反映されない

  • rasuta

    (@rasuta)


    お世話になります。

    MovableTypeからの移行者です。

    MT形式のログをインポートしましたが、コメントの複数改行が反映されません。

    ■ログの状態
    記事の改行:記事はHTMLで書いており、改行は<Br />で行っている
    コメントの改行:MTの時はテキストでの改行が有効になっておりは<Br />使用していない

    ※ちなみにインポート時に記事とコメントのテキストでの改行情報は削除されてしまいます

    記事については<Br />があるため問題ないですが、コメントについては改行情報が削除されている上に、新規コメントでも複数改行が有効になりません。

    プラグインでbrBrbrやmy autopを使用すると、新規コメントについては問題なくなるのですが、記事についてはテキストでの改行も行っているため、余計な改行が入ってしまいます。

    コメントだけテキストでの複数改行を有効にする方法はありませんでしょうか。
    ご存じでしたら教えていただけると大変助かります。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • kazudarts

    (@kazudarts)

    こんにちは
    >rasutaさん
    プラグインでよければ
    自動整形を解除するプラグインがありますよ
    ここ
    日本語の説明ありますので楽ですよ^^

    スレッド開始 rasuta

    (@rasuta)

    ご回答いただきありがとうございます。

    記載しておりませんでしたが、PS Disable Auto Formattingを
    使用しても、brBrbr もしくは my autopにて記事に余計な改行が
    入ってしまうことが改善できませんでした。

    brBrbr もしくは my autop:有効化
    PS Disable Auto Formatting:記事とコメントの片方もしくは両方を自動整形なし

    brBrbr もしくは my autopの機能が、コメント限定で有効にできれば良いのですが
    探してもそういったプラグインはないようです。方法が分かりませんが、手動で
    行うしかないかとも思っております。

    kazudarts

    (@kazudarts)

    >rasutaさん
    読み込んだコメントは、コメントの編集欄で改行なしの一行で読み込まれていますか?

    未検証ですが
    もし改行されて表示されていれば
    brBrbr と my autop:を無効にして
    PS Disable Auto Formattingにて一括整形処理と結う機能で
    強制に
    をコメントに入れた後
    brBrbr もしくは my autop:有効化
    PS Disable Auto Formatting:記事とコメントの片方もしくは両方を自動整形なし
    で行けそうな気がするんですが

    以下かでしょうか。

    スレッド開始 rasuta

    (@rasuta)

    kazudartsさん、ご回答ありがとうございます。

    >読み込んだコメントは、コメントの編集欄で改行なしの一行で読み込まれていますか?
    インポートした記事ですが、改行は改行として、複数改行はただの改行として読み込まれます。改行なしの一行とはなっておりません。

    「一括整形処理」については試してみました。こちらを行うと記事に<p>タグを付けるようで、記事に不要な改行が入ってしまいました。(ちなみに全記事を過去のリビジョンに一括して戻すことは可能でしょうか。復元も同プラグインで行えるのかと勘違いしていました)

    過去の記事は、まずはインポート時に複数改行を改行として取り込む事が改善できればと思っております。

    新規コメントについては、コメントのみテキストの複数改行を複数改行をして表示してくれるものがあれば良いのですが、今のところ見つかりません。

    kazudarts

    (@kazudarts)

    >rasutaさん
    今自サイトで検証しました
    <p>タグたしかについてますね><

    >ちなみに全記事を過去のリビジョンに一括して戻すことは可能でしょうか

    ※ 処理を行う前に極力データベースのバックアップを行っておいてください。とあるので無理かと思われます

    >過去の記事は、まずはインポート時に複数改行を改行として取り込む事が改善できればと思っております
    この辺になると僕の力じゃ~~~
    お役に立てなくてごめんなさい

    何かほかで見つけましたらご報告します

    kurosquare

    (@kurosquare)

    過去の記事は、まずはインポート時に複数改行を改行として取り込む事が改善できればと思っております。

    インポート用の公式プラグインをお使いになったと思いますので、それに手を入れればよいかと思います。

    未検証ですが、
    wp-content/plugin/movabletype-importer/movabletype-importer.phpの450行目あたり

    if( !empty($line) )

    #if( !empty($line) )
    のようにコメントアウトして無効化すればよさそうに見えます。

    スレッド開始 rasuta

    (@rasuta)

    kazudartsさん、kurosquareさん ご回答ありがとうございます。

    >kazudartsさん
    作業前に全記事をエクスポートしていたので、全記事を削除して、
    再度全記事をインポートして元に戻しました。ご心配お掛けしました。

    >kurosquareさん
    お教えいただいた内容にて試したところ、記事・コメントの改行情報が
    削除されなくなりました。詳細お教えいただき本当にありがとうございます。
    おかげさまでこの問題については解決しました。

    コメント欄のみテキストでの連続改行を有効にする方法については、
    引き続き何か解決方法がないか探してみます。

    投稿者のrasutaですが、WordPressアカウントのパス強制リセットが
    あったようですが、以前のメアドが無効のため再登録しました。

    3年前の質問ですが、コメント欄の改行については改善しておらず、
    この度、サーバーを移転するのを気に改めて質問させていただきます。

    ■質問内容
    コメントに入力された複数改行が反映出来ません。

    brBrbr もしくは my autop を使用すると、記事にも余計な改行が入って
    しまうため使えません。

    コメント欄の改行コードのみ、反映出来ないかと思っていますが、
    調べた限り解決策がない状態です。

    もし何かヒントがあればいただけると助かります。

    なお、記事はHTMLで書いております。このため下記を行っています。
    ・ビジュアルリッチエディターは無効
    ・PS Disable Auto Formattingにて「記事内容の自動整形」は無効

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「コメントの複数改行が反映されない」には新たに返信することはできません。