サポート » 使い方全般 » サイトへアクセスできない

  • 解決済 ringnir

    (@ringnir)


    Ver2.7を入れたWPで、前日までは何も問題なかったのですが、サイトへアクセスできなくなりました。エラーメッセージなど何も表示されず真っ白な画面になるだけです。
    何も設定などいじってないのですが。
    ただし、管理画面にはアクセス可能で、管理画面へログイン後にはサイトへもアクセスできるようになります。

    同じサーバーに他にも3つWPをインストールしてあり、他の3つはアクセスできます。これらはVer2.65です。よって、サーバー側の不具合ではないと思うのです。

    何が問題なのかわからず困っています。こちらで解決できなければ再インストールするつもりです。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • モデレーター Naoko Takano

    (@nao)

    一度すべてのプラグインを無効化して、テーマもデフォルトのものに戻してみた場合、サイトが表示されるでしょうか?

    管理画面は問題ないということなのでテーマ関連のトラブルかな?とは思いますが、何もいじってないということなので違う気もしますが…。

    もし上記の方法で正しく表示されたら、まずはテーマ、そして一つずつプラグインを有効化していって、その度にサイトを確認しながらどこが問題なのかを見つけてみてください。

    以下なども参考になるかもしれません。

    http://www.google.co.jp/search?q=site%3Aja.forums.wordpress.org+%E7%9C%9F%E3%81%A3%E7%99%BD&btnG=%E6%A4%9C%E7%B4%A2

    スレッド開始 ringnir

    (@ringnir)

    プラグインを無効にしても、テーマをデフォルトのものに変えても症状は変わりませんでした。
    しかたないので再インストールしてみます。
    ありがとうございました。

    スレッド開始 ringnir

    (@ringnir)

    再インストールもダメでした。
    2.6.5をインストールしなおしてもダメでした。
    管理画面にはアクセスできても、サイトへはアクセスできません。
    一度、管理画面へログインしてからだと、サイトへもアクセスできるようになります。
    ただし、他のPCではアクセスできません。ログインしたPCのみアクセス可能です。
    この場合、何が原因と考えられるのでしょうか?

    モデレーター Naoko Takano

    (@nao)

    ふーむ、ちょっと色々質問させて下さいね。

    再インストールした時は、元々あったサイトのファイルを使われましたか?
    それとも新しくダウンロードした日本語版のパッケージでしょうか。

    おそらくもう行われていると思いますが、再インストールの際は新しく作った/またはすべて空にしたデータベースを使ってください(もとの DB のバックアップも取っておくと良いです)。
    それから、ルートにある .htaccess ファイルも一度削除してみて下さい。

    同じサーバーとありますが、これは同ドメインのサブフォルダに複数のWordPressをインストールしていますか?それとも各インストールごとに違うドメインを割り振っていますか?

    スレッド開始 ringnir

    (@ringnir)

    最初のインストールも再インストールも2.7.1日本語版です。
    インストール後しばらくは問題ありませんでした。
    再インストールはサーバーのファイルを削除して、アップロードしなおしました。
    MySQLを空にして、.htaccessも削除し、再インストールしました。

    再インストール当初はトップページも個別ページも表示されました。
    パーマリンクをカスタム「/%postname%.html」とすると404エラーが出るようになりました。.htaccessには管理画面に表示されるMod_Rewriteルールが記述してあります。
    2.6.5に戻した場合も同じ症状になりますが、トップページにはアクセス可能です。

    >同じサーバーとありますが、これは同ドメインのサブフォルダに複数のWordPressをインストールしていますか?それとも各インストールごとに違うドメインを割り振っていますか?

    同じサーバーに違うドメインを割り振ってそれぞれWPをインストールしています。以前から2.6.5を使っているドメインは何も問題ありません。

    スレッド開始 ringnir

    (@ringnir)

    手動で書き込んだ.htaccessを削除し、パーマリンク設定時に自動書き込みされるようにしたところ、カスタム設定でページが表示されました。

    その後、WP super cacheを適用したところ、トップページも個別ページも真っ白になりました。このsuper cacheをオフにすると再び表示されるようになりました。2.6.5でも2.7.1でも同じ現象です。

    Super cache0.9.1から、手持ちのアーカイブに0.8.6があったのでこれに戻すと、問題なく正常表示されました。よって、Super Cacheのバージョンに問題があったようです。

    × WP2.7.1 + Super cache0.9.1
    × WP2.6.5 + Super cache0.9.1
    ○ WP2.7.1 + Super cache0.8.6
    ○ WP2.6.5 + Super cache0.8.6

    以上のような組み合わせでの表示/非表示でした。

    スレッド開始 ringnir

    (@ringnir)

    書き忘れましたが、Super cacheは管理画面でオフにするだけでなく、サーバーから削除しないとダメでした。自動生成されたadvanced-cache.phpやwp-chace-config.phpも削除し、それから古いバージョンを入れました。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「サイトへアクセスできない」には新たに返信することはできません。