サポート » マルチサイト » サイトネットワークをアップグレードでエラー

  • 解決済 de-0612nishio

    (@de-0612nishio)


    いつもお世話になっております。

    この度お客様のウェブサイトをwordpressのマルチサイトにて構築しています。
    サーバー環境はレンタルサーバーではなく先方側でご用意されたものになるのですが、特に変わった仕様もないようです。
    php5.3.3
    mySQL5.1.73
    sftp以外のアクセスは作業者の拠点からは不可
    それと常時SSL化(マルチサイト)です。

    ウェブサイトの構築は完了しているものの、管理画面からの「更新」類はftpパスワードをお知らせいただいていないため更新が不可能なはずです。
    しかし「サイトネットワークをアップグレード」をクリックしてみると以下のエラー表示が出ます。

    ———————–
    注意してください!https://ドメイン/マルチサイトディレクトリ  の更新中に問題が発生しました。サーバーは稼働しているサイトに接続できないようです。エラーメッセージ: cURL error 35: SSL connect error
    ———————–

    こちらを調べてみたのですが、サーバーに関する設定のエラーなのか何かがよく分かりません。

    このような漠然とした質問で恐縮ですが、ご教授お願いします。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • munyagu

    (@munyagu)

    こんにちは

    私、全く詳しくないですが、検索してみるとよくあるようですね。
    http://blog.wnotes.net/blog/article/php_curl_error

    上記URLのサイトでは、PHPがSSLの処理にNSSを使っているとダメとか。
    phpinfoで確認されてみてはどうでしょうか。
    PHPのバージョンなども古いようなので、NSSのバージョンが古くてTSL1.2に対応していないのかもしれません。

    対策としては、NSSのバージョン3.15.1以降を使う(http://www.h-online.com/security/news/item/NSS-3-15-1-brings-TLS-1-2-support-to-Firefox-1918133.html)か、OpenSSLを使うようにPHPを入れなおす・・・のは許されないかもしれないので、マルチサイトではない方向で検討した方がいいかもしれませんね。

    de-0612nishio

    (@de-0612nishio)

    munyaguさん、ご返信いただきまして誠にありがとうございます。

    http://blog.wnotes.net/blog/article/php_curl_error
    こちらのURLに私もアクセスしていて何となくこれかなと思う節もありました。

    phpinfoで確認しますと「SSL Version:NSS/3.16.2.3 ・・・・」となっており確かにOpenSSLにはなっていませんでした。
    しかし「対策としては、NSSのバージョン3.15.1以降を使う」事自体はクリアしております。

    バージョンがクリアしていてもNSSでは対応できないという事もありえることを考えると、やはりPHPを入れなおすかマルチサイトではない方向で進めるのかの2択になってしまいます。

    結局サーバー内での調整がウエイトを占めるという結果になると私も見解しています。

    de-0612nishio

    (@de-0612nishio)

    nssからOpenSSLを使用するのがベストと思いますが、先方のサーバーなので何かあった時の対策としてマルチサイトを使用せずに構築する事にしました。

    ご返信ありがとうございました。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • トピック「サイトネットワークをアップグレードでエラー」には新たに返信することはできません。