サポート » インストール » サイト表示ができません

  • WordPressMEから2.5にアップグレードを試みました。
    元々サーバーにあったフォルダは、wp-content以外は削除し、2.5のwp-config.phpを編集しすべてをアップロードし、同じ名前のフォルダがあるときは新しい場合は上書きというものを選びました。
    その後、/wp-admin/upgrade.phpにアクセスしてアップデート。ログインもでき、記事も書くことはできるのですが、サイト表示を押すと、
    * This problem can sometimes be caused by disabling or refusing to accept cookies.
    というメッセージが出て、ブラウザでサイトを表示することができません。
    解決法をご存知の方よろしくお願いいたします。

15件の返信を表示中 - 1 - 15件目 (全18件中)
  • すいません。上記の質問をしたものです。サーバーはXREAです。
    また、Safariでページを開こうとした所、下記のエラーメッセージが現れました。
    “http://www.xxxx.com/” を開こうとして多くのリダイレクトが発生しています。あるページへのリダイレクトが設定されているページを開いたときに、リダイレクト先のページから元のページにさらにリダイレクトが設定されている場合にこうした現象が起きる場合があります。

    管理画面は正常に動作しているようですので、管理画面からある1つの投稿に飛ぶことはできると思うのですが、それは大丈夫ですか?要はシングルページ表示はうまくいくか?ということです。

    それと、テーマファイルが何かしている可能性もありますので、ご利用のテーマファイルを一端リネームしてみてください。するとデフォルトテーマを読み込んでくれます。その状態でもエラーが出ますか?
    もし出るようなら、記事自体に問題がある可能性も出てきます。

    お返事ありがとうございます。残念ながら一つの投稿表示ページも表示されません。テーマファイルはいくつか変えてみたのですが、リネームというものをトライしてみます。

    経過報告です。テーマファイルの悪さの可能性をご指摘いただきましたので、リネームというものがわからず、とりあえずサーバー上にアップしたデーターはwp-contentも含めて削除し、再び2.5を一からアップロードしました。
    デフォルトのテーマは二つあったのですが、どちらもサイトの表示が不可能でした。どちらかというと、XREAから独自ドメインに飛ばすときの何らかの不具合の可能性も考えておりますが、いかがでしょうか?よろしくお願いいたします。

    XREAから独自ドメインに飛ばすときの何らかの不具合の可能性も考えておりますが、いかがでしょうか?

    ここがわかりませんが、全体的にどういう動きをしているのか・・・
    リダイレクトがループしてしまっているとかでは無いのでしょうかねぇ?

    データベースをバックアップしておいて、新規にWordpressをインストールしても同様になるなら、サーバ自体になにか不具合が出てるとかも考えられますが。

    お返事ありがとうございます
    >リダイレクトがループしてしまっているとかでは無いのでしょうかねぇ?
    専門的なことはよくわからないのですが、そのリダイレクトがループしているという表現が正しいように思います。その場合、サーバー自体が悪いということでしょうか?いま、value-domainにもサポートメールを出しております。
    さらに、サーバー上でデーターをすべて削除して、新規にwordpressをインストールしてインストールしてみました。
    独自ドメインを仕様しないのであれば、xreaのURLで記事を書いたり投稿したりできるのですが、www.treatneuro.comへ独自ドメインから飛ばそうとすると、やはり多くのリダイレクトが発生しますというメッセージが出てきてしまいます。
    知識が乏しく、見当違いの質問かもしれませんが、解決法を教えて頂けると助かります。

    http://www.treatneuro.comへ独自ドメインから飛ばそうとすると

    ↑これがよくわかりません。
    いま、そのURLへアクセスするとたしかに、そういうエラーを返しますが、独自ドメインから飛ばすとは何でしょうかね?
    要するに、www.treatneuro.com というドメインをお持ちで、VALUEDOMEINかなにかで、DNS設定をしてると言いたいのでしょうか?

    あと、変なhtaccessが置いてあったりしませんか?

    kvaexさんのおっしゃるとおり、XREAから与えられたhttp://s313.xxxxxx のようなURLのようなものがあるのですが、ここにアクセスしてサイト表示は可能のようです。が、折角独自ドメイン(www.treatneuro.com)を持っているので、http://s313.xxxxxxにアクセスしてもwww.treatneuro.comに飛ぶように(この言葉が本来適切でないかもしれませんが)、DNS設定をしております。
    すると、エラーメッセージがでます。

    WordPress2.5を入れた瞬間からの出来事でこのようなエラーがでるようになったのですが、確かwordpressMEを消す時に、htaccessというものを消している可能性もあるかなと思います。その場合、どのようにすればよろしでしょうか???

    具体的にお聞きします

    http://s313.xxxxxx にアクセスすると、www.treatneuro.com に飛ぶというのはおかしいと思います。

    要は http://www.treatneuro.com のDNS設定を、http://s313.xxxxxxに割り当てているわけですよね?
    ということは、その段階で
    http://www.treatneuro.com
    http://s313.xxxxxx
    この2つは同じ所を見ることになります。
    ここまではいいですよね?

    しかしながら、http://s313.xxxxxx にアクセスした場合も http://www.treatneuro.com にしたいということで、リライトを使っているのかどうなのか?
    もし単純にhttp://s313.xxxxxxというサーバにアクセスがあったときにwww.treatneuro.comに移動させてしまっていると、www.treatneuro.com も http://s313.xxxxxx と同じ所を見ているので、再度 http://www.treatneuro.com にアクセスしようとしているのでは無いでしょうか?
    それが延々と繰り返すと、当然ループになりますよね?
    それあwordpressのhtaccessでおこっているのでは無いでしょうか?

    htaccessが無いと、あたかも有効な設定になっているように見えますが、本来はNGな設定になってしまっているのでは?

    少しずつ理解できてきた気がします。htaccessやDNSの設定などを試しまた報告させて頂きます。

    経過報告です。いまだ、問題が解決しておらず、ドメインを購入したValueコマースやサーバーのXREAなどに問い合わせをしていますが返事をいただけておりません。元のデーターを消してまで何回も再インストールなどもしてみたのですが、、、
    http://billben.s313.xrea.com/

    http://www.treatneuro.com
    の関係に対してValueコマースのDNSの設定などの説明文をすでに10回以上は読んで設定し直していますが駄目です。
    http://www.treatneuro.comのDNS設定をhttp://billben.s313.xrea.com/に割り当てる作業をするとまったく改善はないのですが、
    http://www.treatneuro.comを使わずに、http://billben.s313.xrea.com/だけで使用すると問題なくサイトが表示されます。
    また、報告させて頂きます。

    今、http://billben.s313.xrea.com/ にアクセスしたところNGでしたね。
    http://billben.s313.xrea.com/ になにかhtaccessが書き込まれているとか、コントロールパネル(でしたっけ?)上から、なにか設定しているとかありますか?

    正式な直し方かどうかはよくわからないのですが、サイトが表示できるようになりました。kvexさんには本当に付き合っていただき感謝しております。
    結局Wordpressの「設定」のWordPress のアドレス、ブログのアドレス (URL)をそれぞれ、http://billben.s313.xrea.com/ からwww.treatneuro.comに変更したところリダイレクトがなくなりました。WordPressMEでは、前者の設定で大丈夫だったのですが。。。
    本当に初歩的なミスだったと考えられ御迷惑をおかけしました。
    しかし、、、
    WordPressME、Wordpress2.5でエクスポートしておいた記事はインポートできず、100ページ以上におよぶ記事をやりなおさないといけない可能性が高く落ち込んでおります。いずれにしても本当にありがとうございました。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    結局Wordpressの「設定」のWordPress のアドレス、ブログのアドレス (URL)をそれぞれ、http://billben.s313.xrea.com/ からwww.treatneuro.comに変更したところリダイレクトがなくなりました。WordPressMEでは、前者の設定で大丈夫だったのですが。。。

    WordPress 2.3 から、canonical URL の仕組みが導入され、設定と異なる URL でアクセスされた場合、本来の正しい URL にリダイレクトするようになりました。今回の場合、http://billben.s313.xrea.com/ と http://www.treatneuro.com/ の両方でアクセスできる場合、WordPress の設定が前者であれば、後者でのアクセスは前者にリダイレクトされます。そして、XREA 側で、前者から後者に飛ばすようになっていたため、リダイレクトのループが発生してしまった、というわけです。

    WordPressME、Wordpress2.5でエクスポートしておいた記事はインポートできず、

    普通にインポートすればいいと思うんですが、なぜできないんでしょう?? エクスポートされた記事中に http://billben.s313.xrea.com/ という記述があるのが理由ならば、適切なテキストエディターで置換処理すればいいですし。

    lilyfanさんありがとうございます。
    スッキリです。まず、その箇所を疑わなかった自分の知識不足が悔やまれます。
    インポートできました。wp-contentのパーミッションを755から707とかに変更して無事にでき、パーミッションを755に戻しました。
    次は、XREAでよく報告のある画像のアップロードができません。.htaccessを作成してwp-contentに入れる、パーミッションを変更するなどの技がサイトで紹介されていますがエラーがでてしまいます。奥が深く毎日、新鮮な不具合と格闘しております(笑)またlilyfanさんのコメントのようにグレーの四角で文章を囲う技もかっこよいですね。タグなどをしらべてみようと思っているまだまだ初心者です。
    このフォーラムには大変お世話になりました。この記事の閉鎖の方法がわからないのですが、また皆様の助けを借りることも多いと思いますが今後ともよろしくお願いいたします。

15件の返信を表示中 - 1 - 15件目 (全18件中)
  • トピック「サイト表示ができません」には新たに返信することはできません。