サポート » プラグイン » サイト閲覧にユーザ名とパスワードを要求される

  • 解決済 keisukeyoshi

    (@keisukeyoshi)


    WordPressで作成したブログへアクセスすると毎回認証を求められるようになりました。
    Firefoxブラウザで表示されるメッセージ「このサイトがログインすることを求めています。警告: あなたのログイン情報は test.●●.jp と共有されます。この共有は現在訪れているウェブサイトだけとは限りません。」
    ユーザー名とパスワードの入力を求められますが、設定した覚えはありません。
    テストサイトのURLはブログを作成したデザイン会社のURLです。
    キャンセルを2回押せば普通にサイト閲覧可能ですが、認証画面が毎回邪魔なので表示されないようにしたいです。

    ▼症状が発生するまでの経緯

    2022年7月9日
    WordPressとデータベースのPHPバージョンが古いまま、プラグイン「WordPress Popular Posts」を5.5.1 から 6.0.2へアップデート
    →4日後の7月13日にWordpressから下記のメールが届く

    こんにちは。
    
    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。
    
    今回の場合、WordPress がプラグイン WordPress Popular Posts でエラーを捉えました。
    
    まずはじめに、ご自分のサイト (https://○○.jp/blog/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://○○.jp/blog/blog/wp-admin/post.php?post=2838&action=edit) を開き、同様に問題がないか確認してください。
    
    この問題をさらに調査するにはサーバーホストに連絡してみてください。
    
    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。
    
    https://○○.jp/blog/wp-login.php?action=enter_recovery_mode&rm_token=○○
    
    サイトを安全に保つため、このリンクは 1日 で有効期限が切れます。ですが、心配なく。有効期限後にこのエラーが再度発生すれば新しいリンクをお送りします。
    
    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション5.5.9
    現在のテーマ: jin-child (バージョン 1.00)
    現在のプラグイン: WordPress Popular Posts (バージョン 6.0.2)
    PHP バージョン5.6.21 エラー詳細 エラータイプ E_USER_ERROR が /home/users/2/○○.jp/blog/wp-content/plugins/wordpress-popular-posts/vendor/composer/platform_check.php ファイルの 25 行目で発生しました。 エラーメッセージ: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 5.6.21.

    7月13日の時点ではサイトにアクセスしても異常が見当たらなかったので、Wordpress管理画面では何も変更をせず。
    そして本日に至り、サイト表示時にログインを求められる異常に気付きました。
    再度、下記のメールが届きました

    こんにちは。
    
    WordPress 5.2から、サイトでプラグインやテーマが致命的なエラーを発生させた場合にそれを検知してこの自動メールでお知らせする機能が追加されました。
    
    今回の場合、WordPress がプラグイン WordPress Popular Posts でエラーを捉えました。
    
    まずはじめに、ご自分のサイト (https://○○.jp/blog/) を開き、目に見える問題がないか確認してください。次に、エラーが発生したページ (https://○○.jp/blog/blog/wp-admin/post.php?post=2838&action=edit) を開き、同様に問題がないか確認してください。
    
    この問題をさらに調査するにはサーバーホストに連絡してみてください。
    
    もしサイトが壊れていてダッシュボードに正常に接続できない場合、WordPress には特別な「リカバリーモード」があります。これによりダッシュボードに安全にログインし、さらに調査をすることができます。
    
    https://○○.jp/blog/wp-login.php?action=enter_recovery_mode&rm_token=○○
    
    サイトを安全に保つため、このリンクは 1日 で有効期限が切れます。ですが、心配なく。有効期限後にこのエラーが再度発生すれば新しいリンクをお送りします。
    
    この問題を解決しようとする際、以下の情報を聞かれるかもしれません。
    WordPress バーション6.0.3
    現在のテーマ: jin-child (バージョン 1.00)
    現在のプラグイン: WordPress Popular Posts (バージョン 6.0.5)
    PHP バージョン5.6.40 エラー詳細 エラータイプ E_USER_ERROR が /home/users/2/○○.jp/blog/wp-content/plugins/wordpress-popular-posts/vendor/composer/platform_check.php ファイルの 25 行目で発生しました。 エラーメッセージ: Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 5.6.40.

    ▼改善のために試したこと
    「WordPress Popular Posts」プラグインを6.0.2から最新版6.1.1へアップデート
    →「WordPress Popular Posts」プラグインを無効化
    →ブラウザのキャッシュを削除
    https://○○/blog/ へアクセス
    →改善なし。ユーザー名とパスワードを要求される

    リカバリモードになっていたのでリカバリモードを終了
    →改善なし

    ▼原因の推測
    WordPressとデータベースのPHPはバージョンが最新ではない。
    そこに7月9日「WordPress Popular Posts」プラグイン6.0.2へアップデートしたことで、データベースの古いPHPバージョンと相性が悪く、致命的なエラーが発生した。
    プラグインのバグが改善された最新版 WordPress Popular Posts 6.1.1へ本日アップデートしたが、Wordpressかデータベースのどこかで致命的なエラーが起きているので、プラグインをアップデートしてもWordpressやデータベース自体は修復されない。

    ▼実行したいこと
    ロリポップのバックアップオプションに加入しており、2022年11月時点まではバックアップが残っているが7月以前のバックアップは残っていない。
    記事更新が半年以上停止しているブログなので過去の状態へ復元することは構わないが、11月時点に戻すことで直るのかも分からない。
    復元以外に直す方法があれば試したいです。

    長文となり大変恐縮ですが宜しくお願い申し上げます。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • こんにちは。

    私はWordPress Popular Postsプラグインの開発者です。

    ご推察の通り、問題はあなたのサイトが非常に古いバージョンのPHPを使用していることです。

    この問題を解決するには、ホスティングプロバイダーに頼んで PHP のバージョンを少なくとも 7.2 に更新してもらうか、プラグインをバージョン 5.5.1 にダウングレードする必要があります。

    私は日本語を話せないので翻訳機を使用していますが、私の言ったことを理解していただけると幸いです。

    こんばんは。

    ロリポップのいまの仕様を見ますとPHPは7.2のようです。
    ロリポップさんのサポートさんに連絡をしてみてはいかがでしょうか。

    https://lolipop.jp/service/server-spec/

    サポート連絡先は下記です。
    https://lolipop.jp/support/

    トピック投稿者 keisukeyoshi

    (@keisukeyoshi)

    Mr. Héctor Cabrera
    Thank you for your answer

    Rei Narumiya さん
    コメントありがとうございます!
    最初にロリポップへ問い合わせたのですが、Wordpressに関しては専門外のためWordpressフォーラムへ質問するようにとのことでした。
    エラーメールやロリポップの管理画面を見るとPHPバージョンは5.6です。
    プラグインを無効化しても改善してないので、PHPバージョンをアップグレードしても根本解決せず、新たな問題が生まれるかもしれないのが心配です。
    まずはバックアップ復元で過去の状態へ戻してみるのが一番良いでしょうか?

    keisukeyoshi さん、こんにちは。

    プラグインのエラーの件は、すでにコメントがついているので、認証の件についてのコメントです。

    Firefoxブラウザで表示されるメッセージ「このサイトがログインすることを求めています。警告: あなたのログイン情報は test.●●.jp と共有されます。この共有は現在訪れているウェブサイトだけとは限りません。」
    ユーザー名とパスワードの入力を求められますが、設定した覚えはありません。
    テストサイトのURLはブログを作成したデザイン会社のURLです。

    本番公開しているサイトに テストサイトの URL が紛れ込んでいるということは無いでしょうか。

    具体的には、Webブラウザで開いた WordPressで作成したブログページの HTML から読み込んでいる外部ファイル( CSS / JavaScript / 画像 等) の中に、 テストサイトの URL ( test.●●.jp )から始まる絶対パスで書かれたファイルを読み込んでいる記述が残っていたりしないでしょうか。

    • この返信は1年、 2ヶ月前にKOJIが編集しました。
    • この返信は1年、 2ヶ月前にKOJIが編集しました。
    トピック投稿者 keisukeyoshi

    (@keisukeyoshi)

    KOJIさん
    コメントありがとうございます!
    なるほど、その可能性ありますね。
    探してみます!

    トピック投稿者 keisukeyoshi

    (@keisukeyoshi)

    プラグインで検索をかけて、テストサイトURLなどの不要部分を削除で解決しました。
    コメントくださった皆様ありがとうございます!

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「サイト閲覧にユーザ名とパスワードを要求される」には新たに返信することはできません。