サポート » 使い方全般 » テーマ有効でエラー発生

  • 解決済 ytonksuket

    (@ytonksuket)


    WordPressのバージョンが古いまま、Lightningのテーマをインストールして有効化したらエラーで真っ白な画面になりました。
    検索したらFTPからテーマを削除すれば元に戻るとあったので削除して元に戻したのですが、原因を調べずに同じ状況のまま再度Lightningをインストールして有効化してみたらやはりエラーで真っ白になってしまいました。
    またFTPからテーマを削除しようと思ったらFTPにはLightningのテーマがありません。エラー画面のまま何も操作ができなくなってしまったのですが、どうすれば元に戻せるのでしょうか?

    勉強不足で申し訳ありませんが、どなたかご教授いただけますと幸いです。
    よろしくお願いいたします。

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • こんにちは。

    2度目に Lightning のテーマをインストールしたとき、管理画面から行いましたか?
    もしそうであれば、WordPressのインストールディレクトリ -> wp-content -> themes の配下に、Lightning がありませんか?

    FTPクライアントで上記のフォルダにアクセスしているか再度ご確認いただけますか?

    スレッド開始 ytonksuket

    (@ytonksuket)

    Yukinobu Asakawa様。
    さっそくのお返事ありがとうございます。

    インストールした時は管理画面から行いました。
    FTPを一度切って再接続などしていたらthemesの中にLightningが出てきました!これを削除したら元に戻せました!ありがとうございます!

    やはりこの原因はWordPressのバージョンが古いせいなのでしょうか?
    ちなみに現在は5.5.38です。
    PHPを更新しないとバージョンアップができないようです。

    良かったですね。
    Lightningのページで確認すると、

    WordPress バージョン: 5.3またはそれ以降
    PHP バージョン: 5.6.0またはそれ以降

    となっています。
    まずは、WordPressのバックアップ作業を行ってから、サーバー(ご契約されているレンタルサーバーなど)のサーバー管理画面からPHPを最新版にバージョンアップすることをおすすめします。

    WordPress のバックアップ
    https://ja.wordpress.org/support/article/wordpress-backups/

    PHP バージョンの更新
    https://ja.wordpress.org/support/update-php/

    > ちなみに現在は5.5.38です。

    これはPHPのバージョンですよね?

    PHPのバージョン5系は流石に古いのでなんとか7系最新にアップがお勧めです。

    スレッド開始 ytonksuket

    (@ytonksuket)

    Yukinobu Asakawa様。
    ご丁寧にありがとうございます。

    サーバーからPHPのバージョンアップを試していますが、なぜかうまく行えていないようです…
    さすがにその質問はWordpressから離れてしまうのでこちらでの質問は適切ではないですよね。
    もうちょっと調べてみます!

    本当にご丁寧にありがとうございました!

    スレッド開始 ytonksuket

    (@ytonksuket)

    kurudrive様。
    お返事ありがとうございます。

    あ!そうです。5.5.38はPHPのバージョンでした。
    現在サーバーから最新版に更新を試みているのですが、何度やってもWordPressの更新欄の『PHP バージョン5.6.20以上が必要なため、更新できません。』が切り替わらず苦戦しています。

    なるほど。
    一度、サーバー側の PHP がバージョンアップしているか、サーバー会社さんにお問い合わせいただく方が良いかもしれません。
    あと可能性として考えられるのは、.htaccess などで PHP のバージョンを指定しているということは考えられます。
    ご自身で覚えがない場合には、サーバー管理者の方に確認していただいた方が良いと思います。

    参考記事:.htaccessでPHPのバージョンを指定する方法
    https://blog.heteml.jp/?p=5509

    スレッド開始 ytonksuket

    (@ytonksuket)

    Yukinobu Asakawa様。
    ありがとうございます。

    参考記事を読ませていただき、それでも解決に至らなかったらサーバー会社さんに問い合わせてみようと思います。
    最後までご丁寧にありがとうございます。

    ytonksuketさん、こんにちは。

    現在サーバーから最新版に更新を試みているのですが、何度やってもWordPressの更新欄の『PHP バージョン5.6.20以上が必要なため、更新できません。』が切り替わらず苦戦しています。

    PHPをサーバーから最新版に更新されれいるのですか?それはサーバーの管理画面から更新しているという認識でよろしかったでしょうか。
    PHPのバージョンアップを行うならば、まずはWordPressを忘れてください。少なくともWordPressの管理画面からPHPのバージョンアップは実施できません。また、基本的にFTP接続でもPHPのバージョンアップは実施できないと考えてください。

    yukinobuさんの仰る通り、サーバー屋さんが何らかの手段を用意している場合のみ、FTP等で特定のファイルの記載を変更することでPHPのバージョンを変更する(アップデートではない)ことが可能かと思います。

    ここでサポートできる訳ではありませんが、どちらのサーバーをお使いか(お名前やさくらインターネット等と可能であればプラン名)参考までにお伺いできると、サポートの情報くらい教えてくれる優しい方がいるかもしれません。

    ご参考になれば。

    スレッド開始 ytonksuket

    (@ytonksuket)

    shokun0803様。
    遅くなり申し訳ございません。お返事ありがとうございます。

    PHPの更新はサーバーの管理画面から行ってみたのですができなかったので、Yukinobu Asakawa様から教えていただいた参考記事を読みながらFTPからファイルの編集をしたら先ほど無事にPHPの更新ができました!
    その後、Wordpressのバージョンアップも無事完了しました!

    この度はご丁寧にありがとうございました!

    スレッド開始 ytonksuket

    (@ytonksuket)

    お返事くださった皆様、この度はありがとうございました。
    皆様の助言のもと、無事に解決に至りました。

    まだまだ勉強中の身の為、また調べてもわからないことがあったら助言をお願いするかもしれません。
    私も数ヶ月後、数年後に皆様のように初学者の方の手助けができるように頑張ります。

    ありがとうございました。

    ご報告確認しました。無事解決できて良かったです。
    勉強頑張ってくださいね。

    スレッド開始 ytonksuket

    (@ytonksuket)

    Yukinobu Asakawa様。
    ありがとうございます!頑張ります!

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • このトピックに返信するにはログインが必要です。