サポート » テーマ » テーマ(2016)のアップバージョンについて

  • 解決済 itiyama

    (@itiyama)


    こんにちは。スイマセン。お尋ねします。

    WordPressで、Twenty Sixteenをテーマで使っています。

    バージョンアップについて、ご相談です。
    子テーマの利用を考えねばならないのですが、
    実施できていません。

    当方のバージョンは、1.4(Twenty Sixteen) です。

    現在は、1.9 が公開されています。
    当方は、
    style.css、functions.php、footer.php
    この3つのファイルに、変更を加えています。

    何処を変更したのかは、詳細に記録していません。

    Twenty Sixteenを1.9 にバージョンアップ後に、

    上記の3つのファイルを上書きして、それで大きな問題は生じないのでしょうか?
    是非、お教えいただきたく、アップバージョンする前に、
    お尋ねした次第です。よろしくお願い申し上げます。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • CG

    (@du-bist-der-lenz)

    Twenty Sixteenを1.9 にバージョンアップすると置き換えられるので、「style.css、functions.php、footer.php
    この3つのファイルに、変更を加えています。」と、はっきりしているので、子テーマにします。

    こんにちは

    Twenty Sixteen バージョン 1.4 は下記よりダウンロードすることができます。
    https://downloads.wordpress.org/theme/twentysixteen.1.4.zip

    オリジナルのファイルと比較すると変更箇所がわかるのではないでしょうか?
    WinMerge などのファイルの差分比較の機能を持つツールを使うと、変更箇所を簡単に特定することができます。

    差分を元に子テーマを作成することをおすすめします。

    ishitaka さま
    ありがとうございます。子テーマを作成せよとのご指示、わかりました。
    今から、その方向で、進んでみます。また、上手くいったら、お礼をご連絡いたします。

    CG さま
    こんにちは。ありがとうございました。
    子テーマにすることが必須だと了解しました。
    出来るだけ、早い段階でその方向へと進みます。

    CG

    (@du-bist-der-lenz)

    公式テーマディレクトリにある、「Twenty Sixteenの子テーマ」が、助けになりますよ。 https://ja.wordpress.org/themes/search/twenty%20sixteen/

    CG さま
    おはようございます。「Twenty Sixteenの子テーマ」を、
    お教えいただきありがとうございます。どのページが分かりません。
    いいページを探してみます。

    • この返信は1年、 4ヶ月前にitiyamaが編集しました。理由: 間違いました。
    • この返信は1年、 4ヶ月前にitiyamaが編集しました。

    子テーマの作り方は、下記ページが参考になると思います。
    http://wpdocs.osdn.jp/子テーマ

    ishitaka さま
    ありがとうございました。努力して、子テーマを作成していきます。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「テーマ(2016)のアップバージョンについて」には新たに返信することはできません。