サポート » 使い方全般 » バックエンド一部のみで発生する502エラー

  • 解決済 daigo

    (@studio_pastel)


    お世話になります。

    ■環境
    WordPress ver.4.8.2
    CentOS / Apache1.3.42 / PHP5.2.5

    上記環境にインストールをしたところ、通常通り完了したのですが、
    バックエンドの下記ページにアクセスすると、[502 Bad Gateway]エラーが発生します。
    themes.php
    plugins.php
    plugin-install.php
    options-general.php
    profile.php

    上記5ページ以外ではエラーは発生せず、新規投稿等のデータベースとの接続も問題ありません。
    フロントも問題なく表示、動作している状態です。

    インストール直後に発生しているため、テーマはTwenty Seventeenのままで、
    一切のカスタマイズはしておりません。

    ある意味、データベースを直接編集しさえすれば、テーマ編集やプラグイン導入は、FTP経由などで
    対応可能であり、なんとかなりはするのですが、やはりエラーが出たままにしておくのもどうかと思い、
    解決したい次第です。

    ヒントが少なく、どのように解決したものか、頭を悩ませております。

    同様のケースや解決策をご存知の方、ぜひご教授いただけましたら幸いです。

    よろしくお願いいたします。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • munyagu

    (@munyagu)

    こんにちは

    解決方法は分かりませんが、WordPress自体の問題ではない気がするのですが・・・

    Apacheのerror_logを確認してみてください。

    モデレーター Okamoto Hidetaka

    (@hideokamoto)

    Apache1.3にPHP5.2.5というのはちょっと古すぎるかなという気がします。。。
    WordPress自体は後方互換性を重視しているのである程度動作してくれるとは思いますが、
    最新版へのアップデートをお勧めします。

    daigo

    (@studio_pastel)

    > munyaguさま

    ご返信ありがとうございます。
    ご指摘のとおり、インストールそのものは正常終了したのちのクリーンな状態ですので、WordPress自体ではなく、環境要因だと思います。
    なお、サーバー業者に連絡を取ったところ、apacheのerror_log提供は不可とのことでした。

    > Okamoto Hidetakaさま

    ご返信ありがとうございます。
    古いですよね。
    先月にPHP4からPHP5.2.5にアップデートしたそうで、時代錯誤ではないかと呆れておるところです。やはりサーバーの要件が完全に満たせていない現状での正常動作の確保は難しいということですね。

    クライアントの都合で、サーバー変更ができなさそうなので、DBを直接編集しながら作業を進める方向で検討したいと思います。制作自体が無事に完了したとしても、将来的な問題を少なからずはらんでいるので、好ましくはありませんね……。

    おふたりとも迅速にご返信いただき、本当にありがとうございます。

    もう少しだけ回答をお待ちしてみて、結論が変わらないようであれば、解決済にさせていただきます。

    • この返信は2 ヶ月前に  daigo さんが編集しました。
    CG

    (@du-bist-der-lenz)

    パーミッションが設定されていないか、起動していないか、ログインユーザーではなくサイトオーナーになっているとか設定に間違いがあるのでしょうか。

    daigo

    (@studio_pastel)

    CGさま

    ご返信ありがとうございます。
    該当のファイルのパーミッションは644です。

    ただ、インストール時、wp-configは自動生成されなかったり、
    現状、テーマファイルの編集がtheme-editor.phpからはできなかったりと、
    パーミッション怪しいです……。

    daigo

    (@studio_pastel)

    ものはためしと、WordPress 3.4.1をインストールしてみようとしたところ、
    wp-configのデータベース情報の入力後、次の画面に進むと、
    ERR_EMPTY_RESPONSE
    となり、インストール不可でした。

    こうなってくると、パーミッションか、php.iniの設定でしょうか……??

    munyagu

    (@munyagu)

    ググってみましたが、パーミッションが原因でERR_EMPTY_RESPONSEが出るという問題はなかったようですが・・・以下のサイトが詳しそうです。

    http://www.multiburst.net/sometime-php/2010/05/net-err-empty-response/

    しかし、レンタルサーバー上でインストール出来なかったり、インストールしても動かないということであれば、サーバー会社に問い合わせて解決してもらってはどうでしょうか?

    daigo

    (@studio_pastel)

    munyaguさま

    ご返信ありがとうございます。

    ご教授いただいたサイトを参考にeAcceleraterの設定等見直しましたが、、
    変わらず、といった具合でした。

    サーバー会社からは「WordPressの正常挙動を実現しているユーザーもいる」との返答のみで、
    その施策の教授およびアップグレード等の対応も不可とのことでした。

    また、バックエンドに限りますが、他ページでもまれにERR_EMPTY_RESPONSEに遭遇しました。
    理由も見えてこない上、やはり不安定すぎるので、当初は予定にありませんでしたが、
    サーバー業者を変更することにいたしました。

    解決できておらず、申し訳ありませんが、
    一旦スレッドとしては解決済としてクローズさせていただくようにいたします。

    ご回答いただいた皆さま、ありがとうございました。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • このトピックに返信するにはログインが必要です。