サポート » インストール » バージョンアップ、プラグイン更新失敗

  • 解決済 seiji123123

    (@seiji123123)


    昨晩、ワードプレス管理画面から
    プラグインの更新を致しました。

    そのあと、ブログ記事にアクセスすると
    エラーメッセージが表示され閲覧できません。

    まずエラーメッセージ内容の意味を知りたいです。
    そして、もう一度ブログを閲覧できる解決方法を教えてください。
    宜しくお願いします。

    エラーメッセージ
    Warning: require(/home/ユーザー名/ブログURL/public_html/wp-includes/class-wp-roles.php): failed to open stream: No such file or directory in /home/ユーザー名/ブログURL/public_html/wp-settings.php on line 125

    Fatal error: require(): Failed opening required ‘/home/ユーザー名/ブログURL/public_html/wp-includes/class-wp-roles.php’ (include_path=’.:’) in /home/ユーザー名/ブログURL/public_html/wp-settings.php on line 125

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • 메텔

    (@digitmaetel)

    メッセージは、wp-settings.php がディレクトリ先に見つからないとで 125 行目を読めないという、class-wp-roles.phpからのメッセージです。

    ありがとうございます。
    それでは125行目を確認してみます。

    class-wp-roles.php が見つからない、という wp-settings.php からのメッセージだと思います。

    wp-includes/class-wp-roles.php が WordPress 4.4.0 から追加されたファイルのようです。
    WordPress 本体の更新を要するのではないでしょうか。

    ありがとうございます。
    ワードプレスのHPから4.4をダウンロードしましたがセットアップウィザードが表示されません。
    拡張子に対応したソフトをインストールする必要がありますでしょうか?

    WordPress 本体の更新を要するのではないでしょうか。

    とは言いましたが、コアのアップデートにあたってはいろいろ気をつけなければいけないことも多そうなので、アップデートしたプラグインのバージョンを落とす方向で対処してみるのがよいかもしれませんね。

    https://ja.forums.wordpress.org/topic/157304?replies=4

    ワードプレスのHPから4.4をダウンロードしましたがセットアップウィザードが表示されません。
    拡張子に対応したソフトをインストールする必要がありますでしょうか?

    下記ご参照ください。

    アップグレード

    参考URLありがとうございます。
    しかし、うまく理解できず苦戦してます。
    リモートサポート窓口はありますでしょうか?

    半年間大量の時間を注いで作ってきたブログが
    たった数クリックの失敗で閲覧不可になるなんて
    残念すぎます…。どうにかしたいです。

    リモートサポート窓口はありますでしょうか?

    このフォーラムで助力できる範囲としては無いと思います。

    プラグインの更新でエラーが発生したのであれば、wp-content/plugins の中の全てのディレクトリー、phpファイルをリネームして無効化してみてはいかがでしょう。

    また、下記もご参照ください。

    WordPress › フォーラム » 問題解決のためのチェックリスト

    まだ改善できていません。
    思い出してみると、プラグインの更新はできたと思います。そのあと、ワードプレスの更新を押したところ一度無反応でもう一度更新を押したのは確かです。

    バージョンはもともと4.1でして2ヶ月ほど更新操作を放置していました。

    今はフォルダの内容を確認したり
    有料ソフトをダウンロードしてソースコードを読んでいますがまだ改善がみつかりません。

    12/9に操作してからこのような状況なので
    12/9以降に生成されたファイルを全て削除してみようと思います。

    削除しても全くかわりませんでした。

    現在も同じエラー表示
    Warning: require(/home/seiji32921/aga-bbs.com/public_html/wp-includes/class-wp-roles.php): failed to open stream: No such file or directory in /home/seiji32921/aga-bbs.com/public_html/wp-settings.php on line 125

    Fatal error: require(): Failed opening required ‘/home/seiji32921/aga-bbs.com/public_html/wp-includes/class-wp-roles.php’ (include_path=’.:’) in /home/seiji32921/aga-bbs.com/public_html/wp-settings.php on line 125

    메텔

    (@digitmaetel)

    思い出してみると、プラグインの更新はできたと思います。そのあと、ワードプレスの更新を押したところ一度無反応でもう一度更新を押したのは確かです。

    無反応に見えてファイルの入れ替えが実行されている最中だったのではないでしょうか。
    更新中にブラウザのタブを移動したり、別のアプリケーションに移ったりしませんでしたか、わたしからの提案は mimosafa さんと同じ見解です。

    ワードプレスのHPから4.4をダウンロードして解答したファイルで、WordPressを手動アップデートするのが良いでしょう。

    ご指導ありがとうございました

13件の返信を表示中 - 1 - 13件目 (全13件中)
  • トピック「バージョンアップ、プラグイン更新失敗」には新たに返信することはできません。