サポート » プラグイン » バージョン 3.8.3で不明なエラー"/plugin-install.php on line 77"が表示

  • 解決済 majorsystem

    (@majorsystem)


    本日、wordpressを3.8.3にアップデートをかけました。
    アップデートの結果、以下のエラーが表示されました。(以下のエラーが2件出てました。)
    —————-
    Warning: 不明なエラーが発生しました。WordPress.org またはこのサーバーの設定に何か問題が起きている可能性があります。問題が解決しない場合はサポートフォーラムに投稿してみてください。 (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /usr/home/(サーバーのアカウント)/html/wp-admin/includes/plugin-install.php on line 77
    ——————

    plugin-install.php on line 77行目(多分・・・)
    ——————–
    trigger_error( __( ‘An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.’ ) . ‘ ‘ . ‘(WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.)’, headers_sent() || WP_DEBUG ? E_USER_WARNING : E_USER_NOTICE );
    ——————-

    使用しているプラグインは27あります。
    1 .html on PAGES
    2 Akismet
    3 AStickyPostOrderER
    4 brBrbr
    5 Breadcrumb Navigation XT
    6 Category Order
    7 Contact Form 7
    8 Custom Field Gui Utility
    9 Customizable Post Listings
    10 Dagon Design Sitemap Generator
    11 Disable XML-RPC Pingback
    12 Easy Tube
    13 Fancybox
    14 Folding Category List (FoCaL)
    15 Force Wave Dash
    16 Google XML Sitemaps
    17 iThemes Security
    18 My Category Order
    19 My Tag Cloud
    20 Other Posts From Cat
    21 Really Simple CAPTCHA
    22 Search Everything
    23 Smart Update Pinger
    24 Top Level Categories
    25 WordPress Database Backup
    26 WP-DBManager
    27 WP Multibyte Patch

    ※サイトもプラグインも通常に機能しているように見えます。

    エラーの対処をしたいのですが、どのようにすればよいでしょうか。
    よろしくおねがいします。

15件の返信を表示中 - 1 - 15件目 (全18件中)
  • 日本語バージョンが出る前に,3.8.3に手動あるいは自動アップデートされたときに,もしかしたら不具合が出るかもしれないと思ったところがあります。

    今回の更新ファイルに, version.php が含まれていますが,ローカライズ版の場合,これの最後に
    $wp_local_package = ‘ja’;
    が入っています。これが,グローバル版で上書きされると消えてしまいます。

    全く関係ないかもしれないのですが,3.8.3へのアップデートでの不具合ということですので, version.php を確認してみてはいかがですか。

    o6asan様ありがとうございます。
    アップデートを確認しましたところ「バージョン 3.8.3–en_US」をインストールしていました。
    日本語バージョンをインストールしているつもりだったのでずか・・・
    確認します。ありがとうございました。

    もう一つ質問ですが、日本語のバージョン3.8.3が出た場合、現在の「バージョン 3.8.3–en_US」を当てた状態から日本語のバージョン3.8.3を当てても問題ないでしょうか。
    よろしくお願いします。

    もう一つ質問ですが、日本語のバージョン3.8.3が出た場合、現在の「バージョン 3.8.3–en_US」を当てた状態から日本語のバージョン3.8.3を当てても問題ないでしょうか。

    これは,やったことがないのでわかりません。

    ローカルに,3.8.2のファイルが残っていれば,ロールバックしてはどうでしょうか。

    今回のマイナーアップデートで3.8.2と違う主なものは,

    wp-admin/includes/upgrade.php
    wp-admin/includes/post.php
    wp-admin/about.php
    wp-includes/version.php
    readme.html

    だけです。これは,3.8.3–en_USでも同じだと思います。したがって,アップデートとしては,この5つだけを差し替えればいいわけです。

    その際に,グローバル版の version.php には,
    $wp_local_package = ‘ja’;
    がないので,もしかしたらエラーになる場合もあるかもしれないと思ったわけです。

    これが不具合の原因かどうかは,私にはわかりませんが。

    ありがとうございます。

    確認したところ、インストールされた version.php には,
    $wp_local_package = ‘ja’;
    が入っていませんでした。

    今回のアップデートされたファイルが上記5ファイルということで、
    3.8.2のバックアップがありますので差し替えて元にもどしたいと思います。
    ありがとうございました。

    今回のアップデートされたファイルが上記5ファイルということ

    はい,ということなものだから,3.8.2-jaのあるところに

    wp-admin/includes/upgrade.php
    wp-admin/includes/post.php
    wp-admin/about.php
    wp-includes/version.php
    readme.html

    の新ファイルを上書きすると,3.8.3ということになります。

    ただし,このときに,version.phpには忘れずに
    $wp_local_package = ‘ja’;
    を追記しておくべきだろうというのが,私の意見です。これで,エラーがなくなればいいですね。

    バージョン3.8.2-jpを使用しています。
    本日プラグインAkismetを自動アップデートしたところ、以下のアラートが表示されました。Akismetは正常に更新されました。Wordpressの表示にも問題が無いようなんですが…

    似たようなエラーに思えるのですが、原因は全く違うのでしょうか?
    もし、よろしければmajorsystemさんの状況をお知らせいただけますか?
    よろしくお願いします。

    ■設置サーバ会社:heteml

    Warning: 不明なエラーが発生しました。WordPress.org またはこのサーバーの設定に何か問題が起きている可能性があります。問題が解決しない場合はサポートフォーラムに投稿してみてください。 (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/(サーバーのアカウント)/wp-includes/update.php on line 272

    Warning: 不明なエラーが発生しました。WordPress.org またはこのサーバーの設定に何か問題が起きている可能性があります。問題が解決しない場合はサポートフォーラムに投稿してみてください。 (WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.) in /home/(サーバーのアカウント)/wp-includes/update.php on line 417

    私も上記、ROOM441さんと同じ現象が昨日から起きています。
    バージョン3.8.2-jpです。
    バージョン3.8.3-jpでも起こります。
    設置サーバ会社はhetemlです。
    原因が分かりません。

    同じく設置サーバ会社はhetemlで、同じエラーが起こります。

    サーバー会社側の問題のようです。

    hetemlに問い合わせたところ、
    SSLでの接続に不都合があるので、現在修正中の連絡が来ました。
    以下、修正完了までの対応方法を問い合わせメールから転載します。
    —————-
    上記のエラーが表示された場合でもWordPress内でSSL通信を
    非SSL通信に切り替え、プラグインのインストール/更新を
    行なうことが可能です。
    —————-

    SSL がらみだったんですか。

    日本語のメッセージに気を取られて,
    ~ not establish a secure connection ~
    を見落としていました。

    majorsystem様,すみません。
    見当違いの書き込みで,ご迷惑をかけたかもしれません。

    o6asanさん、
    こちらでいろいろ書き込んで下さったおかげで、Googleでたどり着き、
    もしかしたら、サーバーがらみ?と思い当たる事ができました。
    majorsystemさん、ともども感謝です。
    とりあえず、hetemlで運営している方はSSLがらみ、でOKだと思います。

    それとは別に、バージョンアップの際のチェック、勉強になりました!

    …majorsystemさんも同じ原因だといいんですが。

    메텔

    (@digitmaetel)

    サーバーに繋がりにくい障害につきまして

    heteml では現在はメールサーバーの障害に対応している最中のようです。
    対応が進むのを待つことにしてます。
    バックグラウンド更新はエラーになっているようですが、
    ダッシュボード内でのプラグイン、テーマの更新は実行できています。
    更新中にエラーはズラリと表示されてドキッとしますが、一旦更新が完了すればダッシュボード内でのエラー表示は見られなくなりました。

    皆様と同じく、
    wp-admin/includes/plugin-install.php on line 77
    のエラーが起こっております。

    サーバーはCORESERVERです。
    ロリポップでは同様のエラーは発生しませんでした。

    情報が少ないようなので、ご参考になればと思い書き込みさせていただきました。

    WordPress3.9がリリースされたようですが、これにアップデートすることでこの問題は解決するのでしょうか?
    とりあえず諸々のアップデートは日本語版のリリースを待つことにしています…

    WordPress3.7.1、3.8.3で同じエラーが発生しているようでした。(CORESERVER)
    プラグインの更新を実行したらエラーは表示されなくなったことをご報告いたします。

    私も
    wp-admin/includes/update.php on line 117
    のエラーが出ております。
    ワードプレスのパフォーマンスが著しく低下し、表示にも不具合が生じています。
    サーバーはhostgatorです。

15件の返信を表示中 - 1 - 15件目 (全18件中)
  • トピック「バージョン 3.8.3で不明なエラー"/plugin-install.php on line 77"が表示」には新たに返信することはできません。