サポート » 使い方全般 » パスワードかけた投稿ページの画像がGoogleの画像検索ででてきてしまいま

  • 解決済 kazuvegas

    (@kazuvegas)


    一部の人のみに公開するために投稿ページにパスワードをかけています。

    しかし、自分のHP名でGoogleの画像検索をすると、パスワードかけたはずのページの画像がGoogleのサムネイルで表示されてしまいます。

    これを防ぐためにいい方法はありませんか?

    バスワードをかけるとクローラーは入ってこないと思うのですが、設定方法がおかしいのでしょうか?

    テーマはデフォルトのテーマで、パスワード昨日もそのデフォルトの機能を使っています。

    宜しくお願いいたします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • 表示設定の「検索エンジンがサイトをインデックスできないようにする」にチェックが入っていないのではありませんか。
    そして、
    .htaccess ファイルにクロールをさせない宣言をしておいて投稿するのが良かったでしょう。

    画像検索で表示される画像のアドレスはどうなっていますか。
    投稿ページはパスワードを掛けても、投稿ページの閲覧にパスワードが必要にするものでサーバーにアップロードしたファイルはインターネット上にあることに変わりがないので、画像ファイルへの直接アドレスをGoogleがクロールしたため検索できるようになっている。ということなのでしょう。

    robot.txtファイルを使ってクローラーの拒否をするといいと思います。
    例えばこういうページなどで設定が説明されています
    http://memorva.jp/memo/website/robots_txt.php

    また 画像検索からの削除というページも参考になるのではないでしょうか?

    モデレーター gatespace

    (@gatespace)

    横からスイマセン。

    まず、「検索エンジンがサイトをインデックスできないようにする」にチェックを入れると<head>タグ内に <meta name='robots' content='noindex,nofollow' />が追加されます。
    これは全てのページに対して行われますので、投稿に制限をかけていないサイトトップやアーカイブ系のページにも影響を及ぼします。

    そして、この設定に合わせてWordPressはrobots.txtを自動で生成します。
    これについては以前、自分でブログ記事を書いたので、参照していただけると幸いです。

    WordPressで自動生成されるrobots.txt

    なお、nekomimiTaichoさんが書かれているように、自分でrobots.txtを設置した場合はそちらが優先されます。
    WordPressにアップロードした画像類は /wp-content/uploads/ に保存されているので、このディレクトリのみクローラーを拒否すればいいと思います。

    ただし、一度検索エンジンにインデックスされてしまった場合は次にクローラーが来るまでは、検索対象となっていますので、nekomimiTaichoさんの投稿されたリンク先もあわせてご覧ください。

    (補足)
    投稿に対してWordPressのパスワード制限をかけても、そこに配置されている画像は投稿ページとURLが異なる(別の場所にアップロードされている)のでインデックスされる可能性があります。
    (投稿を見ると画像は全て http:// から書かれているのが分かると思います)

    これで満足がいかなかった場合ですが、
    .htaccess を用いて画像そのものへのアクセスを制限する(直リンクを防ぐ)方法もありますが、デメリットもありますのでまずはrobots.txtを設置することで様子を見てください。

    こんにちは、

    kazuvegasさんの WEBサイトで確認していただきたいのですが、

    WEBサイトのURL/wp-content/uploads/ を表示してみてください。

    サーバー設定によっては、

    Index of /wordpress/wp-content/uploads/

    といった表示とともに、画像へのリンクリストが表示される事があります。

    このリストは、WordPressとは無関係にサーバーの機能で表示されます。

    このページが表示されている場合は、クロールされてしまうと思います。

    uploadsディレクトリ以下のディレクトリには、index.htmlなどが、デフォルトでは、配置されていないため、サーバーの設定の問題が、表面化しやすいです。

    これを見えなくするためには、

    .htaccessファイルに、

    Options -Indexes

    を記述していただくと、インデックスは表示されなくなり、403エラーが表示されます。

    .htaccessがよくわからない時には、すべてのディレクトリに、index.htmlという空のテキストファイルを置いてみてください。

    kazuvegas

    (@kazuvegas)

    みなさん、たくさんのコメントありがとうございます。

    みなさまの意見をいただいた結果、
    robots.txtファイルをルートフォルダーに設置し、
    /wp-content/uploads/のフォルダだけインデックスしないように記述をしました。

    サイト自体はインデックスしてほしいので、今回はWPの管理画面からは触らず、
    直接サーバーにrobots.txtを設置しました。

    nobitaさん、ためしてみましたがindexファイルを置かなくても403が出てくれました。
    いつもわかりやすい説明ありがとうございます。今後ともよろしくお願いいたします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「パスワードかけた投稿ページの画像がGoogleの画像検索ででてきてしまいま」には新たに返信することはできません。