サポート » 使い方全般 » パーマリンク設定後404エラー

  • はじめての投稿になります。よろしくお願いします。
    パーマリンクに関する404エラーの過去記事は一通り読みましたが、解決できず投稿させていただきます。

    ubuntu+apache+mysql 上にwordpress3.0.1をインストールしました。
    なにも記事は投稿していない(デフォルトのみ)状態です。
    そこでパーマリンクの設定をデフォルトから変えてみたところ、TOPページ以外が404エラーになってしまいます。
    mod_rewrite の起動は行っておりますし、.htaccessのパーミッションも666に変更しております。(Webルートディレクトリに配置)
    そもそも初心者でして、どういった挙動がただしいのかすら分かっていません。
    行き詰まってしまっておりまして、有識者のお知恵をお借りできないかと。

    お手数ですが、よろしくお願いいたします。

    ★以下がWebルートディレクトリです。
    /opt/myblog

    ★アパッチエラーログ
    [Thu Sep 02 19:11:12 2010] [error] [client XXX.XXX.XXX.19] File does not exist: /opt/myblog/2010, referer: http://XXX.XXX.XXX.52/

    ★mod_rewrite起動
    $ sudo a2enmod rewrite
    Module rewrite already enabled

    ★.htaccess
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • モデレーター jim912

    (@jim912)

    taka.ike@gmail.comさん、こんにちは。

    apacheのエラーログからするに、mod_rewriteが効いていないのは明白です。
    となると、apache設定ファイルのAllowOverride Allに記述されおらず、.htaccessが有効になっていないとか、mod_rewriteが正しく起動していないなどが考えられます。

    トピック投稿者 taka.ike@gmail.com

    (@takaikegmailcom)

    jim912さん

    ありがとうございます!
    mod_rewriteが効いていないのですね。
    apache設定ファイルを再確認したところAllowOverride Allが設定されていない部分がありました。。。おはずかしい。。。
    以下ファイル*****************
    <VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /opt/myblog
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory “/usr/lib/cgi-bin”>
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /var/log/apache2/access.log combined

    Alias /doc/ “/usr/share/doc/”
    <Directory “/usr/share/doc/”>
    Options Indexes MultiViews FollowSymLinks
    AllowOverride All
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    </VirtualHost>
    ***********************

    2日ほど作業が止まっていましたのでほんとに助かりました。
    ありがとうございます。

    こんにちは。
    同様の現象が起きて困っているのですが、お恥ずかしながら全くの初心者で「mod_rewrite の起動」をどのようにすればいいのかがわかりません。

    どなたか教えていただけますでしょうか。
    よろしくお願いいたします。

    補足ですが、「.htaccess」は以下のようになっています。

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    tomatomatoさん、便乗質問はできません、新たにスレッドを立ち上げてください。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「パーマリンク設定後404エラー」には新たに返信することはできません。