サポート » インストール » 3.3 ビジュアルエディタが使えない・・・

  • 3.3にアップグレードしたら、ビジュアルエディタにエラーが発生しHTMLタグしか使用出来なくなりました。

    追加で補足アップグレード版なんか出るんですかね?

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • 3.3にアップグレードしたら、ビジュアルエディタにエラーが発生しHTMLタグしか使用出来なくなりました。

    同様の症状です。明らかにバグだと思います。

    http://wordpress.org/support/topic/visual-editor-is-no-longer-showing-after-upgrading-to-33?replies=13

    に同様の問題が指摘されているようです。

    フルスクリーンにするとVEで編集はできます。ただ、元に戻す時、いったんHTMLにする必要があるようです。

    モデレーター Seisuke Kuraishi (tenpura)

    (@tenpura)

    PHP の JSON 拡張 は有効になっておりますでしょうか?phpinfo() で確認してみてください。

    JSON 拡張がない場合は、3.3の /wp-admin/load-scripts.phpこちら で置き換えてみてください。

    PHP の JSON 拡張 は有効になっておりますでしょうか?phpinfo() で確認してみてください。

    コメントありがとうございます。

    php.infoではver1.2.1でenableとなっています。

    本家も見ていろいろ試しましたがうまくいかなかったので3.3をDLしFTPで上書きインストールをしました(最初は3.21->3.3自動インストール)。

    これによりVEが切り替えできるようになりました。

    その後、わかったのですが、PS Disable Auto Formattingが問題のようです。このプラグインを有効化するとまた同様の症状になりました。

    VEが使えないのは、IEのブラウザの時のみです。

    他のブラウザでログインすると、VEは使用できますがスペースの認識がありません。

    ???

    なぜでしょう・・・

    モデレーター Seisuke Kuraishi (tenpura)

    (@tenpura)

    kenichi.sugawara さん
    3.3 アップグレードに伴う問題とその解決方法 は試されましたでしょうか?
    また具体的にどのようなエラーがでているのでしょうか。

    その後、わかったのですが、PS Disable Auto Formattingが問題のようです。このプラグインを有効化するとまた同様の症状になりました。

    shiny_cloudさんと同じ不具合に遭遇しました。取り急ぎ「PS Disable Auto Formatting」側のPluginを以下に修正しました。

    編集画面で読み込むJavaScriptのパスが絶対パスで出力されているためにスクリプトエラーを起こし、動作不具合が起きているようです。

    ■PS Disable Auto Formatting 1.0.8
    ps_disable_auto_formatting.php 95行目

    $scripyt_src = get_option( 'siteurl' ) . '/' . str_replace( str_replace( '\\', '/', ABSPATH ), '', str_replace( '\\', '/', dirname( __file__ ) ) ) . '/js/330/ps_editor.js';

    $scripyt_src = plugins_url() . '/ps-disable-auto-formatting/js/330/ps_editor.js';

    場当たり的な修正なので、あくまで参考までに残します。
    恐らくwp-config.phpあたりの記載の問題かと。

    落ち着いたら解決方法を考えます。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「3.3 ビジュアルエディタが使えない・・・」には新たに返信することはできません。