サポート » 使い方全般 » フォーラム用のパーマリンクの設定が、ユーザー間で変わってしまう

  • 解決済 satochan

    (@satochan)


    bbPress2.2.3をつかって、フォーラムページを作成したのですが、
    パーマリンクの件で、一点不明の事象が起こっています。

    管理者側で、フォーラムのパーマリンクを、 http://xxxx.jp/forums/forum/%post_id%/  と設定しており、管理者がフォーラムを立ち上げた後、管理者側では、
    トピック/リプライについて問題なく投稿ができます。パーマリンクも設定どおりになっています。

    しかしながら、寄稿者、購読者側では、管理者が立ち上げたフォーラムにアクセスしても、
    ”ページが見つかりません”となってしまいます。
    なおかつ、全く理由がわからないのが、なぜか、パーマリンクの設定が、
    http://xxxx.jp/forums/forum/%postname%/
    になってしまいます。

    パーマリンクは、Custom post type permalinksというプラグインを使用して、
    設定しており、下記の注意書きがあるので、末尾の / はしっかりつけています。

    カスタム投稿タイプのパーマリンクの設定
    カスタム投稿タイプごとのパーマリンク構造を設定できます。
     使用できるタグは、WordPress標準のタグと '%"カスタム分類名"%' です。 (例: %actors%)
     '%"カスタム分類名"%' は、そのカスタム分類のタームに置換されます。
    末尾の '/' の有無は、標準のパーマリンク構造の設定に統一されます。 未入力のときは、/%postname%/ に設定されます。

    bbPressは、2.1.2 / 2.1.3 / 2.2.3で試しましたが、すべて同じ現象であった
    ため、bbPressのバージョン依存ではないことがわかりました。

    また、会員制サイト構築のプラグイン、wp-members と s2memberの二つを入れ替えて
    みましたが、現象は変わらなかったため、会員制サイト構築のプラグインによる依存では
    ないことが確認がとれました。

    さらにテーマを変えても現象が変わらないこと、及び、プラグインをすべて停止しても、
    現象が変わらないことは確認できています。

    理由の見当がつかないため、疑わしいと思われる部分についてお知恵をいただけますと
    大変たすかります。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • スレッド開始 satochan

    (@satochan)

    Forum/topic/replyの、パーマリンク設定をDefault(/%postname%/)に
    することで、現状は問題が解決したように見えるので、ご報告します。
    もし、今後変化があれば、またご報告します。

    スレッド開始 satochan

    (@satochan)

    結局、上記では解決できずにいました。

    再度、プラグインをすべて無効にして調べたところ、Custom post type permalinks
    プラグインが原因であることがわかりました。

    (前回、プラグインを無効にして時間を置かずに確認しましたが、今回はプラグインを無効にして時間がたってから確認しました。)

    取り急ぎ、報告まで。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • トピック「フォーラム用のパーマリンクの設定が、ユーザー間で変わってしまう」には新たに返信することはできません。