サポート » 使い方全般 » フロントページの表示設定がうまく反映されない

  • 解決済 seitaro

    (@seitaro)


    はじめて質問させていただきます。

    表示設定(reading)でフロントページの設定項目以下、固定ページで
    投稿ページを特定のページに指定しても反映されません。

    具体的には、指定後に指定したページを確認すると

    Parse error: parse error, unexpected T_IF in /usr/local/apache/htdocs/html_test/wp-content/themes/wp.vicuna/index.php on line 17

    というエラー表示が出てしまいます。
    エラー表示をの記述をもとにindex.php内の17行目を探ってみると
    <?php end if ?>
    という行があり、この行を削除してみました。
    するとエラー表示はされなくなったのですが、コンテンツが読み込まれずにヘッダーとサイドバーやフッターのみが表示されるという状態になりました。

    自分はphp初心者なので、その周辺の記述が怪しいことは理解したのですがどのように処理すれば良いかがわかりません。

    どなたかご教示いただけると大変助かります。
    よろしくお願いいたします。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • 例示された

    <?php end if ?>

    がコピーペーストしたもので間違いがないのであれば構文が間違っています。

    <?php endif; ?>

    にして試してみてください。

    アドバイスありがとうございます。

    ご指摘いただいた通り修正してみましたが不具合は直りませんでした。
    また、表示されるエラーメッセージにも変化はありません。

    <?php endwhile; end if; ?>

    のような記述も試してみましたがだめでした。

    今はすべてのプラグインを外している状態なのでプラグイン周りでの干渉等も考えづらいです。

    ほかに何か可能性はありますでしょうか?

    まず使用しているテンプレートとその配布先、公式のvicunaであれば使用しているスキンの情報なども教えてください。
    現状の内容だけでは判断できません。
    また、defaultのテーマでもページの設定はうまくいきませんか?テーマを他のものに変更して試してみてください。(テーマが原因か特定するため)

    使用しているテンプレート:vicuna(公式のものです)
    使用しているスキン:flat

    defaultのテーマに戻すと投稿の設定が反映されていました。
    またもう一度vicunaに戻すとindexを開いた時点で

    Parse error: parse error, unexpected T_IF in /usr/local/apache/htdocs/html_test/wp-content/themes/wp.vicuna/index.php on line 17

    というエラーメッセージが表示されました。

    vicunaテーマのindex.phpの記述に致命的なエラーがあるのでしょうか?
    一応以下にindex.phpの記述を。

    <?php get_header(); ?>
    	<title><?php bloginfo('name'); ?></title>
    </head>
    <body class="mainIndex double">
    <div id="header">
    	<p class="siteName"><a href="<?php bloginfo('home'); ?>"><?php bloginfo('name'); ?></a></p>
    	<?php vicuna_description(); ?>
    </div>
    
    <div id="content">
    	<div id="main">
    		<h1><?php bloginfo('name'); ?></h1>
    <?php
    	if (have_posts()) :
    		while (have_posts()) : the_post();
    ?>
    <?php           end if; ?>
    			</ul>
    		</div>
    <?php
    		endwhile;
    	endif;
    ?>
    <?php vicuna_paging_link('indent=2') ?>
    		<p class="topicPath"><a href="<?php bloginfo('home'); ?>" title="<?php _e('Home', 'vicuna'); ?>"><?php _e('Home', 'vicuna'); ?></a></p>
    	</div><!-- end main-->
    
    <?php	get_sidebar(); ?>
    
    <?php	get_footer(); ?>

    連続投稿になってしまい申し訳ないです。

    さきほどindex.phpの内容を
    もう一度ダウンロードしたvicunaのものに差し替えたところ正常になりました。
    投稿ページもきちんと反映されています。

    ご協力のおかげで原因の特定につながりました。
    大変ありがとうございました。

    具体的なコードのエラー部分、またなぜindex.phpの内容が不適切に書き換えられていたのかまではわかりませんでしたが、phpの勉強をしながら徐々に確かめていこうと思います。

    解決してなによりです。
    どうやら途中のソースがごっそり抜け落ちているようですね。
    原因までは分かりませんが、アップロード時の転送エラーなどが原因かもしれません。
    問題は切り分けからはじめると解決がはやいですよ;)

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック「フロントページの表示設定がうまく反映されない」には新たに返信することはできません。