サポート » 使い方全般 » ブラウザによって突然メニュー機能が動作しなくなりました。困っています。

  • 解決済 neko_89

    (@neko_89)



    はじめまして。

    8年ぐらいワードプレスで使っていたサイトなのですが、メニュー機能が、近頃気付いた時には突然googleクロムのブラウザで機能せず、おかしいなと思い試しにサファリで開いてみると、以前通り通常動作するという問題が現れました。

    その問題のメニューというのは、長く下にスクロールする1ページサイトの、メニューをクリックしても指定の位置に飛ばなくなったというものです。

    以上の質問をwordpress.comのフォーラムでしてみたところ、ここのサイトを教えてもらいました。

    その際に教えていただいた事は、

    >話の内容から察するに、Javascriptでエラーが発生しているようです。Chromeの場合F12キーでデベロッパーツールが開きますので、エラー箇所を特定出来ます。
    エラーメッセージとエラー箇所のコード、使用しているテーマ、使用しているプラグイン、WordPressのバージョン、PHPのバージョンなどを明記してWordPress.org日本語サポートフォーラムで尋ねてください。

    との事でした。

    エラーメッセージは:
    (index):1 Failed to set referrer policy: The value ” is not one of ‘no-referrer’, ‘no-referrer-when-downgrade’, ‘origin’, ‘origin-when-cross-origin’, ‘same-origin’, ‘strict-origin’, ‘strict-origin-when-cross-origin’, or ‘unsafe-url’. The referrer policy has been left unchanged.

    JQMIGRATE: Migrate is installed, version 1.4.1

    エラー個所のコード:
    は、どこのことかわかりません。
    一箇所それらしき場所があるのですが、コピーできずにいます。

    使用しているテーマ:
    Weald Version: 1.1.6

    使用しているプラグイン:
    は以下の物ですが、8年ぐらい前にネットの情報を頼りに素人が作ったので本当にこれらが必要なのか、これらが何をするものなのか今となっては覚えていません。

    WP Statistics
    W3 Total Cache
    Unveil Lazy Load
    Shortcodes by Angie Makes
    PS Disable Auto Formatting
    Post Types Order
    Page Builder by SiteOrigin
    Grid FX
    Duplicator
    Category Order and Taxonomy Terms Order
    BackWPup
    Async JS and CSS

    WordPressのバージョン:
    WordPress 5.0.3

    PHPのバージョン:
    PHP5.6.36
    です。

    どなたか似たような経験をされた方、またはご存知の方おられましたら、ご教示どうぞよろしくお願いいたします。

6件の返信を表示中 - 16 - 21件目 (全21件中)
  • neko_89

    (@neko_89)

    RICKさん

    ご親切にたくさんのアドバイス本当にありがとうございます。

    >wp-config.phpにdefine('WP_CACHE', true);の?記述があるならその記述を削除してみてください。

    探してみたのですが、ありませんでした。

    >キャッシュを削除したいページでF12を押す
    更新ボタンを長押し or 右クリック
    キャッシュの削除とハード再読込をクリック

    試してみましたが、変わりませんでした 泣

    >リストにあるAsync JS and CSSとGrid FXは現在WordPressの管理画面から
    直接インストールできないようになっています。
    これらが影響している可能性があるので削除してみるのも手かもしれません。

    この二つを両方削除してキャッシュを消して更新したけど変わりませんでした。

    そうなんです。
    他ブラウザ、例えばsafariだと問題なく機能しているんです。
    しかも、adminのなかの、左上のブラシの形のアイコンのcustomiseのところからだと、微妙に動くんですよね。(微妙というのが、メニューをクリックして、スライドしてその位置までは行かないのですが、フェードアウトしてフェードインする形でその指定の場所には一応行くという。とても意味のわからない動作なのです。。。)
    どういう事でしょうか?

    WP_manabu

    (@wp_manabu)

    こんばんわ〜

    さきほど、別のスレットにて質問し、ブラウザーの表示のトラブルを解決した者です。
    RICKさんに「別のブラウザーで確かめてみては」というアドバイスをいただき、ためしてみたところ、現状以外のブラウザーで正常に閲覧できることが確認できました。

    で、問題の、うまく表示できないChromeについては、何度、キャッシュをクリアしても、正常に表示されないので、当ブラウザーを再インストールした結果…うまく、いきましたー。

    参考にしたのは、このウェッブサイトです。
    やや古い情報のようですけれど、じぶんで「補助線」を引きながらカンタンにできたりしました。

    ご参考までに〜

    アドバイスをいただきました皆様

    ご親切に本当にありがとうございました。

    どの方法も試してみましたが、解決せず、デベロパーもするすると言いつつ何もしてくれないので、技能のない私にはこれ以上ワードプレスは手に負えないと実感し、今まで数年私なりに頑張ってきたので無念ですが、オンラインのページ作成ツールに移行する事に決めました。

    ありがとうございました。

    解決できずに終わってしまったようですが、ご利用のテーマに問題があったようです。
    https://themeforest.net/item/weald-flat-responsive-portfolio-wordpress-theme/5235877
    Changelog の v1.1.7 の所に
    – Fixed single-page scrolling in Chrome
    の記述がありますので、テーマをアップデートすれば問題は解決するのではないでしょうか?
    有料テーマの場合は、販売元のサポート窓口へ問い合わせしましょう。

    アドバイスをくださった皆様へ追記。

    あの後、近年サポートに対応してくれなくなっていた(しかし大好きで何年も使っていた)テーマのレビュー欄に上記の事を書き込み、このテーマを泣く泣く去る事を記入したところ、デベロパーの方からアップデートのお知らせが来て、その途端問題のあった全機能が回復し、複雑な気持ちになっている次第です。

    アドバイスをくださった皆様、本当にありがとうございました。

    CG

    (@du-bist-der-lenz)

    多忙だったのでしょうね。でも、 @neko_89 さんが、アプローチされたことが不具合を確認できるきっかけになったのかもしれませんよ。有料テーマの場合は、コードをみることができない限りは、判断できません。デベロパーも、ユーザーで克服できると判断したぐらいの事だったかもしれません。テンプレートのコードをみても、理解が出来ないユーザーには、有料テーマの場合は、販売元のサポート窓口へ問い合わせるのは大切なことです。

6件の返信を表示中 - 16 - 21件目 (全21件中)
  • このトピックに返信するにはログインが必要です。