サポート » プラグイン » プラグインの信用性について

  • nests

    (@nests)


    お世話になります。
    技術的な内容とは程遠いため、フォーラムを使用するか迷いましたがご質問させていただきます。

    現在、自社のホームページをワードプレスにて作成しております。
    普段は別内容の仕事をしているためコーディングなどの技術はほとんどありません。
    ある程度完成したものを会議にて報告したところ、使用しているプラグインのセキュリティ上の懸念を
    指摘されました。お客様の情報を預かる以上、プラグインとテーマに関しては作成者が日本の企業で、登記が確認されたものを使うことになりました。

    使わなくなることで問題があるプラグインがあり、その対応策に困っております。
    アドバイスなどをいただけると幸いです。

    1.WP Multibyte Patch  
     以前はContact Form 7を使用(上記問題によりGoogleformに入れ替え)しておりましたが、使わなくなる。画像や動画の名前の文字化けの懸念がある程度。個人的には信用度は高いと思っている。
    2.WPtouch Mobile Plugin
     テーマがモバイル表示に対応していないため、CSSを編集するか、テーマを別のものにするか検討中。他プラグインは上記問題により断念。
    3.Yoast SEO
     XLMサイトマップは自作する。それ以外のプラグインは上記問題により断念。
    4.Really Simple SSL
     必ずSSL化は必須ですが、プラグインは上記問題により使用できないため手打ちでどうにかする予定。やり方はこれから調べます。

    対応策や条件に合うプラグインなど教えていただけると幸いです。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • shokun0803

    (@shokun0803)

    nestsさん、こんにちは。

    本来であれば否定的なお話をお返しするのは建設的ではないので、あくまでも個人の参考意見として聞いていただけますと幸いです。

    使用しているプラグインのセキュリティ上の懸念を
    指摘されました。お客様の情報を預かる以上、プラグインとテーマに関しては作成者が日本の企業で、登記が確認されたものを使うことになりました。

    少なくともプラグインディレクトリ、テーマディレクトリに公開されているプラグインやテーマは、公開前に有志のチェックが入っており、コードも公開されているため、セキュリティ上の懸念があれば指摘がされているはずです。
    もちろん後から発生した問題があっても、最悪の場合公開中止の対策が取られますし、作者は迅速に修正対応されています。

    WordPress本体を含め、オープンソースとはそういうものなので、ソースコードが公開されていないフリーウェアを使用するよりははるかにセキュアだと思われます。

    普段は別内容の仕事をしているためコーディングなどの技術はほとんどありません。

    技術に自信のない方が、自力でカスタマイズすることと、常にアップデートされているテーマやプラグインを使用することの天秤を考えていただく方が、セキュアなサイトを運用するうえで重要かと思われます。
    自作カスタマイズ部分は外部に非公開で、仮にセキュリティホールが存在していても、誰からも指摘されることがありません。

    〇か月以上更新のないプラグイン、テーマは使用しない。
    ログインページはBASIC認証等でアクセスを制限する。
    ユーザーは個別に作成し、共通アカウントでログインをしない。
    等、別のセキュリティ向上施策を検討し、会議にて了承を頂く方がよろしいかと存じます。

    ご参考になれば。

    munyagu

    (@munyagu)

    こんにちは

    「お客様の情報を預かる」というのがどういうことか分からないですが・・・
    通常のホームページであれば、お客様の情報をサイトの中に持つことは無いと思います。
    EC機能などでその必要があるのであれば、そこだけ何かのECサービスを利用されてはどうでしょうか。

    WordPress から静的なファイルを出力して、普段は管理画面やデータベースにアクセスできないようにするサービスなどもありますので、技術力不足によるセキュリティ的懸念を心配されるのであればそのようなサービスを利用するか、何かのサイト構築サービスを利用されてもいいかもしれません。

2件の返信を表示中 - 1 - 2件目 (全2件中)
  • このトピックに返信するにはログインが必要です。