サポート » プラグイン » プラグインを有効化しようとするとエラーが発生します

  • 解決済 lacoet

    (@lacoet)


    初めて投稿させていただきます。
    テーマとプラグインに関して困っていることがありますので
    お詳しい方にご協力頂けると嬉しいです。
    急ぎではありませんのでどうぞ宜しくお願い致します。

    海外のサイトでExellent Plusというテーマを購入致しました。

    テーマはきちんとインストールできましたので、現在このテーマに基づくページが表示されています。

    と、ここまではよかったのですが

    こちらのテーマには Excellent Plus Demo Import というプラグインが付属していて、このプラグインをインストール/有効化すると、あらかじめ作成されているデモページ(テンプレートページ)が使えるようになります。

    このプラグインをインストールまではできたのですが、有効化しようとすると下記のエラーが出てしまい使うことができません。

    ———-
    重大なエラーを引き起こしたため、プラグインを有効化できませんでした。

    Parse error: syntax error, unexpected T_STRING in /home/users/0/lolipop.jp-dp24064384/web/la-coet/wp-content/plugins/one-click-demo-import/one-click-demo-import.php on line 89
    ———-

    テンプレートが使えないとテーマを購入した意味がないので、どうにか有効化したいのですが、エラーの解決方法が分からないので困っています。

    何度も有効化しようと試みましたが、同じエラーが出てしまいます。

    サーバ側に問合せてみたところ、以下のような回答を受け取りました。
    ———-
    ご連絡いただいたエラーの内容を確認いたしましたところ、
    /la-coet/wp-content/plugins/one-click-demo-import/one-click-demo-import.php
    というファイルの89行目付近の記述が原因で、
    「syntax error, unexpected T_STRING」というエラーが発生しているようです。
    ———-

    phpなどの知識が全くないため、どこをどうすればいいか全く分からない状態です。

    本来テーマを購入したサイトに問い合わせるべきかもしれませんが、英語で質問することが
    できずこちらに投稿させて頂きました。

    ぜひ助言を頂けると助かります。
    どうぞ宜しくお願い致します。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • CG

    (@du-bist-der-lenz)

    @lacoet さんが利用しているサーバーのPHPバージョンの把握認知が必須です。また当該「Exellent Plus」テーマのWordPressへのバージョン4.7.5対応は確認できてますでしょうか。プロダクトテーマは、プロダクトに責任を課すのが、プロダクト側の欲することでもあります。

    利用しているサーバーのPHPバージョンとWordPressバージョン4.7.5がマッチしている時は、「syntax error, unexpected T_STRING」を書き直すことで大丈夫です。その動作を確認の上、プロダクトに申請しておきましょう。

    • この返信は4 ヶ月、 2 週間前に  CG さんが編集しました。
    モデレーター Takayuki Miyoshi

    (@takayukister)

    商用プロダクトのサポートは本フォーラムの対象から外れます。ここではなく販売元のサポート窓口に問い合わせてください。

    アドバイスありがとうございます。
    もう一度自分で調べてみてから販売元に問い合わせてみたいと思います。

3件の返信を表示中 - 1 - 3件目 (全3件中)
  • このトピックに返信するにはログインが必要です。