サポート » 使い方全般 » プラグインインストールエラー

  • WordPress6.3 php8.1 mysql8 のサーバ仕様ですが、contactform7 等のプラグインはインストールできるのですが、seo系のプラグインがインストールエラーになります。(all in one seo pack 、google site kit等)

    wordpressのバージョンに対応していても、phpのバージョンに対応していないことが原因なのでしょうか?

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • wordpressのバージョンに対応していても、phpのバージョンに対応していないことが原因なのでしょうか?

    プラグインによって、対応バージョンが異なる可能性は考えられますね。プラグインのドキュメントで確認してもらえれば対応バージョンは分かると思います。

    トピック投稿者 momotarou

    (@strise)

    ご回答ありがとうございます。

    プラグインのサイトへ行き確認してみます。

    こんにちは

    どのようなエラーが起こっているかは、サーバーのエラーログを確認してみてください。

    トピック投稿者 momotarou

    (@strise)

    インストールに失敗しました: ディレクトリを作成できませんでした。 /home/******/*/*/*****/*****/*****/wp-content/upgrade/all-in-one-wp-migration-7.76-ja

    上記のようなエラーばかりです。

    upgradeディレクトリに問題があるのでしょうか?

    PHP8.1バージョンの問題でプラグインが正常にアップデートできないのでしょうか?

    munyagu

    (@munyagu)

    ディレクトリの作成に失敗する原因は、

    • upgrade ディレクトリに対して権限が不足している。
    • 作成しようとするディレクトリがすでに存在している。

    のどちらかではないかと思います。

    PHP8.1バージョンの問題でプラグインが正常にアップデートできないのでしょうか?

    そのような疑念があるのであれば、PHP のバージョンを変更してみてはどうでしょうか。

    トピック投稿者 momotarou

    (@strise)

    ご回答ありがとうございます

    ただ、サーバーの環境がphp8.1のみのサポートです。他、phpのバージョンも7.4以下でサポート対象外の環境です。mysqlも8バージョンしか利用できず。PHPも仮に旧バージョンに変更すると、mysqlとの連結でエラーが出て、wordpress自体が動作しません。

    upgrade ディレクトリの権限も755です。

    サーバー上に不可視の消したはずのファイルが残っているのでしょうか?

    FTPクライアントソフト上やサーバーの管理画面のファイルマネージャー等で確認しても残ってはいないのですが…

    よくあるWordpress簡単インストールなど、利用しましたが、最初はほとんどエラーが表示され、インストールできない状態でした、手動インストールもファイルのアップロードデータがエラーでアップロードできません。(htmlファイルはアップロードできました。)約数回目でwordpressがインストールできたサーバーです。

    munyagu

    (@munyagu)

    ディレクトリへの権限が十分で、該当ディレクトリも無いとすると、私には原因は分かりません。

    WordPress の簡単インストールや FTP はサーバー側から提供されている機能と思いますので、サーバー会社に問い合わせてみてはどうでしょうか。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「プラグインインストールエラー」には新たに返信することはできません。