サポート » 使い方全般 » プラグイン等がインストールできません。

  • 解決済 niichi

    (@niichi)


    プラグインのインストールや更新の際
    ダウンロードができません。

    ダウンロードに失敗しました。: No working transports found

    調べてみたのですが
    php.ini の~って記載があったのですが、
    わたくし初心者なものでちんぷんかんぷんです!

    どうか優しくおしえてください

15件の返信を表示中 - 1 - 15件目 (全35件中)
  • CG

    (@du-bist-der-lenz)

    初心者であろうが言い逃れの先回りにもならないのですが、「php.ini の~って記載があったのですが、」では、漠然と見当ができるぐらいです。

    投稿に記載する内容

    どのような条件でどのような問題が見られますか? 以下のポイントを考慮して、正確かつ具体的に記述してください。

    WordPress のバージョン
    使用しているプラグインとテーマの情報(名称、入手先 URL、バージョン)
    PHP、MySQL のバージョン
    サーバー環境(ホスティングサービス名、OS、ウェブサーバー等)
    ブラウザとそのバージョン
    エラーが表示された場合、「XX のようなエラー」ではなく、なるべくエラー文をコピーしてそのまま貼り付けてください

    参考:トピック: 問題解決のためのチェックリスト « サポートフォーラム — WordPress

    WordPress 4.8.1
    プラグインは初期のまま
    テーマも初期のまま
    そもそも、テーマもプラグインもダウンロードできないのでなにもかわっていません。
    MySQL5

    たとえば、wordpress最新のヴァージョンlに更新しようとすると

    WordPress を更新

    http://downloads.wordpress.org/release/ja/wordpress-4.8.2.zip から更新をダウンロードしています…

    ダウンロードに失敗しました。: No working transports found

    インストール失敗

    とでます。

    CG

    (@du-bist-der-lenz)

    先のログイン出来なかった時の「アクセス権限がありません」と合わせて考えるに、「要求されたリクエストを完了できる HTTP トランスポートがありません。」ということでしょう。

    原因としては、php.ini に記載されているエクステンションが無効になっていると思うのですが、そこが端折られているので推測する対処法としては;extension=php_curl.dllを有効にして Apache を再起動するだけで直ると思います。それでもエラーが出る場合は、;extension=php_openssl.dllも有効にしましょう。

    CG

    (@du-bist-der-lenz)

    ブラウザからインストールを行った、という点から見当ですが、インターネットと接続できていないためと思われ、サーバーにファイルをアップロードしてインストールすればよいでしょう。

    こんにちは

    PHP のバージョンはいくつでしょうか?
    ※ WordPress 4.8.1 は PHP 5.2.4 以上(推奨 7 以上)でなければ動作しません。

    こんにちは

    お使いのサーバーはC社のMW1というプランかと思いますが、そのサーバーでは管理画面からのアップデートなどはできないようです。
    (プランの詳細についてはサーバー会社に問合せてみてください)

    ではインストールやアップデートはどうするかというと、プラグインをダウンロードして解凍し、FTPなどでアップロードして更新してください。

    以下のURLなどの手順で実施すれば良いと思います。
    http://sachips.byeto.jp/wordpress/wordpress-plugin-manual-upgrade.html

    返信ありがとうございます。

    >先のログイン出来なかった時の「アクセス権限がありません」と合わせて考えるに、「要求されたリクエストを完了できる HTTP トランスポートがありません。」ということでしょう。

    >原因としては、php.ini に記載されているエクステンションが無効になっていると思うのですが、そこが端折られているので推測する対処法としては;extension=php_curl.dllを有効にして Apache を再起動するだけで直ると思います。それでもエラーが出る場合は、;extension=php_openssl.dllも有効にしましょう。

    とありますが。具体的にどのような操作をすれば有効になるのでしょうか?
    何を伝えれば、操作方法がわかりますか?

    ishitaka さん

    ありがとうございます。
    PHPのver情報ですが、調べ方を調べたのですが。
    SSHでサーバーに入ってコマンドを入力するということは分かったのですが。
    具体的にどのように調べるかといったことが
    わからず、すみません。
    ご教授ください。

    munyaguさん

    ありがとうございます。
    どうやら過去にWM1というプランからWM2というプランに変更したみたいで
    C社に連絡してwordpressに対応してますよと確認は頂きました。

    FTPでのアップロードの手順ありがとうございます!
    勉強させていただきます!

    PHP のバージョン チェックは、下記ページが参考になると思います。
    https://wpdocs.osdn.jp/サーバー情報を調べる

    どうやら過去にWM1というプランからWM2というプランに変更したみたいで
    C社に連絡してwordpressに対応してますよと確認は頂きました。

    WM2 プランは「PHP 5.6/7.0」となっているので、PHP のバージョンは大丈夫ですね。失礼しました。

    ishitaka様

    ありがとうございます。参考にさせていただきます!

    先ほど改めて、C社に連絡したところどうやらプラン変更できていなかったみたいです。
    実際はMW1プランからHOMEMWプランに変更されているだけでした。

    なのでWMW1プランのままみたいなので、最新版のWPは対応してないってことですよね。

    つまり、この問題はWPの旧バージョンを使用すれば解決するってことでしょうか?

    WordPressやPHPのどのバージョンを使っても解決しません。

    MW1プランにおけるサーバーの制約なので

    1.プランを変更する
    2.別のサーバーに乗り換える
    3.FTPで更新することにする

    のいずれかが必要です。

    WordPressの更新などができるサーバープランについては、サーバー会社に問合せてください。

    munyagu さん、フォローありがとうございます。

    munyagu さんが指摘のように、MW1 では「WordPress の管理画面から WordPress のアップデート及びプラグインの更新ができません」とサーバーの仕様にありますね。詳細はサーバー会社に問い合わせてください。

    munyagu さま
    ishitakaさま

    お返事ありがとうございます。
    そういった仕様となっているのですね!
    承知いたしました。それではFTPでのアップロードで解決したいと思います。

    また、動作確認されていないwordpressのverを使用していくうえで、
    アップデート以外にも不都合というのはでてくるのでしょうか?

    もし出てくるようでしたら素直に過去バージョンを使用していきたいと思います。

    また頂いておりました、解決方法に
    サーバーの乗り換えやプランの変更ですが
    使用しているソフトがありまして、そのソフト会社に相談したところ
    そのソフトの都合上サーバーやプランの変更が不可能、もしくはお金が結構かかるといった
    ことですので、今回はFTPでアップロードすることにさせていただきます。

    また、動作確認されていないwordpressのverを使用していくうえで、
    アップデート以外にも不都合というのはでてくるのでしょうか?

    サーバーの詳細な仕様(制限事項や組み込まれているモジュール、各ソフトウェアのバージョンおよび設定等)が分からないのでなんともいえません。サーバー会社に問い合わせてください。
    動作しない例では、PHP の GD ライブラリが使えない環境(あくまでも例です)では、画像のサムネイルが作成されなかったり、CAPTCHA 画像が表示されない等があります。

15件の返信を表示中 - 1 - 15件目 (全35件中)
  • トピック「プラグイン等がインストールできません。」には新たに返信することはできません。