サポート » 使い方全般 » モジュール imagick のインストール

  • 解決済 itiyama

    (@itiyama)


    こんにちは。よろしくお願いします。
    Wordpressにログインし、サイトヘルスステータスを見ると、

    ・モジュール imagick がインストールされていないか、無効化されています
    ・モジュール zip がインストールされていないか、無効化されています
    と、あります。

    可能であれば、この二つのモジュールを入れたい(有効にしたい)のですが、
    その方法をお尋ねいたします。

    ググったら、さくらインターネットの例として、
    php.iniに、”extension = imagick.so” を追記すると、ありました。

    私は、コアサーバーを利用しています。そうすると、
    root /public_html /.fast-cgi-bin
    に、php74.ini があります。このiniファイルの内容は、

    cgi.force_redirect = 0;
    date.timezone = Asia/Tokyo
    engine = On
    ・・・中略・・・
    opcache.fast_shutdown=1

    となっています。この末尾に、加えたら良いんでしょうか?
    お教えください。

    また、「モジュール zip」についても、
    extension = zip.so
    を追記することで対応できるのでしょうか。
    ご教授ください。お願い申し上げます。

    「サイトヘルス情報をクリップボードにコピー」した概略は、
    以下のようなものです。

    ### wp-core ###
    version: 5.4.2
    
    ### wp-server ###
    server_architecture: Linux 4.4.0-174-generic x86_64
    httpd_software: Apache
    php_version: 7.4.3 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    imagick_availability: false
    
    ### wp-database ###
    extension: mysqli
    server_version: 5.7.29-log
    client_version: mysqlnd 7.4.3
5件の返信を表示中 - 1 - 5件目 (全5件中)
  • こんにちは

    サーバーの設定方法についてはサーバー会社へお問合せください。

    munyaguさま
    ありがとうございました。サーバー会社側に尋ねてみたあとで、
    こちらへと、投稿しました。
    サポート担当者は「サポート外です」とのこと。

    サポートへの質問文章が拙かったかも知れませんので、
    今一度、質問をし直してみます。ありがとうございました。

    ホスティングサービス側はPHPの環境については説明してくれますが、「WordPressで」と言うと条件反射でサポート外ですと言われることがあります。
    「PHPでimagickモジュールとZIPモジュールを使用することはできますか?」とサーバー会社に聞いてみましょう。

    npsslさま
    ご親切に、お教え頂きありがとうございました。
    お教えのような文言でサポートに尋ねましたところ、
    以下のようなことでした。

    ■imagick
     ────────────────────
    【コアサーバー】
    PHP7.1のみでご利用可能でございます。
    ・サイト設定にてPHPバージョンを「php71」へ変更
    ・【/public_html/.fast-cgi-bin/php71.ini】に「extension = imagick.so」
      を記述
    といったお手続きを行ってください。
    
     【XREA】
    PHP7.0のみでご利用可能でございます。
    ・サイト設定にてPHPバージョンを「php70」へ変更
    ・【/public_html/.fast-cgi-bin/php70.ini】に
     「extension = /usr/local/lib/php/extensions/imagick.so」を記述
    といったお手続きを行ってください。
    ────────────────────
    
     ■ZIP
     ────────────────────
    【コアサーバー・XREA共通】
    PHPバージョン7.3以前でございましたら導入しております。
    ────────────────────

    当方は、phpのバージョンを7.4にしておりますので、
    7.1にバージョンダウンするのは、躊躇われます。
    よって、imagickおよびZIPのモジュールを利用することは、
    断念いたします。ありがとうございました。
    解決しました。お陰様でスッキリしました

    itiyama

    (@itiyama)

    解決済みにいたします

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • このトピックに返信するにはログインが必要です。