サポート » テーマ » ライブプレビューが表示されない

  • インストール済みのテーマを選んで「ライブプレビュー」を押しても何も表示されません。
    左側はカスタマイズメニューが縦に並び、右側にライブプレビューが表示されるはずですが、真っ白です。

    新しいテーマを追加したいと思い、外観→テーマ→新規追加で「ライブ」ボタンを押すと、インストールされていないテーマは右側に表示されます。が、おしゃれなヘッダー画像などは表示されず、カスタマイズされていないシンプルな投稿記事のみが表示されます。

    インストール済みのテーマだけ真っ白という状態です。

    以前、業者さんに頼んで特設サイトを設け、トップのURLを変えたことがあります。それ以来、このような症状になったと思われます。

    現在使用しているテーマは「Huemanバージョン: 3.3.22」です。

    よろしくお願いします。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • CG

    (@du-bist-der-lenz)

    以前、業者さんに頼んで特設サイトを設け、トップのURLを変えたことがあります。それ以来、このような症状になったと思われます。

    それを解決してからか、原因の切り分けになるでしょう。

    CGさん、ご返信ありがとうございます。

    それを解決と言いますと・・・特設サイトのことでしょうか。
    それは今はもうなくて、最初に設置したときの状態に戻ったのですが、
    特設サイトを設けた時からライブプレビューが表示されなくなりました。

    よろしくお願いします。

    WordPressアドレスとサイトアドレスが違うのは原因として考えられるでしょうか?

    設定を見たところ、

    WordPress アドレス (URL) http://www.×××-××××.net/wordpress
    サイトアドレス (URL)http://www.×××-××××.net

    となっています。最初の立ち上げ時と同じかどうかは不明です。

    引き続き、よろしくお願いします。

    CG

    (@du-bist-der-lenz)

    特設サイトの情報がわからないところですが、また、「それは今はもうなくて、最初に設置したときの状態に戻った」というのは、それ以前の「Huemanバージョン: 3.3.22」使用時に戻ったと理解すればよいのでしょうか。設置をやめた時点で、後処理は行われたのでしょうか。
    あれこれと6時間考えていて、「Hueman」テーマということで見当をついたことがいくつかあります。その後、どういう対策を処しましたか、進捗状況をお伝え下さい。

    CGさん、6時間も考えてくださったのですか!
    ありがとうございます。

    今回ご相談しているサイトは勤務先のもので、ある一定期間だけ特設サイトを設置していました。
    元々のwww.×××-××××.netにアクセスすると、自動的に別のURLに飛ぶ仕組みです。
    投稿記事を下書き保存してプレビューすると特設ページのトップが表示され、個別の記事がプレビューできなかったので不便でした。

    特設ページが撤去された後の後処理については、業者任せだったためよくわかりません。
    気がつくとテーマのライブプレビューが使えない状態になっていました。

    業者への連絡も取っていますが、もし自分で解決できればと思い、こちらで質問させていただきました。

    引き続きよろしくお願いします。

    こんにちは

    WordPressをデバッグモードにし、プレビューの操作をしてみてください。
    何かエラーが表示されないでしょうか?
    WordPressでのデバッグ

    また、可能であればサーバーのエラーログを確認してみてください。

    CG

    (@du-bist-der-lenz)

    可能性に大きく作用しそうなのが「Hueman」テーマ所以です。このテーマは独自のカスタマイズシステムをアドオンプラグインで読み込んでいます。特設ページを解除のあとで、「Hueman」を使用しているのでしょうか。業者に確認する際、その旨を強調しておきましょう。

    CGさま

    特設サイト設置前も後も「Hueman」を使用しています。

    画像が表示されていない という症状には URL の間違い、ライブプレビューが真っ白という症状にはプラグインの衝突 (コンフリクト) が考えられます。

    まず画像が表示されない理由はブラウザの開発者ツールを開き Console の場所にいくつかエラーが出ているのではないかと思います。可能であればここに貼り付けていただくと何が原因かは突き止められるのではないかと思います (ドメインは伏せていただいても大丈夫です)。

    ライブプレビューが真っ白については、プラグイン同士のコンフリクトの可能性が一番高いです。Hueman テーマとその Addons プラグインはかなりカスタマイザーがいじられているテーマですので特にコンフリクトの起こる可能性は高いかと思います。まずはプラグインをすべて無効化して再びライブプレビューを確認してみてください。(またそれでもだめならデフォルトの TwentySeventeen テーマでも確認)

    Miruconさま

    ブラウザの開発者ツールのConsoleというのは、サイトを表示している時にF12を押して表示される画面のことですよね。
    「jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
    www-widgetapi.js:121 Failed to execute ‘postMessage’ on ‘DOMWindow’: The target origin provided (‘https://www.youtube.com’) does not match the recipient window’s origin (‘http://www.○○○○.net’).
    f.C @ www-widgetapi.js:121」というエラーが表示されています。

    確かにウィジェットにyoutubeを埋め込んでいますが、関係あるでしょうか。

    よろしくお願いします。

10件の返信を表示中 - 1 - 10件目 (全10件中)
  • このトピックに返信するにはログインが必要です。