サポート » 使い方全般 » リンクに「target=”_blank”」を設置時に起こる現象について

  • fujimotoyousuke

    (@fujimotoyousuke)


    お世話になります。有識者の方に教えていただきたく質問させていただきます。

    <a href=”https://example.com” target=”_blank” rel=”nofollow”>テキスト</>

    このようにテキストリンクでも画像リンクでも、「target=”_blank”」を設置した状態で、WordPressの編集モードを「ビジュアルモード」もしくは「テキストモード」に切り替えをすると、

    <a href=”https://example.com” target=”_blank” rel=”nofollow noopener noreferrer”>テキスト</>

    というように、「noopener noreferrer」が付与される現象を、わたしの環境(PHP7.0.9 / WordPress4.7.4)で確認しています。

    これは『rel=noopener 付与による Tabnabbing対策』で、いつからか分かりませんが、このような仕様になっているものだと思います。

    「noopener noreferrer」が付与されることは、不具合ではないと思うのですが、このWordPressの編集モードを「ビジュアルモード」もしくは「テキストモード」に切り替えをすることで、「noopener noreferrer」が付与されてしまう現象で困っているのですが、良い方法があれば教えていただきたいです。

    「noopener noreferrer」が知らぬ間に付与されるないようにできる方法があれば教えて欲しいです。

    よろしくお願いします。

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • nobita

    (@nobita)

    こんにちは、

    TwentySeventeenで確認できました。

    WordPress4.7.4でのTinyMCEのセキュリティ対策みたいですね。

    Noreferrer — WordPress Plugins

    等が参考になりませんか?

    • この返信は2 年前に  nobita さんが編集しました。
    nobita

    (@nobita)

    追記

    もし可能であれば、noopener noreferrer があるとどのような問題があるのか教えていただけるとうれしいです。

    Colorful-life.

    (@colorfullifeinfo)

    こんにちは

    we do not recommendと書かれていますのでお勧めは出来かねますが、tinymce.initでallow_unsafe_link_targettrueにすればnoopener noreferrerは付与されなくなるようです
    https://www.tinymce.com/docs/configure/content-filtering/#allow_unsafe_link_target

    エディターに反映するならこんな感じでしょうか。

    add_filter( 'tiny_mce_before_init', 'clf_tiny_mce_before_init' );
    function clf_tiny_mce_before_init($settings) {
    	$settings['allow_unsafe_link_target'] = true;
    	return $settings;
    }
    nobita

    (@nobita)

    ごめんなさい、リンク先間違えてましたー

    https://wordpress.org/support/topic/remove-rel-noopener-noreferrer-in-wordpress-4-7-4/

    • この返信は2 年前に  nobita さんが編集しました。
    Colorful-life.

    (@colorfullifeinfo)

    あら、私おもいっきり内容かぶせてしまってましたね、すみません

    そういう事ですので、@nobitaさんがご提示くださったリンク先をご覧頂くことをお勧めします

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「リンクに「target=”_blank”」を設置時に起こる現象について」には新たに返信することはできません。