サポート » プラグイン » 以前のデータベースの記事を今のデータベースに入れたいのですが

  • 以前のwordpressはバージョン2.8.2を使っていました。

    この時、何かバージョンアップしている時か、エラー画面がでて、ログイン画面に入れなくなりました。エラー画面にあったplugin.phpを削除すればいい、と聞いたのでやってみると、また違うエラーがでたので、データベースに記事はあるので最新版にしようと思いました。

    そこで最新版のwordpress3.9をインストールしました。

    ここに旧2.8.2のデータを移してくる方法は、何かないでしょうか?

    旧2.8.2はログインできないため、エクスポートを選び、テキストファイルを抽出して。というのは出来ないかと思われます。

    どうぞ、よろしくお願いします。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • 메텔

    (@digitmaetel)

    新しいサイトを作ったデータベースに旧データベースのデータをインポートしましょう。

    旧バージョン2.8.2にログインできないために、エクスポートしていないんですね。

    だから、新しいデータベースにインポートも出来ないんですが・・・

    何か良いアイデアはないでしょうか?

    wordpressにログインする必要はありません。
    sshが使えてmysqlの操作が許可されているならそれで、phpMyAdminが使えるならそれで
    データベースの内容をエクスポート&インポートするだけです。

    遅くなりました。
    今、やっとphpMyAdminをお名前.comサーバーを使って、インストールしているのですが、あと1歩のところまで、きております。

    最後、phpMyAdmin画面が表示されません。
    http://ドメイン名/phpmyadmin/だと証明書エラーになり、以下を見てみると

    http://ドメイン名/phpmyadmin/setup/の以下、エラー画面です。

    Fatal error: Call to undefined function PMA_generate_common_url() in /export/sd205/www/jp/r/e/gmoserver/8/1/sd0273681/solaris-matsuda.com/phpmyadmin/libraries/common.inc.php on line 332

    というエラーがでて、332行目をみると、以下です。

    /**
    * check HTTPS connection
    */
    if ($GLOBALS[‘PMA_Config’]->get(‘ForceSSL’)
    && !$GLOBALS[‘PMA_Config’]->get(‘is_https’)) {
    PMA_sendHeaderLocation(
    preg_replace(‘/^http/’, ‘https’,
    $GLOBALS[‘PMA_Config’]->get(‘PmaAbsoluteUri’))
    332行目→ . PMA_generate_common_url($_GET, ‘text’));
    // delete the current session, otherwise we get problems (see bug #2397877)
    $GLOBALS[‘PMA_Config’]->removeCookie($GLOBALS[‘session_name’]);
    exit;
    }

    すいません、もしわかれば、よろしくお願いします。

    モデレーター gatespace

    (@gatespace)

    お名前.comのプランが不明ですが、
    少なくとも共用サーバーSDでは、phpMyAdminはインストールされておらず、ユーザーが自分でインストールする必要があります。
    また「phpMyAdmin の 設置・利用に関してはサポート対象外となります。」と書いてあります。

    http://guide.onamae-server.com/sd/3_12_15_25_2/

    また、このフォーラムもWordPressのフォーラムですから
    phpMyAdminがインストール出来ない or 動作しない と言うことに関してフォローできかねます。

    gatespaceさん、ご丁寧にありがとうございます。

    なんとか、phpMyAdmin画面が出ました!

    やっと、これからインポート、エクスポートをチャレンジしてみます。

    この記事をみて、やろうと思っています。
    http://algorhythnn.jp/blg/2013/09/28/phpmyadmin-imp-exp/

    また、進捗あれば書きこませて頂きます。
    ありがとうございます。

    やっとphpMyAdminがインストールでき、2つのデータベースも見れるようになりました。

    それで単純に旧データベースからエクスポートして、sddb0040101776.cgidb.sqlという圧縮ファイルをダウンロードしました。

    それを新データベース(これにはテーブルがありません。と出ています。)にインポートすると、以下のエラーが出ました。

    エラー

    実行した SQL:


    — データベース: sddb0040101776

    CREATE DATABASE sddb0040101776 DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

    MySQLのメッセージ: ドキュメント
    #1044 – Access denied for user ‘sd_dba_MjExNzUw’@’172.17.8.%’ to database ‘sddb0040101776’

    何がいけないんでしょうか?
    初めてのSQLの為、調べましたが、よくわかりませんでした。
    アドバイスよろしくお願いします。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「以前のデータベースの記事を今のデータベースに入れたいのですが」には新たに返信することはできません。