サポート » インストール » 使用していない JavaScript の削除等

  • 解決済 mrsmith11

    (@mrsmith11)


    WordPressのブログと、woo commerceのECサイトをサイト両方運営しております。

    Google のPageSpeed Insightsで、自分のwordpressやwoo commerceを調べてみると、
    モバイル40点、パソコン55点でした。

    以下、改善できる項目が表示されており、すべて改善すると、約6秒ほど改善されるようです。

    ——————

    使用していない JavaScript の削除
    2.56 s

    最初のサーバー応答時間を速くしてください
    2.09 s

    テキスト圧縮の有効化
    1.48 s

    レンダリングを妨げるリソースの除外
    0.62 s

    使用していない CSS を削除してください
    0.16 s

    ——————

    もしこれらすべてを改善した場合の話なのですが、
    wordpress(または、woo commerce)のバージョンアップ更新をしたら、
    すべてがリセットされ、これらを修正した意味はなかったことになるでしょうか?

    それが嫌で、更新の度に無限に外注がかかりそうで、プログラマーに発注する気がおきません。
    (毎回毎回、wordpressのアップデートの度にプログラマーに連絡しなければならないので・・・)

    どなたかご存じの方お教えいただけますでしょうか。

    よろしくお願いいたします。

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • shokun0803

    (@shokun0803)

    mrsmith11さん、こんにちは。

    これに関しては修正する箇所によるとしか言えません。
    WordPress やテーマ、プラグインのアップデートで修正箇所がクリアされるとすれば、WordPress のコアファイルを修正した場合、公式からインストールした(アップデート可能な)テーマやプラグインそのものを修正した場合になります。

    例えば、テーマであれば子テーマを作成しその中を改修している場合、基本的にはアップデートで改修箇所がクリアされてしまうようなことは考えられません。プラグインについては、自作のプラグインで公式等からのアップデートの影響を受けない物であればクリアされることは考えにくいです。

    外注先のプログラマーさんの WordPress に対する知識が十分にあり、アップデートの影響を受けない範囲での改修を依頼するならば、WordPress やプラグイン(ここでは WooCommerce かな?)のバージョンアップで修正が無駄になるようなことはないと考えられます。

    ご参考になれば。

    改善項目のうち、「最初のサーバー応答時間を速くしてください」と「テキスト圧縮の有効化」については、どちらかというとWordPress本体よりもWebサーバー側の問題ですので、WordPressのバージョンアップで元に戻る可能性は低いと思います。

    また「使用していない JavaScript の削除」、「レンダリングを妨げるリソースの除外」、「使用していない CSS を削除してください」については、もし子テーマ等で修正が可能なのであれば、修正後に本体のバージョンアップで元に戻ることはありません。

    プログラマーに外注する際に、
    「WordPress や WooCommerce がアップデートしてもリセットされないように Google のPageSpeed Insights のスコアを向上させて欲しい」
    と委託したらいいんじゃないでしょうか。

    スレッド開始 mrsmith11

    (@mrsmith11)

    皆様ありがとうございます。参考になりました。
    一番簡単そうな、

    「WordPress や WooCommerce がアップデートしてもリセットされないように Google のPageSpeed Insights のスコアを向上させて欲しい」

    を試してみたいです。

    「テキスト圧縮の有効化」は拡張機能で対応が可能です。
    CDNサービスやキャッシュ系の拡張機能で改善する事があります。

    利用しているテーマは何方になるのでしょうか。基本的にはサーバー側の仕様とテーマ依存の要素が大きいかと思われます。
    WooCommerce デフォルトテーマであるStorefrontの場合、PageSpeed Insightsスコアは、
    スマホ = 65 程、ディスクトップ = 85 程です。
    WooCommerce専用テーマであれば、オールグリーンには可能です。
    https://pbs.twimg.com/media/EwU0jPrUYAEnZeU?format=jpg&name=large
    画像仕様
    月500円のホスティング + WordPress5.7 + WooCommerce5.0 + Elementor3.1.x 利用で商品スライダー無しです。
    利用しているテーマは宣伝になるので、ここでは申し上げれませんが、Elementor利用していなければ、
    オールグリーンにはなるかと思います。少々のカスタマイズは必要ですが。

    スレッド開始 mrsmith11

    (@mrsmith11)

    Masaki (@itanami) 様

    ありがとうございます。ちなみに、なんというプラグインになりますでしょうか?

    ifnoob (@ifnoob) 様

    情報不足で失礼いたしました。

    WooCommerceは、Shopstar!バージョン: 1.0.94
    作者: Out the Box

    WordPressの通常のブログのほうは、

    Twenty Tenバージョン: 3.2
    作者: WordPress チーム

    を使用しております。

    85点以上取れそうでしょうか?
    更新があっても影響を及ぼさず、ずっとオールグリーンを維持していただけるのでしたら、ぜひお願いしたいのですが。

    ご利用のShopstar!テーマのDemoあまりにも酷いですね。PageSpeed Insights 初期アクセスでは解析不能となりました。
    https://developers.google.com/speed/pagespeed/insights/?url=https%3A%2F%2Fdemo.outtheboxthemes.com%2Fshopstar%2F

    TwentyTenテーマ利用り方もスコアが悪いとなると、ホスティングサーバーはどちらのサーバーでしょうか?。
    ホスティングサーバーによっては、諦めるしかない状態の可能性があります。

    スコアを何点以上とか欲しいとかよく聞きますが、これはホスティングサーバーとサイト構成により、何点になるかはサイト管理者次第です。

    • この返信は6ヶ月、 2週前にifnoobが編集しました。
    スレッド開始 mrsmith11

    (@mrsmith11)

    ifnoob (@ifnoob)様

    ありがとうございます。
    Shopstar!テーマ デモではなく、テスト的に製作した私のサイトでは、モバイル45 パソコン79でした。
    商品点数が8点くらいしか登録してないので、スコアが良かったんですかね?
    トップページで採点したのですが。
    こちらは、コアサーバーを利用しております。

    Twenty Tenバージョン: 3.2 通常のWordPressのブログの方は、スコアはトップページでモバイル24 と パソコン50でした。
    GMOのI CLUSTA(アイクラスタ)を使用しております。

    いずれも、最初のサーバーへの応答時間を早くして下さい。が、いちばん分数・秒数が多いですね。

    サーバーを変えたほうがいいでしょうか?
    コアサーバーv2に移行しようと考えているのですが。

    よろしくお願いいたします。

    > Shopstar!テーマ デモではなく
    テーマは実際に構築してみないと分かりませんので、Demoがあれば普通にDemoを調べますが?。

    基本的にWooCommerceの場合商品点数が多いから遅いとはなりません。
    現に1万点商品登録があるWooCommerceサイトは普通に稼働しているようです。
    ホスティングを変えるのが一番で、後は高速化プラグインなどでの調整です。
    使用していないjavascriptとなるのは、jQuery本体だけでもそう言ったメッセージになりますので、余り気にしない方が良いかと。

    スレッド開始 mrsmith11

    (@mrsmith11)

    ありがとうございました。参考になりました。

    スレッド開始 mrsmith11

    (@mrsmith11)

    ありがとうございました。

12件の返信を表示中 - 1 - 12件目 (全12件中)
  • このトピックに返信するにはログインが必要です。