サポート » マルチサイト » 子サイトにログイン出来ません(再・・・)

  • 解決済 isamu ishikawa

    (@isamu-ishikawa)


    マルチサイト(サブディレクトリ)を作成しましたが、
    親サイトからダッシュボードに入ろうとすると「ページの自動転送設定が正しくありません」と表示されます。

    また親サイトも表示されなくなってしまい「ページの自動転送設定が正しくありません」と表示されます。

    現状は本サイトのダッシュボードはには入れる状況です。

    .htaccessへの記述は下記の通りとなります。
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    AddHandler x-httpd-php5.3 .php .phps

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    以前に失敗した際には

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    こちらの記述を削除したら直ったのですが、
    今回この部分を削除してUPしても直らない状況です。

    現在の使用環境は以下の通りです。

    エックスサーバー
    サブディレクトリ
    WordPress 4.4.4
    Firefox 47.0

    ご教授のほど宜しくお願い致します。

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • モデレーター のむらけい (Kei Nomura)

    (@mypacecreator)

    管理画面に入れるのであれば、
    設置URL/wp-admin/network/setup.php
    にアクセスすると(ネットワークの設置 ページ)、正しい設定手順が確認できます。

    その中に、

    次の内容を (設置サーバのパス) にある .htaccess ファイルへ追加して、他の WordPress ルールを置き換えてください:

    という記述があるはずです。.htaccessをこれにあわせて書き換えてみてください。

    mypacecreator 様

    ご教授ありがとうございます。

    ネットワークの設置 ページの通りに書き換えたのですが・・・
    やはり症状が一緒の状況になってしまいます。

    書き換えた内容部分は下記の通りです。

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    wp-config

    /* マルチサイト機能を実行するタグ */
    define(‘WP_ALLOW_MULTISITE’, true);  ← この部分を削除

    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, false);
    define(‘DOMAIN_CURRENT_SITE’, ‘saitamaya.cc’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    /* 編集が必要なのはここまでです ! WordPress でブログをお楽しみください。 */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

      ↓   ↓   ↓  ↓  ↓
    /* マルチサイト機能を実行するタグ */
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, false);
    define(‘DOMAIN_CURRENT_SITE’, ‘saitamaya.cc’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    /* 編集が必要なのはここまでです ! WordPress でブログをお楽しみください。 */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    .htaccess

    AddHandler x-httpd-php5.3 .php .phps

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    # END WordPress
      ↓  ↓ ↓  ↓↓  ↓↓  ↓

    AddHandler x-httpd-php5.3 .php .phps

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    # END WordPress
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    どこが悪いのでしょうか?

    まだまだ素人レベルなので具体的に記述等を教えていただくと助かります。

    宜しくお願い致します。

    mypacecreator 様 

    すいません

    もう一度チャレンジしたら子サイトは表示されました。

    しかし・・・・

    何故か親ページのTOPページが表示されずに
    「ページの自動転送設定が正しくありません」と表示されます。

    TOPページ以外は表示されます。

    表示されないページ
    http://saitamaya.cc/

    表示されるページ
    http://saitamaya.cc/denka/
    http://saitamaya.cc/figure/
    http://saitamaya.cc/brand/

    おおもとにTOPだけが表示されない現象です。

    これについてはまったく原因が分からないので・・・・

    すいません

    宜しくお願い致します。

    無事!?

    プラグインのRedirectionを無効化する事で解決しました。
    (原因自体がまだ分かってはいませんが・・・)

    mypacecreator様

    お忙しい中、回答ありがとうございました。

    Firefox で確認したんじゃないですか

    熊本地震東区避難所78日目 様

    internet explorerでもgooglechromeでも無事に表示されております。

    コメントありがとうございます。

    internet explorerでは、気が付かないかもしれませんが、他のブラウザでアクセスしたら、リダイレクトが延々と繰り返されるので、直ぐに判断ついたことですよ。

    延々とリダイレクトが繰り返される場合は、古いバージョンでは分かりませんが、FirefoxでもChromeでも、「リダイレクトループが含まれています」という表示がでて、延々とリダイレクトが繰り返されたりはしないと思います。
    つい最近、自動翻訳のパラメータを.htaccessで付与しようとした際に、FirefoxとChromeでこのメッセージが解消できずに苦労しました。

    もう解決したようですが、「ページの自動転送設定が正しくありません」というメッセージはリダイレクトループ設定自体ではなく、Cookieが原因で起きるようですよ。
    少なくともmozillaのサポートによれば。
    https://support.mozilla.org/ja/kb/websites-dont-load-troubleshoot-and-fix-errors

8件の返信を表示中 - 1 - 8件目 (全8件中)
  • トピック「子サイトにログイン出来ません(再・・・)」には新たに返信することはできません。