サポート » 使い方全般 » 投稿を編集できない

  • 解決済 riverain

    (@riverain)


    久しぶりにWordPressに記事を投稿しようとログインしたところ、 メニューの投稿(/wp-admin/edit.php)をクリックすると「この投稿タイプの投稿を編集する権限がありません。」と表示されました。

    ダッシュボードの概要で141件の投稿(/wp-admin/edit.php?post_type=post)をクリックすると、「すべて (143) | 所有 (142) | 公開済み (142) | 下書き (1)」の部分は表示されるものの、タイトル以下の部分は「投稿が見つかりませんでした。」と表示されました。

    ダッシュボードの下書きに表示されているタイトル(/wp-admin/post.php?post=1104&action=edit)をクリックするとで「この投稿タイプの投稿を編集する権限がありません。」と表示されました。

    投稿記事自体は表示されていますが編集しようとすると「この投稿タイプの投稿を編集する権限がありません。」と表示され編集できません。

    前回投稿した2017/03/30には問題なく投稿編集出来ていました。この時点から現在まで自動更新でアップデートされたくらいしかWordPressの更新はしていません。

    正常に編集するための対処方法をご教示ください。

    サーバーOS CentOS 7
    RDBMS MySQL 5.7.18
    WEBサーバー Apache/2.4.26 (Unix) OpenSSL/1.0.2l HTTP/2 で運用
    PHP 7.0.20

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • ほぼ同じ環境(こちらはさくらのVPSでKUSANAGI)で、私もほぼ同じ状況に遭遇しました。こちらで確認できたのはダッシュボードへログイン後

    ・過去の投稿・ページが表示されない
    ・既存の投稿・ページが編集できない
    ・投稿やページの新規作成画面で「公開」ボタンなどが表示されない
    ・その他、いくつかの設定画面で「権限がありません」のようなメッセージが表示される
    ・それ以外は正常に動作しており、サイト自体は問題なく表示され、フォームから送信された内容もメールで届く

    で、別のさくらのVPS環境(こちらもKUSANAGI)でも全く同じ状況でした。

    実はどちらも昨日、CentOSをアップデートしたあとから上記の状況になったので、シェルでこのアップデートを取り消す( # yum history undo ○○ )ことで、どちらも正常に動作するようになりました。

    この情報がお役に立てばなによりです。

    返信ありがとうございます。

    下記コマンドで正常に編集出来ていた時点までロールバックしてみたのですが、状況は変わらず「この投稿タイプの投稿を編集する権限がありません。」、「投稿が見つかりませんでした。」と表示され編集ができませんでした。これで仮に編集できるようになってもセキュリティ的に問題がありますが…。

    # yum history rollback id

    • この返信は2 年、 2 ヶ月前に  riverain さんが編集しました。

    まったく違う環境ですが、私も同様のトラブルに見舞われましたのでご参考までに。

    《サーバ環境》

    • Ubuntu 14.04.5 LTS
    • Apache 2.4.26
    • PHP 7.0.20
    • MariaDB 10.1.24

    私の場合(初歩的なミスですが……)PHP 7.0にもかかわらず /etc/apache2/mods-enabled/ 内に php7.0.conf, php7.0.load がなかったのが原因でした。フロント側からは問題なく表示できていたので気付くまでに時間がかかったというわけです。

    ということで

    sudo a2dismod php5.6
    sudo a2enmod php7.0
    sudo /etc/init.d/php7.0-fpm restart
    sudo service apache2 restart

    で問題の事象が解決しました。

    返信ありがとうございます。

    ApacheのPHP関連の設定は下記の様に設定しています。
    phpinfo()でもPHP Version 7.0.20になっているので多分大丈夫なはず。

    /usr/local/apache2/conf/httpd.conf

    LoadModule proxy_module modules/mod_proxy.so
    LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so

    #php
    <IfModule prefork.c>
    LoadModule php7_module modules/libphp7.so
    </IfModule>

    DirectoryIndex index.php index.html
    <FilesMatch \.php$>
    SetHandler “proxy:fcgi://127.0.0.1:9000”
    </FilesMatch>

    Apache 2.4.26 で ProxyFCGIBackendType Directive が追加されたのが原因でした。
    /usr/local/apache2/conf/httpd.conf に
    ProxyFCGIBackendType GENERIC を追加すると編集可能になりました。

    参考サイト
    mod_proxy_fcgi – Apache HTTP Server Version 2.4 ProxyFCGIBackendType Directive https://httpd.apache.org/docs/2.4/en/mod/mod_proxy_fcgi.html#proxyfcgibackendtype

    Topic: Invalid post type. « WordPress.org Forums https://wordpress.org/support/topic/invalid-post-type-7/

    Revisions to Wrong SCRIPT_FILENAME in Apache 2.4.26 – Stack Overflow https://stackoverflow.com/posts/44657409/revisions

5件の返信を表示中 - 1 - 5件目 (全5件中)
  • トピック「投稿を編集できない」には新たに返信することはできません。