サポート » 使い方全般 » 投稿・固定ページの投稿ボタンをおすと、即座にTOPにリダイレクトされるようになりました

  • 解決済 小石

    (@kohetraiscojp)


    曖昧な内容で申し訳ありません。
    先日、「4.9.9」で運営していたマルチサイトが急に投稿できなくなった、という相談をうけました。
    具体的には、記事や投稿の本文に「style=”~”」のタグや「<tbody>」のタグがある場合に限り(<table>は大丈夫)、編集画面から下書き保存もプレビューも投稿もできず、ボタンを押すと即座にトップページにリダイレクトされる、というものでした。4つある子サイトすべて同じ状態です。
    逆にどんな長文でも、上記のタグがなければ問題なく動作しました。

    新規だけでなく既存のページも同様で、上記内容があるページについては修正が反映されない(プレビューや更新ボタンを押すとリダイレクトされる)という状況です。
    また、今回の件と関連するか不明ですが、「メディアを追加」ボタンで画像を挿入しようと試みると、アップロード・メディアライブラリ追加までは動きますが、ページへの挿入は動きませでした。

    いつからこうなったかは誰も把握していないということですが、その間、プラグインのアップデートとWPの自動更新はあったようです。
    GutenbergやClassicEditorも入れておらず、そのかわり他のプラグインは最新です。

    やったこと
    1.プラグイン全オフ→効果なし
    2.テーマをTwenty Seventeenに→効果なし
    3.パーマリンクをデフォルトに→効果なし
    4.マルチサイトの子サイトをふやして検証→同じ現象発生
    5..htaccessを初期のものに→効果なし
    6.デバッグモードオンに→リダイレクトの瞬間は特に出力なし
    7.WPを手動で4.9.10にアップデート→効果なし
    8.PHPのメモリやアップロード上限、MySQLのパケット上限を拡大→効果なし

    なにぶん初めて見る症状で、エディタ系の異常か、サーバが何かに反応してリダイレクトしているか、と推測していますが手詰まりになっています。
    このような動作の場合、どういった可能性がありそうでしょうか。もし似たケースの解消例やヒントを頂ければ幸甚です。
    よろしくお願い致します。

    • このトピックは 小石が7 ヶ月前に変更しました。
    • このトピックは 小石が7 ヶ月前に変更しました。
5件の返信を表示中 - 16 - 20件目 (全20件中)
  • 小石

    (@kohetraiscojp)

    CG様、ありがとうございます。
    先刻、別のサーバにAll-in-One WP Migrationを使ってマルチサイトごとインストールしたところ、
    環境の違いが大きいのか、サイトとしては色々と不完全な動作をしていましたが、
    表題のTOPへのリダイレクトは発生しませんでした。

    CG

    (@du-bist-der-lenz)

    〈「メディアを追加」ボタンで画像を挿入しようと試みると、アップロード・メディアライブラリ追加までは動きますが、ページへの挿入は動きませでした。〉であるとか、〈「style=”~”」のタグ〉であるとか、ヒントはありますよ。

    小石

    (@kohetraiscojp)

    CG様、ありがとうございます。
    エディター周りの動作不具合では、以前
    WP_PROXY_PORTの設定などで解決したり、
    admin-ajax.phpのエラーから解消したことはりますが、
    お恥ずかしながら今回はその種の手がかりも私には見つけられず、
    手詰まりになっております…。

    小石

    (@kohetraiscojp)

    大変時間が空いてしまい申し訳ありません、こちらの件ですが、
    結果としてWAFによるものではという事になりまして、動作を停止できるタイミングを
    見計らって検証することになりました。
    いろいろとアドバイスを頂いたにもかかわらず、外的要因ということになりそうで
    申し訳ありませんでした。
    お騒がせいたしました。

    CG

    (@du-bist-der-lenz)

    別のサーバに複製したら、課題は起こらなかった。わけですからね。

5件の返信を表示中 - 16 - 20件目 (全20件中)
  • このトピックに返信するにはログインが必要です。