サポート » プラグイン » 携帯電話からの投稿&メールからの投稿

  • esports_hige

    (@esports_hige)


    初歩的な質問なのかもしれませんがご容赦ください。

    携帯からの投稿、そしてできれば携帯からメールでの投稿を実現したいと考えています。

    WP-shot や Ktai-entry 等
    調べれる限りでインストールしてみたのですが、
    アドレス登録やPOP3設定を行っても全く投稿が成功しません。

    ロジックは

    携帯メール→投稿用メール→WP側POP3設定により受信(携帯メールアドレスにより判断)→投稿完了

    この流れだと認識しています。

    投稿用アドレスはGmailを使用しようと考え設定をしました。

    何が問題として考えられますでしょうか?
    もし検討がつかれるかたが見えましたらご教授いただければと思います。

    よろしくお願いいたします。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • モデレーター IKEDA Yuriko

    (@lilyfan)

    Ktai Entry 作者です。

    何が問題として考えられますでしょうか?
    もし検討がつかれるかたが見えましたらご教授いただければと思います。

    これだけでは情報が足りなくて、トラブルシューティングの一般的手法を解説するしかありません。

    まず、メール投稿の設定内容を確認してください。wp-shot, Ktai Entry ともに、POP の設定内容を WordPress の管理パネル「投稿設定」に記載する必要があります。Ktai Entry の附属ドキュメントに Gmail の設定方法が書いてあるので参考にしてみてください。

    次に、使用している携帯電話の機種。送信しているメールの種類や作成手順 (文字だけのメールか、写真つきメールか、デコメールの類いか) などを教えてください。

    それから、WordPress を設置しているサーバーの情報 (レンタルサーバーなら業者名やサービスの名称) も必要です。少なくとも PHP のバージョンは知りたいです。レンタルサーバーではなく、自宅サーバーや組織内に置いてあったりする場合は、ネットワーク構成も必要でしょう (プロキシー内部にあったりして POP アクセスがブロックされている可能性があるため)。

    Ktai Entry には、動作ログを取る機能がありますので、これを有効にして確認する手もあります。やり方については附属ドキュメントをよく読んでみてください。

    トピック投稿者 esports_hige

    (@esports_hige)

    作者様

    早々のご回答ありがとうございます。
    もう一度、設定方法等を見直して実施してみます。

    サーバーは会社のサーバーになります。ハウジングされています。
    PHPのバージョンは管理者に聞いてみないとわからない為、
    もう一度実施し難しいようであれば、情報をもって質問させていただきます。

    メールの作成手順手しましては
    ノーマルな文章に添付ファイル(写メで撮った写真)をつけて
    Gmailへ送信しました。

    トピック投稿者 esports_hige

    (@esports_hige)

    もう一度、プラグインのインストールを試みました。
    管理画面にて下記のメッセージが出ています。

    重大なエラーを引き起こしたのでプラグインの有効化はできませんでした。
    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/blog/tomida/wp-content/plugins/ktai_entry/ktai_entry.php on line 68

    PHPのバージョンが低いということですね。
    一度、明日管理者にバージョンアップが可能かを問い合わせてみます。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    サーバーは会社のサーバーになります。ハウジングされています。

    そのウェブサーバーは、メールサーバーと別マシンですか? 同じマシンですか? また、ウェブサーバーから外部 (Gmail 等) への POP アクセスは許可されていますか?

    POP が許可されていないと、Gmail からのメール読み出しはできません。逆に、ウェブサーバーとメールサーバーが同居しているならば、「メール着信による投稿スクリプト起動」の方法が使えるかもしれません。この設定は少し高度なため、サーバー管理者と相談してみてください。

    PHP のバージョンについては、できれば PHP 5.2.8 にすることをおすすめします。PHP 4.x 系統は、もはやサポートされていないので、使うのは避けた方がよいです (OS のディストリビューションによっては、PHP 4.x 系統での独自にセキュリティーパッチを当てていることもありますが)。

    トピック投稿者 esports_hige

    (@esports_hige)

    PHPのバージョンですが、4.3.8だそうです。5.2以上へのバージョンアップが可能かを確認したところ、他の仕様に影響を及ぼす為、出来ないとの回答でした。残念ながらKtai Entryは難しいとの結論になりました。ご返答ありがとうございました。

    他に現状のバージョンでメール投稿が可能なプラグインをご存知の方がおみえになりましたらお教えいただけますと幸いです。

    モデレーター IKEDA Yuriko

    (@lilyfan)

    PHPのバージョンですが、4.3.8だそうです。5.2以上へのバージョンアップが可能かを確認したところ、他の仕様に影響を及ぼす為、出来ないとの回答でした。

    うーん。4.4.9 ならともかく、4.3.x 系統というのは頂けませんね……。OS やディストリビューションが不明なので、あながち「セキュリティーが低い」とは言えないですが、PHP5 が登場して3年以上になるのに、いまだに PHP5 の動作確認ができていないというのは、開発能力および危機管理能力が「やばい」と思います (もし、PHP 4 に特大セキュリティホールが出たらサービス停止のおそれがあるため)。

    今年中に、PHP5 への移行を図るよう、スケジュールを組む必要があるでしょう。どうせ移行するならば、PHP 5.3 が出てからの方がいいでしょうから、PHP 5.3 のリリースに合わせて準備するのがよいと思います。このへんは、esports_hige さん自身も PHP 業界の動向を調べて、社内の開発陣にコンタクトを取ってみてください (余計な仕事が増えて大変??)。

    他に現状のバージョンでメール投稿が可能なプラグインをご存知の方がおみえになりましたらお教えいただけますと幸いです。

    社外への POP アクセス (110 ポートでの通信および POP3 プロトコル) が通るならば、wp-shot (の最新版 0.4 系統) が比較的マトモでしょう。

    もし POP がブロックされていると、他に使えるツールはかなり少ないです。拙作の wp-mta もしくは、wp-mb_mail の STDIN 対応版ぐらいしかないです。

    トピック投稿者 esports_hige

    (@esports_hige)

    ご回答ありがとうございます。
    お恥ずかしい限りです…。開発者側と調整をし進めてみます。ご助言ありがとうございます。

    wp-shotも、もう一度試してみます。
    POP3プロトコルは問題ないそうです。
    Gmailで行う際の設定は、KtaiEntryと同じで良いんですよね。
    頑張って設定してみます。

    ありがとうございました。

7件の返信を表示中 - 1 - 7件目 (全7件中)
  • トピック「携帯電話からの投稿&メールからの投稿」には新たに返信することはできません。