自宅サーバですかね?
OpenSSLをアップデートしてみてはどうでしょう。
npssl様
ご連絡ありがとうございます。
自宅サーバではなくて、
結構有名何処のサーバのVPSを借りています。
サーバ会社にいま問い合わせしておりますが、
まだ返答は来ていません。
自宅サーバでは全く問題はないのですが
SSLはつかっていないと思うのですが。
SSLはつかっていないと思うのですが。
WordPress.orgのサーバに対して、更新を確認する際などはすべてTLSによる暗号化が行われています。
WordPress 4.4では古いOpenSSLのバージョンとの組み合わせでこのような問題が生じるという報告がコアで上がっており、WordPress側でこの問題に対応することになりました。
今後リリースされるWordPress 4.5以降および4.4.1以降ではすでに対策が完了しています。
こちらのファイルをwp-includes/certificates/ca-bundle.crtに上書きしてみてください。(必ずバックアップを!)
それで解決したら、OpenSSLのバージョンが原因です。(≒サーバ側の問題)
Daisuke Takahashi様
ご連絡ありがとうございます。
なるほどですね。
一度、上書きをかけてみます。
ご丁寧にありがとうございます。
結果はまたご報告入れます。
入れ替えて実行しましたがやはりダメみたいです。
ーー
An error occurred while updating PS Auto Sitemap:
ダウンロードに失敗しました。 error:0D0890A1:asn1 encoding routines:func(137):reason(161)
ーー
# which openssl
/usr/bin/openssl
# openssl version
OpenSSL 0.9.7a Feb 19 2003
みなさんいろいろありがとうございます。
レンタルサーバ屋さんよりご連絡を頂きました。
PHPのバージョンとOpenSSLのバージョンが低いためだそうです。
PHP 5.3.15
OpenSSL 0.9.7a Feb 19 2003
でも、VPSなので自力でアップをするか、
WPのファイルを書き換えるかどちらかが必要だそうです。
VPSのレンタルサーバ屋さんはこれをしてくれないようなのですが。。;
ーー
弊社にて動作確認済みの3.9.1より
バージョンアップした場合に多く不具合のお問い合わせをいただいております。
調査いたしました結果、対処方法が確認できましたので、ご報告させていただきます。
wordpressのエラーにつきましては、ご利用サーバー内のOpenSSLバージョンや
PHPモジュールのバージョンなどが、ダウンロード先のwordpress.orgの許可する
HTTPS接続セキュリティに達していないために起きております。
しかしながら、現状ご利用サーバーではOpenSSLやPHPバージョンアップの計画がございません。
その為、wordpress.orgに対して、HTTP接続でダウンロード可能となるように、
WordPress側のプログラムファイルを変更する方法をご提案させていただきます。
変更するプログラムファイル
WordPressディレクトリの中にある「wp-includes」ディレクトリ内の「class-http.php」
標準搭載のWordPressであれば、以下のディレクトリ内に該当ファイルがございます。
/www/htdocs/wp/wp-includes
変更内容:class-http.php(140行目前後)
【変更前】
‘sslverify’ => true,
【変更後】
‘sslverify’ => false,
※注
上記の「class-http.php」は、WordPress更新時に上書きされるファイルの為、
一度プログラム更新作業を行った後は、再度同じ修正が必要になります。
ーー
WPを実装してレンタルしているのなら、
このぐらいのサポートはやっていただけてもいいかと思うのです。
またご連絡します。
VPSを使っているのであればサービス事業者は顧客のデータを弄ることはしません。(VPS自体がそういうサービスなので。)
必要なメンテナンスなども利用者が自分で責任を負い、自分で行う必要があります。
それが難しいのであれば、root権限などのない、普通のレンタルサーバに移行するのがいいかと思います。
Daisuke Takahashi 様
ご回答ありがとうございます。
VPSはもう8年ほど使っておりますが、
レンタルサーバ屋がマシンを交換との希望で
3ヶ月ほど前に新サーバに乗り換えました。
そのレンサバにはWPのインストール等が設置されています。
なので、
その新サーバはみなOSなどが古いわけで、今回のアップデートをしないとならないのか?
とあたまをひねってるわけですが、
そういうものなのでしょうか?
ホスティング事業者とどういう契約で交換したのかにもよりますが、普通、サーバのソフトウェアや設定などをデフォルトの状態から変更するのは利用者がすることですね。
あと、おそらく検証ということで一時的に変更したのかとは思いますが、誰でも見れる場所なので、一応書いておきます。
パーミッションを777にして運用するのは非常に危険です。
詳しくはCodexを参照していた誰場と思いますが、適切なパーミッションを指定して運用してください。
ファイルパーミッションの変更 – WordPress Codex 日本語版