• お世話になります。
    投稿から新規投稿をクリックすると真っ白い画面にこのようなエラーメッセージになることがあります。
    ——————————————-
    You are not autorised to delete posts in this category.
    ——————————————-

    権限は、編集者で投稿しても、管理者で投稿しても同じで、
    しかもエラーが出るのが不定期というか、規則が見つけられなくて困っています。
    今はうまく投稿できてるのですが、
    今日は何回かそのようなエラーになりました。

    ダッシュボードの右側にある、クイック投稿では大丈夫です。

    あと、何を情報として書けばいいでしょうか・・・。
    エラーメッセージそのもので検索しても日本の記事がヒットしません。
    autorisedという単語が間違っているのか?autorised単体だけで検索すると記事がまったくヒットしません。

    入れている主なプラグインは下記です

    Allow Categories(WordPressのカテゴリーに対してアクセス制限するためのプラグイン)
    http://wordpress.org/extend/plugins/allow-categories/
    解説ページ
    http://web.level-k.jp/wordpress/plugin/web874.html

    theme-my-login(会員登録したあとのログイン画面を管理する)
    http://wordpress.org/extend/plugins/theme-my-login/
    解説ページ 
    http://design-cupola.com/archives/post/theme-my-login-ja

    Subscribe2(投稿記事のお知らせメールやメルマガを送る)
    解説
    http://tenderfeel.xsrv.jp/wordpress/99/#sb2

    カテゴリは、お知らせと会員用という2つのカテゴリが作ってあり
    会員用というカテゴリに投稿すると、ログインしている場合にしか表示されないようにしています。

    今日何回もエラーが出ていて、今投稿しようとしたらエラーが出なかったという・・・
    どんな状態の時にこうなるのかさえまだわからないんですが
    原因をさぐる方法についてでもいいのでアドバイスいただけないでしょうか。

6件の返信を表示中 - 1 - 6件目 (全6件中)
  • トピック投稿者 piyoyo33

    (@piyoyo33)

    こちらの件、まだ困っています。

    いろんなプラグインを外してみても不定期に出るし、
    最後の手・・と思って
    別サーバーに最新版をインストールして、同じ状態にしたところ
    また不定期にこのメッセージが出ます。

    http://enscilab.sakura.ne.jp/wp-admin/post-new.php
    真っ白画面で下記の一行だけ

    You are not autorised to delete posts in this category.

    特定のブラウザでもないし、特定のIPからの投稿でもないし
    特定の権限でもないです(管理者アカウントでも編集者アカウントでも出る)
    で、そのままブラウザの戻るボタンで戻って、
    ダッシュボードに一度入ってから、新規投稿すると出ないこともあります。

    どこかに事例はのってないでしょうか・・・。

    ほとほと困っています・・・

    autorised は authorised のタイプミスじゃないですかね?

    要するに「そのカテゴリ内の投稿を編集する権限がありません」という事だと思います。

    原因として一番怪しいのが Allow Categories ですね。

    piyoyo33さんがお使いの WordPress やプラグインのバージョンが解りませんが、単純に対応していない可能性があります。プラグインのページでは WordPress 3.0.1 の段階でプラグインの最新版の 0.66 が動作しないという方が3人おられますよ。

    プラグインを外しても症状が出るという事ですが、もしこのプラグインが特定のタグや情報をデータベースに書き込むタイプのプラグインだった場合、このプラグインが上手く動作しないと原因不明のエラーがでる場合があります。

    その辺の可能性を考えて原因を探ってみてください。

    トピック投稿者 piyoyo33

    (@piyoyo33)

    >Heihachiroさん
    返信ありがとうございます。

    ヒントだけでも助かります。
    英語がまちがってるみたいで翻訳もよくわからず困っていました。

    「そのカテゴリ内の投稿を編集する権限がありません」
    ということだと
    やはり、会員制サイトのように改変していることに関係がありそうですね。
    プラグインの情報を探してみます!

    こんにちは
    以下の関数が原因じゃないかと思います

    Allow Categories

    function allow_delPost($in){
    		global $wpdb;
    		$article=get_post($in);
    		$catUser = Allow_Category::allow_getCategory();
    		if (Allow_Category::allow_notAdmin()) {
    			$trouve=false;
    			if ($catUser) {
    				$cats = get_the_category($in);
    
    				foreach($cats as $ct){
    					if (in_array($ct->cat_ID,$catUser)) {
    						$trouve=true;
    						break;
    					}
    				}
    			}
    			if (!$trouve) {
    				die("You are not autorised to delete posts in this category.");
    			}
    		}
    	}
    トピック投稿者 piyoyo33

    (@piyoyo33)

    >nobitaさん
    ありがとうございます!(感涙)
    また一歩答えに近づけました・・・

    しかしながら私がPHPを読み解くのができなくて
    もし$trouveじゃなければ、終了してこのメッセージ出しなさいと
    書いてあるんですよね? ということくらいしか理解できず(汗)

    さてはて。。。どうしたものか・・。
    他の方では起こってないということは、バグじゃなくて

    Allow Categoriesの設定が間違っている可能性がありますね。
    そこから調べ直してみます。本当にありがとうございます。

    トピック投稿者 piyoyo33

    (@piyoyo33)

    アドバイスありがとうございました。

    Allow Categoriesの対応WPバージョンが2.8以下だったみたいで
    こちらは3.0の最新のをインストールしていたので
    変なエラーが出ていたようです。
    それを調べていて、WPのバグ??と不思議に思ったんですが・・・

    最新のWordPressでは、ダッシュボード >投稿 >カテゴリーをクリックすると
    edit-tags.phpが出ます。
    タグをクリックしても同じedit-tags.phpです。

    2.7の画面をみると、カテゴリーでは
    categories.phpが呼び出されます。
    タグをクリックするとedit-tags.phpが出ます。

    この件では、新規投稿をクリックしてるのにget_the_categoryのある場所に読みにいってるのが腑に落ちないんですが・・・・
    エラーメッセージも「このカテゴリーを削除する権限ありません」 とか
    何故かカテゴリーに関するエラーなんですね。

    このあたりに何かWordPressのバージョンが新しくなったことと関係があるような樹がしました。

    とりあえず、今回の件は
    バージョンダウンをしてみるか、
    ただしバージョンダウンしちゃうと3.0で出てきた新機能も使っているのでそれをあきらめなければいけないので、
    もしくは、Allow Categoriesでやっていること(ログインしている人だけに見せるカテゴリーを限定するプラグイン)
    別の方法でできるか探してみたいと思います。

6件の返信を表示中 - 1 - 6件目 (全6件中)

トピック「新規投稿時に、You are not autorised to delete posts in this category.と不定期に出る」には新たに返信することはできません。